]> git.pld-linux.org Git - packages/ccache.git/blame_incremental - ccache.spec
- up to 3.2.3
[packages/ccache.git] / ccache.spec
... / ...
CommitLineData
1Summary: Compiler cache
2Summary(pl.UTF-8): Pamięć podręczna dla kompilatora
3Summary(pt_BR.UTF-8): Cache para compiladores C/C++
4Name: ccache
5Version: 3.2.3
6Release: 1
7License: GPL v3
8Group: Development/Tools
9Source0: https://www.samba.org/ftp/ccache/%{name}-%{version}.tar.xz
10# Source0-md5: 608c78632086a4a051514722d6067a7b
11URL: http://ccache.samba.org/
12BuildRequires: automake
13BuildRequires: tar >= 1:1.22
14BuildRequires: xz
15BuildRequires: zlib-devel >= 1.2.3
16BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18%define _libdir %{_prefix}/%{_lib}/%{name}
19
20%description
21ccache is a compiler cache. It acts as a caching pre-processor to
22C/C++ compilers, using the -E compiler switch and a hash to detect
23when a compilation can be satisfied from cache. This often results in
24a 5 to 10 times speedup in common compilations.
25
26%description -l pl.UTF-8
27ccache to pamięć podręczna dla kompilatora - działa jako cachujący
28preprocesor dla kompilatorów C/C++, wykorzystujący opcję kompilatora
29-E oraz tablicę haszującą do wykrywania, czy do kompilacji wystarczy
30zawartość pamięci podręcznej. Daje to zazwyczaj przyspieszenie
31kompilacji 5 do 10 razy.
32
33%description -l pt_BR.UTF-8
34ccache é um cache para compiladores. Ele funciona mantendo um cache de
35pré-processamento para compiladores C/C++ utilizando-se do parâmetro
36- -E e de um hash para detectar quando uma compilação pode ser
37 reaproveitada de um cache armazenado em disco. O ganho de tempo em
38 compilações comuns pode chegar a uma escala de até 10 vezes em relação
39 ao tempo normal.
40
41%package wrapper
42Summary: Symlinks for c++/cc/g++/gcc
43Summary(pl.UTF-8): Dowiązania symboliczne do c++/cc/g++/gcc
44Group: Development/Tools
45Requires: %{name} = %{version}-%{release}
46
47%description wrapper
48This package contains the softlinks to ccache for each compiler.
49
50%description wrapper -l pl.UTF-8
51Ten pakiet zawiera dowiązania symboliczne do ccache dla każdego
52kompilatora.
53
54%prep
55%setup -q
56
57# Make sure system zlib is used
58%{__rm} -r zlib
59
60%build
61cp -f /usr/share/automake/config.* .
62CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
63%configure
64
65%{__make}
66
67%install
68rm -rf $RPM_BUILD_ROOT
69install -d $RPM_BUILD_ROOT/etc/env.d
70
71%{__make} install \
72 DESTDIR=$RPM_BUILD_ROOT
73
74for X in CCACHE_DIR CCACHE_TEMPDIR CCACHE_LOGFILE CCACHE_PATH CCACHE_CC CCACHE_PREFIX \
75 CCACHE_DISABLE CCACHE_READONLY CCACHE_CPP2 CCACHE_NOSTATS CCACHE_NLEVELS \
76 CCACHE_HARDLINK CCACHE_RECACHE CCACHE_UMASK CCACHE_HASHDIR CCACHE_UNIFY \
77 CCACHE_EXTENSION CCACHE_NOHASH_SIZE_MTIME
78do
79 echo "#${X}=\"\"" > $RPM_BUILD_ROOT/etc/env.d/${X}
80done
81
82install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},/etc/profile.d}
83for cc in cc c++ g++ gcc %{_target_cpu}-pld-linux-gcc %{_target_cpu}-pld-linux-g++; do
84 ln -s ../../bin/%{name} $RPM_BUILD_ROOT%{_libdir}/$cc
85done
86echo 'export PATH=%{_libdir}:$PATH' > \
87 $RPM_BUILD_ROOT/etc/profile.d/%{name}.sh
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%files
93%defattr(644,root,root,755)
94%doc AUTHORS.txt MANUAL.txt NEWS.txt README.txt
95%attr(755,root,root) %{_bindir}/ccache
96%{_mandir}/man1/ccache.1.*
97%config(noreplace,missingok) %verify(not md5 mtime size) /etc/env.d/CCACHE_*
98
99%files wrapper
100%defattr(644,root,root,755)
101%attr(755,root,root) /etc/profile.d/%{name}.sh
102%dir %{_libdir}
103%attr(755,root,root) %{_libdir}/c++
104%attr(755,root,root) %{_libdir}/cc
105%attr(755,root,root) %{_libdir}/g++
106%attr(755,root,root) %{_libdir}/gcc
107%attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-g++
108%attr(755,root,root) %{_libdir}/%{_target_cpu}-pld-linux-gcc
This page took 0.078249 seconds and 4 git commands to generate.