]> git.pld-linux.org Git - packages/cassandra-bin.git/blame - cassandra-bin.spec
- Version 1.0.10-1.
[packages/cassandra-bin.git] / cassandra-bin.spec
CommitLineData
4e6d3cb2 1# TODO: Fix .init cassandra status does not work now.
16c24e02
MK
2# TODO: Fix .init stop routine it is now subset of PLD default one
3# TODO: Fix of data/ cassandra created dirs/files privilages (now they are all readable)
f60c3231 4# TODO: Consider adding
4e6d3cb2 5# cassandra - memlock unlimited
16c24e02 6# to /etc/security/limits.conf ?
3f05bde6 7
4e6d3cb2 8%define shname cassandra
f60c3231 9%include /usr/lib/rpm/macros.java
087ae4ed 10Summary: Cassandra database binary package
4e6d3cb2 11Summary(pl.UTF-8): Binarna redystrybucja bazy danych Cassandra
087ae4ed 12Name: cassandra-bin
e128f9c8 13Version: 1.0.10
b5445178 14Release: 1
3f05bde6
MK
15License: ASF
16Group: Applications/Databases
e128f9c8
MK
17# http://www.idg.pl/mirrors/apache/cassandra/1.0.10/apache-cassandra-1.0.10-bin.tar.gz
18Source0: http://www.idg.pl/mirrors/apache/cassandra/%{version}/apache-cassandra-%{version}-bin.tar.gz
19# Source0-md5: e17cf13d09a3e9325d6b4e7f4ae26862
087ae4ed
MK
20Source1: cassandra.in.sh
21Source2: %{shname}.init
687fc4b6 22Source3: %{name}.tmpfiles
40af29a9 23Patch0: %{name}-jamm_path_fix.patch
3f05bde6
MK
24URL: http://cassandra.apache.org/
25BuildRequires: rpm-javaprov
26BuildRequires: rpmbuild(macros) >= 1.300
f60c3231
ER
27Requires(post,preun): /sbin/chkconfig
28Requires: rc-scripts
dd8de5bc 29Suggests: java-jna
3f05bde6
MK
30BuildArch: noarch
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
087ae4ed
MK
34Cassandra brings together the distributed systems technologies from
35Dynamo and the data model from Google's BigTable. Like Dynamo,
36Cassandra is eventually consistent. Like BigTable, Cassandra provides
37a ColumnFamily-based data model richer than typical key/value systems.
3f05bde6
MK
38
39%description -l pl.UTF-8
4e6d3cb2
TP
40Cassandra łączy technologie systemów rozproszonych z Dynamo i model
41danych z googlowskiego BigTable. Tak jak Dynamo, Cassandra jest
087ae4ed 42ostatecznie spójna. Tak jak BigTable daje do dyspozycji model danych
4e6d3cb2 43oparty na ColumnFamily, bogatszy niż typowe systemy klucza i wartości.
3f05bde6
MK
44
45%prep
b51a24b8 46%setup -q -n apache-cassandra-%{version}
40af29a9 47%patch0 -p1
3f05bde6 48
3f05bde6
MK
49%install
50rm -rf $RPM_BUILD_ROOT
4e6d3cb2 51install -d $RPM_BUILD_ROOT{/etc/rc.d/init.d/,%{_sysconfdir}/%{shname},%{_bindir},%{_sbindir},%{_datadir}/%{shname}} \
687fc4b6
JR
52 $RPM_BUILD_ROOT/var/{lib/%{shname}/{commitlog,conf,data,saved_caches},{log,run}/%{shname}} \
53 $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
4e6d3cb2 54
3f05bde6 55install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/cassandra
7d92ab98 56cp -p bin/{*sstable*,*tool,cassandra-cli} $RPM_BUILD_ROOT%{_bindir}
4e6d3cb2
TP
57cp -p bin/cassandra $RPM_BUILD_ROOT%{_sbindir}
58cp -p %{SOURCE1} lib/*.jar $RPM_BUILD_ROOT%{_datadir}/%{shname}
59cp -p conf/{*.properties,cassandra-env.sh,cassandra.yaml,README.txt} $RPM_BUILD_ROOT/var/lib/%{shname}/conf
3f05bde6 60
687fc4b6
JR
61install %{SOURCE3} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{shname}.conf
62
3f05bde6
MK
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%pre
3f05bde6
MK
67%groupadd -g 259 -r cassandra
68%useradd -M -o -r -u 259 -d /var/lib/%{shname} -s /bin/sh -g cassandra -c "Cassandra Server" cassandra
69
f60c3231
ER
70%post
71/sbin/chkconfig --add cassandra
72%service cassandra restart
73
3f05bde6
MK
74%preun
75if [ "$1" = "0" ]; then
f60c3231
ER
76 %service cassandra stop
77 /sbin/chkconfig --del cassandra
3f05bde6
MK
78fi
79
3f05bde6
MK
80%files
81%defattr(644,root,root,755)
82%doc CHANGES.txt LICENSE.txt README.txt NEWS.txt NOTICE.txt
83%attr(754,root,root) /etc/rc.d/init.d/cassandra
84%attr(755,root,root) %{_bindir}/cassandra-cli
85%attr(755,root,root) %{_bindir}/nodetool
7d92ab98 86# %attr(755,root,root) %{_bindir}/clustertool
3f05bde6
MK
87%attr(755,root,root) %{_bindir}/json2sstable
88%attr(755,root,root) %{_bindir}/sstable2json
7d92ab98
MK
89%attr(755,root,root) %{_bindir}/sstableloader
90# %attr(755,root,root) %{_bindir}/schematool
91# %attr(755,root,root) %{_bindir}/config-converter
3f05bde6
MK
92%attr(755,root,root) %{_bindir}/sstablekeys
93%attr(755,root,root) %{_sbindir}/cassandra
087ae4ed 94%{_datadir}/%{shname}
687fc4b6 95/usr/lib/tmpfiles.d/%{shname}.conf
3f05bde6
MK
96%attr(750,cassandra,cassandra) %dir /var/lib/%{shname}
97%attr(750,root,cassandra) %dir /var/lib/%{shname}/conf
087ae4ed
MK
98%attr(640,root,cassandra) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{shname}/conf/*.properties
99%attr(755,root,cassandra) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{shname}/conf/*.sh
3f05bde6 100%attr(640,root,cassandra) /var/lib/%{shname}/conf/*.txt
087ae4ed 101%attr(640,root,cassandra) %config(noreplace) %verify(not md5 mtime size) /var/lib/%{shname}/conf/*.yaml
3f05bde6 102%attr(750,cassandra,cassandra) %dir /var/log/%{shname}
4e6d3cb2 103%attr(750,cassandra,cassandra) %dir /var/run/%{shname}
This page took 0.051986 seconds and 4 git commands to generate.