]> git.pld-linux.org Git - packages/cas.git/blob - cas.spec
354004d8db46cfc9561a0f3695e4842055fd863a
[packages/cas.git] / cas.spec
1 #
2 # TODO:
3 # - package all $MODULES
4 # - subpackages for modules
5 # - fix tomcat path
6 %include        /usr/lib/rpm/macros.java
7 Summary:        JA-SIG Central Authentication Service
8 Name:           cas-server
9 Version:        3.3.5
10 Release:        0.1
11 License:        MIT License
12 Group:          Networking/Daemons/Java/Servlets
13 Source0:        http://www.ja-sig.org/downloads/cas/%{name}-%{version}-release.tar.gz
14 # Source0-md5:  c12594a2af98ee2dd11a8c97895d91af
15 Source1:        %{name}-context.xml
16 URL:            http://www.ja-sig.org/products/cas/
17 BuildRequires:  jpackage-utils
18 BuildRequires:  rpm-javaprov
19 BuildRequires:  rpmbuild(macros) >= 1.300
20 Requires:       jpackage-utils
21 Requires:       tomcat >= 6
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %define webappdir %{_datadir}/%{name}
26 %define libdir    %{_datadir}/%{name}/WEB-INF/lib
27
28 %description
29 CAS is an authentication system originally created by Yale University
30 to provide a trusted way for an application to authenticate a user.
31 CAS became a JA-SIG project in December 2004.
32
33 CAS provides enterprise single sign on service: CAS Downloads
34
35     - An open and well-documented protocol
36     - An open-source Java server component
37     - A library of clients for Java, .Net, PHP, Perl, Apache, uPortal, and
38       others
39     - Integrates with uPortal, BlueSocket, TikiWiki, Mule, Liferay, Moodle
40       and others
41     - Community documentation and implementation support
42     - An extensive community of adopters
43
44 %package authenticator-spnego
45 Summary:        Spnego authenticator for CAS server
46 Requires:       %{name} = %{version}-%{release}
47 Group:          Libraries/Java
48
49 %description authenticator-spnego
50
51 %package authenticator-x509
52 Summary:        x509 authenticator for CAS server
53 Requires:       %{name} = %{version}-%{release}
54 Group:          Libraries/Java
55
56 %description authenticator-x509
57
58 %package authenticator-openid
59 Summary:        OpenID authenticator for CAS server
60 Requires:       %{name} = %{version}-%{release}
61 Group:          Libraries/Java
62
63 %description authenticator-openid
64
65 %package authenticator-legacy
66 Summary:        Legacy authenticator for CAS server
67 Requires:       %{name} = %{version}-%{release}
68 Group:          Libraries/Java
69
70 %description authenticator-legacy
71
72 %package authenticator-radius
73 Summary:        Radius authenticator for CAS server
74 Requires:       %{name} = %{version}-%{release}
75 Group:          Libraries/Java
76
77 %description authenticator-radius
78
79 %package authenticator-ldap
80 Summary:        LDAP authenticator for CAS server
81 Requires:       %{name} = %{version}-%{release}
82 Group:          Libraries/Java
83
84 %description authenticator-ldap
85
86 %package authenticator-generic
87 Summary:        Generic authenticator for CAS server
88 Requires:       %{name} = %{version}-%{release}
89 Group:          Libraries/Java
90
91 %description authenticator-generic
92
93 %package authenticator-trusted
94 Summary:        Trusted authenticator for CAS server
95 Requires:       %{name} = %{version}-%{release}
96 Group:          Libraries/Java
97
98 %description authenticator-trusted
99
100 %package authenticator-jdbc
101 Summary:        JDBC authenticator for CAS server
102 Requires:       %{name} = %{version}-%{release}
103 Group:          Libraries/Java
104
105 %description authenticator-jdbc
106
107 %package integration-berkeleydb
108 Summary:        Berkeleydb ticket registry for CAS server
109 Requires:       %{name} = %{version}-%{release}
110 Group:          Libraries/Java
111
112 %description integration-berkeleydb
113
114 %package integration-jboss
115 Summary:        Jboss ticket registry for CAS server
116 Requires:       %{name} = %{version}-%{release}
117 Group:          Libraries/Java
118
119 %description integration-jboss
120
121 %package integration-memcached
122 Summary:        Memory ticket registry for CAS server
123 Requires:       %{name} = %{version}-%{release}
124 Group:          Libraries/Java
125
126 %description integration-memcached
127
128 %package integration-restlet
129 Summary:         I have no idea WTF is that, but it is for CAS server
130 Requires:       %{name} = %{version}-%{release}
131 Group:          Libraries/Java
132
133 %description integration-restlet
134
135 %prep
136 %setup -q
137 unzip modules/%{name}-webapp-%{version}.war -d webapp
138
139 %build
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/cas-server,%{_datadir},%{_sharedstatedir}/{cas-server,tomcat/conf/Catalina/localhost}}
144
145 cp -a webapp $RPM_BUILD_ROOT%{webappdir}
146
147 MODULES="integration-berkeleydb integration-jboss integration-memcached integration-restlet support-generic support-jdbc support-ldap support-legacy support-openid support-radius support-spnego support-trusted support-x509"
148
149 for i in $MODULES; do
150   install modules/%{name}-$i-%{version}.jar $RPM_BUILD_ROOT%{libdir}/%{name}-$i-%{version}.jar
151 done
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %dir %{_sysconfdir}/cas-server
159 #%config(noreplace) %{_sysconfdir}/cas-server/web.xml
160 # do not make this file writeable by tomcat. We do not want to allow user to
161 # undeploy this app via tomcat manager.
162 %config(noreplace) %{_sharedstatedir}/tomcat/conf/Catalina/localhost/cas-server.xml
163 %{_datadir}/cas-server
164 %exclude %{libdir}/cas-server-support-spnego-3.3.5.jar
165 %exclude %{libdir}/cas-server-integration-berkeleydb-3.3.5.jar
166 %exclude %{libdir}/cas-server-support-x509-3.3.5.jar
167 %exclude %{libdir}/cas-server-integration-jboss-3.3.5.jar
168 %exclude %{libdir}/cas-server-support-openid-3.3.5.jar
169 %exclude %{libdir}/cas-server-support-legacy-3.3.5.jar
170 %exclude %{libdir}/cas-server-support-radius-3.3.5.jar
171 %exclude %{libdir}/cas-server-integration-memcached-3.3.5.jar
172 %exclude %{libdir}/cas-server-integration-restlet-3.3.5.jar
173 %exclude %{libdir}/cas-server-support-ldap-3.3.5.jar
174 %exclude %{libdir}/cas-server-support-generic-3.3.5.jar
175 %exclude %{libdir}/cas-server-support-trusted-3.3.5.jar
176 %exclude %{libdir}/cas-server-support-jdbc-3.3.5.jar
177 %attr(2755,root,servlet) %dir %{_sharedstatedir}/cas-server
178
179 %files authenticator-spnego
180 %defattr(644,root,root,755)
181 %{libdir}/cas-server-support-spnego-3.3.5.jar
182
183 %files authenticator-x509
184 %defattr(644,root,root,755)
185 %{libdir}/cas-server-support-x509-3.3.5.jar
186
187 %files authenticator-openid
188 %defattr(644,root,root,755)
189 %{libdir}/cas-server-support-openid-3.3.5.jar
190
191 %files authenticator-legacy
192 %defattr(644,root,root,755)
193 %{libdir}/cas-server-support-legacy-3.3.5.jar
194
195 %files authenticator-radius
196 %defattr(644,root,root,755)
197 %{libdir}/cas-server-support-radius-3.3.5.jar
198
199 %files authenticator-ldap
200 %defattr(644,root,root,755)
201 %{libdir}/cas-server-support-ldap-3.3.5.jar
202
203 %files authenticator-generic
204 %defattr(644,root,root,755)
205 %{libdir}/cas-server-support-generic-3.3.5.jar
206
207 %files authenticator-trusted
208 %defattr(644,root,root,755)
209 %{libdir}/cas-server-support-trusted-3.3.5.jar
210
211 %files authenticator-jdbc
212 %defattr(644,root,root,755)
213 %{libdir}/cas-server-support-jdbc-3.3.5.jar
214
215 %files integration-berkeleydb
216 %defattr(644,root,root,755)
217 %{libdir}/cas-server-integration-berkeleydb-3.3.5.jar
218
219 %files integration-jboss
220 %defattr(644,root,root,755)
221 %{libdir}/cas-server-integration-jboss-3.3.5.jar
222
223 %files integration-memcached
224 %defattr(644,root,root,755)
225 %{libdir}/cas-server-integration-memcached-3.3.5.jar
226
227 %files integration-restlet
228 %defattr(644,root,root,755)
229 %{libdir}/cas-server-integration-restlet-3.3.5.jar
This page took 0.0551 seconds and 2 git commands to generate.