]> git.pld-linux.org Git - packages/carob.git/blob - carob.spec
- libcarob moved to _libdir; cleanup
[packages/carob.git] / carob.spec
1 %define _ver    %(echo %{version} |tr . _)
2 Summary:        Carob library
3 Summary(pl):    Biblioteka carob
4 Name:           carob
5 Version:        0.6.2
6 Release:        0.2
7 License:        Apache License v2.0
8 Group:          Libraries
9 Source0:        https://forge.continuent.org/frs/download.php/182/%{name}-r%{_ver}.tar.gz
10 # Source0-md5:  6969f74fa9f4c19c434b68d29590eb3a
11 URL:            http://carob.continuent.org/HomePage
12 BuildRequires:  gmp-devel
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 Bringing Sequoia technology to the C/C++ world.
18
19 Carob's base is a C++ port of the JDBC driver code. It offers to
20 developpers the same access as in Java. Connections, Requests,
21 ResultSets and all necessary C++ classes can be used transparently and
22 directly in any C++ enabled application.
23
24 %package devel
25 Summary:        Header files for carob library
26 Summary(pl):    Pliki nag³ówkowe biblioteki carob
27 Group:          Development/Libraries
28 Requires:       %{name} = %{version}-%{release}
29
30 %description devel
31 This is the package containing the header files for carob library.
32
33 %description devel -l pl
34 Ten pakiet zawiera pliki nag³ówkowe biblioteki carob.
35
36 %package static
37 Summary:        Static carob library
38 Summary(pl):    Statyczna biblioteka carob
39 Group:          Development/Libraries
40 Requires:       %{name}-devel = %{version}-%{release}
41
42 %description static
43 Static carob library.
44
45 %description static -l pl
46 Statyczna biblioteka carob.
47
48 %prep
49 %setup -q -n %{name}-r%{_ver}
50
51 %build
52 %{__make} \
53         CXX="%{__cxx}" \
54         CXXFLAGS="%{rpmcflags} -fPIC" \
55         LDFLAGS="%{rpmldflags} -lpthread"
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 install -d $RPM_BUILD_ROOT{%{_includedir}/carob,%{_libdir}}
61 install libcarob.so.1 $RPM_BUILD_ROOT%{_libdir}
62 install libcarob.a $RPM_BUILD_ROOT%{_libdir}
63 install include/*.hpp $RPM_BUILD_ROOT%{_includedir}/carob
64 ln -s libcarob.so.1 $RPM_BUILD_ROOT%{_libdir}/libcarob.so
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post   -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README
75 %attr(755,root,root) %{_libdir}/libcarob.so.1
76
77 %files devel
78 %defattr(644,root,root,755)
79 %attr(755,root,root) %{_libdir}/libcarob.so
80 %{_includedir}/carob
81
82 %files static
83 %defattr(644,root,root,755)
84 %{_libdir}/libcarob.a
This page took 0.114683 seconds and 3 git commands to generate.