]> git.pld-linux.org Git - packages/captive.git/blob - captive.spec
- BR: libtool, cleanup, restored clean
[packages/captive.git] / captive.spec
1 Summary:        Captive - NTFS read/write filesystem for Linux
2 Summary(pl):    Captive - obs³uga NTFS dla Linuksa z odczytem i zapisem
3 Name:           captive
4 Version:        1.1.6.1
5 Release:        1
6 License:        GPL
7 Group:          Base/Kernel
8 Source0:        http://www.jankratochvil.net/project/captive/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  81fcc21997cf46ad9440d1a1464a384e
10 Patch0:         %{name}-non_root_install.patch
11 Patch1:         %{name}-popt_link.patch
12 Patch2:         %{name}-configure_ac.patch
13 URL:            http://www.jankratochvil.net/project/captive/
14 BuildRequires:  ORBit2-devel
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gettext-devel
18 BuildRequires:  gnome-vfs2-devel >= 2.0
19 BuildRequires:  libfuse-devel >= 2.4.1
20 BuildRequires:  libtool
21 BuildRequires:  libxml2-devel >= 2.5.9
22 BuildRequires:  openssl-devel
23 BuildRequires:  perl-tools-pod
24 BuildRequires:  pkgconfig
25 BuildRequires:  readline-devel
26 BuildRequires:  rpmbuild(macros) >= 1.202
27 Provides:       group(captive)
28 Provides:       user(captive)
29 Requires(postun):       /usr/sbin/groupdel
30 Requires(postun):       /usr/sbin/userdel
31 Requires(pre):  /bin/id
32 Requires(pre):  /usr/bin/getgid
33 Requires(pre):  /usr/sbin/groupadd
34 Requires(pre):  /usr/sbin/useradd
35 Requires:       ntfsprogs >= 1.8.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Captive project implements the first full read/write free access to
40 NTFS disk drives. You can mount your Microsoft Windows NT, 200x or XP
41 partition as a transparently accessible volume for your GNU/Linux.
42
43 This compatibility was achieved in the Wine way by using the original
44 Microsoft Windows ntfs.sys driver. It emulates the required subsystems
45 of the Microsoft Windows kernel by reusing one of the original
46 ntoskrnl.exe, ReactOS parts, or this project's own reimplementations,
47 on a case by case basis. Project includes the first open source
48 MS-Windows kernel API for Free operating systems. Involvement of the
49 original driver files was chosen to achieve the best and unprecedented
50 filesystem compatibility and safety.
51
52 %description -l pl
53 Projekt Captive implementuje pierwszy pe³ny, swobodny dostêp z
54 odczytem i zapisem do partycji NTFS. Pozwala zamontowaæ partycje z
55 Microsoft Windows NT, 200x i XP jako dostêpny w sposób przezroczysty
56 wolumen pod Linuksem.
57
58 Kompatybilno¶æ osi±gniêto metod± Wine poprzez u¿ycie oryginalnego
59 sterownika ntfs.sys. Captive emuluje wymagane podsystemy j±dra
60 Microsoft Windows poprzez wykorzystanie oryginalnego ntoskrnl.exe,
61 czê¶ci ReactOS-a lub w³asne implementacje z tego projektu w zale¿no¶ci
62 od danego przypadku. Projekt zawiera pierwsze API j±dra MS-Windows z
63 otwartymi ¼ród³ami dla wolnodostêpnych systemów operacyjnych. Wybrano
64 wykorzystanie plików oryginalnego sterownika aby osi±gn±æ lepsz±
65 kompatybilno¶æ i bezpieczeñstwo.
66
67 %package devel
68 Summary:        Header files for captive library
69 Summary(pl):    Pliki nag³ówkowe biblioteki captive
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description devel
74 This is the package containing the header files for captive.
75
76 %description devel -l pl
77 Ten pakiet zawiera pliki nag³ówkowe biblioteki captive.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84 # Fix not finished moving captive-sandbox-server to libdir
85 sed -i -e 's/--sandbox-server=@sbindir@/--sandbox-server=@libdir@/g' src/client/gnomevfs/captive.conf.in
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I macros
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 %configure \
94         --enable-shared \
95         --disable-static \
96         --with-readline \
97         --disable-bug-replay \
98         --enable-lufs=no \
99         --enable-fuse=yes \
100         --disable-install-pkg \
101         --enable-sandbox-setuid=captive \
102         --enable-sandbox-setgid=captive \
103         --enable-sandbox-chroot=/var/lib/captive \
104         --enable-man-pages \
105         --enable-sbin-mountdir=/sbin \
106         --enable-sbin-mount-fs=ntfs:fastfat:cdfs:ext2fsd \
107         --with-oribt-line=link \
108         --with-tmpdir=/tmp
109
110 %{__make}
111
112 %install
113 rm -rf $RPM_BUILD_ROOT
114
115 %{__make} install \
116         DESTDIR=$RPM_BUILD_ROOT
117
118 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs.la
119
120 %find_lang %{name}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %pre
126 %groupadd -g 141 captive
127 %useradd -u 141 -r -d /var/lib/captive -s /bin/false -c "Captive User" -g captive captive
128
129 %postun 
130 if [ "$1" = "0" ]; then
131         %userremove captive
132         %groupremove captive
133 fi
134
135 %files -f %{name}.lang
136 %defattr(644,root,root,755)
137 %doc AUTHORS NEWS README THANKS TODO
138 %attr(755,root,root) /sbin/*
139 %attr(755,root,root) %{_bindir}/captive-cmdline
140 #%attr(755,root,root) %{_bindir}/captive-bug-replay was here earlier.
141 %%attr(755,root,root) %{_libdir}/captive-sandbox-server
142 %{_sysconfdir}/gnome-vfs-2.0/modules/*
143 %{_sysconfdir}/w32-mod-id.captivemodid.xml
144 %attr(755,root,root) %{_libdir}/libcaptive-*.so
145 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs*.so
146 %{_mandir}/man?/*
147 %{_var}/lib/captive
148
149 %files devel
150 %defattr(644,root,root,755)
151 %attr(755,root,root) %{_libdir}/libcaptive.so
152 %{_libdir}/libcaptive.la
153 %{_includedir}/captive
This page took 0.067663 seconds and 4 git commands to generate.