]> git.pld-linux.org Git - packages/captive.git/blob - captive.spec
- BR sed4
[packages/captive.git] / captive.spec
1 Summary:        Captive - NTFS read/write filesystem for Linux
2 Summary(pl):    Captive - obs³uga NTFS dla Linuksa z odczytem i zapisem
3 Name:           captive
4 Version:        1.1.6.1
5 Release:        1
6 License:        GPL
7 Group:          Base/Kernel
8 Source0:        http://www.jankratochvil.net/project/captive/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  81fcc21997cf46ad9440d1a1464a384e
10 Patch0:         %{name}-non_root_install.patch
11 Patch1:         %{name}-popt_link.patch
12 Patch2:         %{name}-configure_ac.patch
13 URL:            http://www.jankratochvil.net/project/captive/
14 BuildRequires:  ORBit2-devel
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gettext-devel
18 BuildRequires:  gnome-vfs2-devel >= 2.0
19 BuildRequires:  libfuse-devel >= 2.4.1
20 BuildRequires:  libtool
21 BuildRequires:  libxml2-devel >= 2.5.9
22 BuildRequires:  openssl-devel
23 BuildRequires:  perl-tools-pod
24 BuildRequires:  pkgconfig
25 BuildRequires:  readline-devel
26 BuildRequires:  rpmbuild(macros) >= 1.202
27 BuildRequires:  sed >= 4.0
28 Provides:       group(captive)
29 Provides:       user(captive)
30 Requires(postun):       /usr/sbin/groupdel
31 Requires(postun):       /usr/sbin/userdel
32 Requires(pre):  /bin/id
33 Requires(pre):  /usr/bin/getgid
34 Requires(pre):  /usr/sbin/groupadd
35 Requires(pre):  /usr/sbin/useradd
36 Requires:       ntfsprogs >= 1.8.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Captive project implements the first full read/write free access to
41 NTFS disk drives. You can mount your Microsoft Windows NT, 200x or XP
42 partition as a transparently accessible volume for your GNU/Linux.
43
44 This compatibility was achieved in the Wine way by using the original
45 Microsoft Windows ntfs.sys driver. It emulates the required subsystems
46 of the Microsoft Windows kernel by reusing one of the original
47 ntoskrnl.exe, ReactOS parts, or this project's own reimplementations,
48 on a case by case basis. Project includes the first open source
49 MS-Windows kernel API for Free operating systems. Involvement of the
50 original driver files was chosen to achieve the best and unprecedented
51 filesystem compatibility and safety.
52
53 %description -l pl
54 Projekt Captive implementuje pierwszy pe³ny, swobodny dostêp z
55 odczytem i zapisem do partycji NTFS. Pozwala zamontowaæ partycje z
56 Microsoft Windows NT, 200x i XP jako dostêpny w sposób przezroczysty
57 wolumen pod Linuksem.
58
59 Kompatybilno¶æ osi±gniêto metod± Wine poprzez u¿ycie oryginalnego
60 sterownika ntfs.sys. Captive emuluje wymagane podsystemy j±dra
61 Microsoft Windows poprzez wykorzystanie oryginalnego ntoskrnl.exe,
62 czê¶ci ReactOS-a lub w³asne implementacje z tego projektu w zale¿no¶ci
63 od danego przypadku. Projekt zawiera pierwsze API j±dra MS-Windows z
64 otwartymi ¼ród³ami dla wolnodostêpnych systemów operacyjnych. Wybrano
65 wykorzystanie plików oryginalnego sterownika aby osi±gn±æ lepsz±
66 kompatybilno¶æ i bezpieczeñstwo.
67
68 %package devel
69 Summary:        Header files for captive library
70 Summary(pl):    Pliki nag³ówkowe biblioteki captive
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 This is the package containing the header files for captive.
76
77 %description devel -l pl
78 Ten pakiet zawiera pliki nag³ówkowe biblioteki captive.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 # Fix not finished moving captive-sandbox-server to libdir
86 sed -i -e 's/--sandbox-server=@sbindir@/--sandbox-server=@libdir@/g' src/client/gnomevfs/captive.conf.in
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I macros
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --enable-shared \
96         --disable-static \
97         --with-readline \
98         --disable-bug-replay \
99         --enable-lufs=no \
100         --enable-fuse=yes \
101         --disable-install-pkg \
102         --enable-sandbox-setuid=captive \
103         --enable-sandbox-setgid=captive \
104         --enable-sandbox-chroot=/var/lib/captive \
105         --enable-man-pages \
106         --enable-sbin-mountdir=/sbin \
107         --enable-sbin-mount-fs=ntfs:fastfat:cdfs:ext2fsd \
108         --with-oribt-line=link \
109         --with-tmpdir=/tmp
110
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115
116 %{__make} install \
117         DESTDIR=$RPM_BUILD_ROOT
118
119 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs.la
120
121 %find_lang %{name}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %pre
127 %groupadd -g 141 captive
128 %useradd -u 141 -r -d /var/lib/captive -s /bin/false -c "Captive User" -g captive captive
129
130 %postun 
131 if [ "$1" = "0" ]; then
132         %userremove captive
133         %groupremove captive
134 fi
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc AUTHORS NEWS README THANKS TODO
139 %attr(755,root,root) /sbin/*
140 %attr(755,root,root) %{_bindir}/captive-cmdline
141 #%attr(755,root,root) %{_bindir}/captive-bug-replay was here earlier.
142 %%attr(755,root,root) %{_libdir}/captive-sandbox-server
143 %{_sysconfdir}/gnome-vfs-2.0/modules/*
144 %{_sysconfdir}/w32-mod-id.captivemodid.xml
145 %attr(755,root,root) %{_libdir}/libcaptive-*.so
146 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs*.so
147 %{_mandir}/man?/*
148 %{_var}/lib/captive
149
150 %files devel
151 %defattr(644,root,root,755)
152 %attr(755,root,root) %{_libdir}/libcaptive.so
153 %{_libdir}/libcaptive.la
154 %{_includedir}/captive
This page took 0.035539 seconds and 4 git commands to generate.