]> git.pld-linux.org Git - packages/captive.git/blob - captive.spec
- added provides user/group captive
[packages/captive.git] / captive.spec
1 #
2 #
3 Summary:        Captive - NTFS read/write filesystem for Linux
4 Summary(pl):    Captive - obs³uga NTFS dla Linuksa z odczytem i zapisem
5 Name:           captive
6 Version:        1.1.6.1
7 Release:        1
8 License:        GPL
9 Group:          Base/Kernel
10 Source0:        http://www.jankratochvil.net/project/captive/dist/%{name}-%{version}.tar.gz
11 # Source0-md5:  81fcc21997cf46ad9440d1a1464a384e
12 Patch0:         %{name}-non_root_install.patch
13 Patch1:         %{name}-popt_link.patch
14 Patch2:         %{name}-configure_ac.patch
15 URL:            http://www.jankratochvil.net/project/captive/
16 BuildRequires:  ORBit2-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gettext-devel
20 BuildRequires:  gnome-vfs2-devel >= 2.0
21 BuildRequires:  libxml2-devel >= 2.5.9
22 BuildRequires:  libfuse-devel >= 2.4.1
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-tools-pod
25 BuildRequires:  pkgconfig
26 BuildRequires:  readline-devel
27 Provides:       group(captive)
28 Provides:       user(captive)
29 Requires(postun):       /usr/sbin/groupdel
30 Requires(postun):       /usr/sbin/userdel
31 Requires(pre):  /bin/id
32 Requires(pre):  /usr/bin/getgid
33 Requires(pre):  /usr/sbin/groupadd
34 Requires(pre):  /usr/sbin/useradd
35 Requires:       ntfsprogs >= 1.8.0
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Captive project implements the first full read/write free access to
40 NTFS disk drives. You can mount your Microsoft Windows NT, 200x or XP
41 partition as a transparently accessible volume for your GNU/Linux.
42
43 This compatibility was achieved in the Wine way by using the original
44 Microsoft Windows ntfs.sys driver. It emulates the required subsystems
45 of the Microsoft Windows kernel by reusing one of the original
46 ntoskrnl.exe, ReactOS parts, or this project's own reimplementations,
47 on a case by case basis. Project includes the first open source
48 MS-Windows kernel API for Free operating systems. Involvement of the
49 original driver files was chosen to achieve the best and unprecedented
50 filesystem compatibility and safety.
51
52 %description -l pl
53 Projekt Captive implementuje pierwszy pe³ny, swobodny dostêp z
54 odczytem i zapisem do partycji NTFS. Pozwala zamontowaæ partycje z
55 Microsoft Windows NT, 200x i XP jako dostêpny w sposób przezroczysty
56 wolumen pod Linuksem.
57
58 Kompatybilno¶æ osi±gniêto metod± Wine poprzez u¿ycie oryginalnego
59 sterownika ntfs.sys. Captive emuluje wymagane podsystemy j±dra
60 Microsoft Windows poprzez wykorzystanie oryginalnego ntoskrnl.exe,
61 czê¶ci ReactOS-a lub w³asne implementacje z tego projektu w zale¿no¶ci
62 od danego przypadku. Projekt zawiera pierwsze API j±dra MS-Windows z
63 otwartymi ¼ród³ami dla wolnodostêpnych systemów operacyjnych. Wybrano
64 wykorzystanie plików oryginalnego sterownika aby osi±gn±æ lepsz±
65 kompatybilno¶æ i bezpieczeñstwo.
66
67 %package devel
68 Summary:        Header files for captive library
69 Summary(pl):    Pliki nag³ówkowe biblioteki captive
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description devel
74 This is the package containing the header files for captive.
75
76 %description devel -l pl
77 Ten pakiet zawiera pliki nag³ówkowe biblioteki captive.
78
79 %prep
80 %setup -q
81 %patch0 -p1
82 %patch1 -p1
83 %patch2 -p1
84 # Fix not finished moving captive-sandbox-server to libdir
85 sed -i -e 's/--sandbox-server=@sbindir@/--sandbox-server=@libdir@/g' src/client/gnomevfs/captive.conf.in
86
87 %build
88 %{__libtoolize}
89 %{__aclocal} -I macros
90 %{__autoconf}
91 %{__autoheader}
92 %{__automake}
93 cp -f /usr/share/automake/config.sub .
94
95 %configure \
96         --enable-shared \
97         --disable-static \
98         --with-readline \
99         --disable-bug-replay \
100         --enable-lufs=no \
101         --enable-fuse=yes \
102         --disable-install-pkg \
103         --enable-sandbox-setuid=captive \
104         --enable-sandbox-setgid=captive \
105         --enable-sandbox-chroot=/var/lib/captive \
106         --enable-man-pages \
107         --enable-sbin-mountdir=/sbin \
108         --enable-sbin-mount-fs=ntfs:fastfat:cdfs:ext2fsd \
109         --with-oribt-line=link \
110         --with-tmpdir=/tmp
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs.la
121
122 %find_lang %{name}
123
124 %clean
125 #rm -rf $RPM_BUILD_ROOT
126
127 %pre
128 %groupadd -g 141 captive
129 %useradd -u 141 -r -d /var/lib/captive -s /bin/false -c "Captive User" -g captive captive
130
131 %postun 
132 if [ "$1" = "0" ]; then
133         %userremove captive
134         %groupremove captive
135 fi
136
137 %files -f %{name}.lang
138 %defattr(644,root,root,755)
139 %doc AUTHORS NEWS README THANKS TODO
140 %attr(755,root,root) /sbin/*
141 %attr(755,root,root) %{_bindir}/captive-cmdline
142 #%attr(755,root,root) %{_bindir}/captive-bug-replay was here earlier.
143 %%attr(755,root,root) %{_libdir}/captive-sandbox-server
144 %{_sysconfdir}/gnome-vfs-2.0/modules/*
145 %{_sysconfdir}/w32-mod-id.captivemodid.xml
146 %attr(755,root,root) %{_libdir}/libcaptive-*.so
147 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs*.so
148 %{_mandir}/man?/*
149 %{_var}/lib/captive
150
151 %files devel
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_libdir}/libcaptive.so
154 %{_libdir}/libcaptive.la
155 %{_includedir}/captive
This page took 0.051723 seconds and 4 git commands to generate.