]> git.pld-linux.org Git - packages/captive.git/blob - captive.spec
- works, updated to 1.1.7
[packages/captive.git] / captive.spec
1 # http://gentoo-wiki.com/HOWTO_NTFS_write_with_Captive_approach
2 # nice article about how to use it in gentoo, should be easy to prot to pld
3
4 # please allow those bconds to remain here as next version might be gnome-vfs2 independent
5 # %bcond_without        vfs     # enable gnome2 cvs
6 Summary:        Captive - NTFS read/write filesystem for Linux
7 Summary(pl):    Captive - obs³uga NTFS dla Linuksa z odczytem i zapisem
8 Name:           captive
9 Version:        1.1.7
10 Release:        1
11 License:        GPL
12 Group:          Base/Kernel
13 Source0:        http://www.jankratochvil.net/project/captive/dist/%{name}-%{version}.tar.gz
14 # Source0-md5:  34312cd854ca992f0daf0a8faabaae9a
15 Patch0:         %{name}-popt_link.patch
16 URL:            http://www.jankratochvil.net/project/captive/
17 #%if %{with vfs}
18 BuildRequires:  gnome-vfs2-devel >= 2.0
19 #%endif
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  gettext-devel
23 BuildRequires:  libfuse-devel >= 2.4.1
24 BuildRequires:  libtool
25 BuildRequires:  libxml2-devel >= 2.5.9
26 BuildRequires:  openssl-devel
27 BuildRequires:  perl-tools-pod
28 BuildRequires:  pkgconfig
29 BuildRequires:  readline-devel
30 BuildRequires:  rpmbuild(macros) >= 1.202
31 BuildRequires:  ORBit2-devel
32 BuildRequires:  sed >= 4.0
33 Provides:       group(captive)
34 Provides:       user(captive)
35 Requires(postun):       /usr/sbin/groupdel
36 Requires(postun):       /usr/sbin/userdel
37 Requires(pre):  /bin/id
38 Requires(pre):  /usr/bin/getgid
39 Requires(pre):  /usr/sbin/groupadd
40 Requires(pre):  /usr/sbin/useradd
41 Requires:       ntfsprogs >= 1.8.0
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %description
45 Captive project implements the first full read/write free access to
46 NTFS disk drives. You can mount your Microsoft Windows NT, 200x or XP
47 partition as a transparently accessible volume for your GNU/Linux.
48
49 This compatibility was achieved in the Wine way by using the original
50 Microsoft Windows ntfs.sys driver. It emulates the required subsystems
51 of the Microsoft Windows kernel by reusing one of the original
52 ntoskrnl.exe, ReactOS parts, or this project's own reimplementations,
53 on a case by case basis. Project includes the first open source
54 MS-Windows kernel API for Free operating systems. Involvement of the
55 original driver files was chosen to achieve the best and unprecedented
56 filesystem compatibility and safety.
57
58 %description -l pl
59 Projekt Captive implementuje pierwszy pe³ny, swobodny dostêp z
60 odczytem i zapisem do partycji NTFS. Pozwala zamontowaæ partycje z
61 Microsoft Windows NT, 200x i XP jako dostêpny w sposób przezroczysty
62 wolumen pod Linuksem.
63
64 Kompatybilno¶æ osi±gniêto metod± Wine poprzez u¿ycie oryginalnego
65 sterownika ntfs.sys. Captive emuluje wymagane podsystemy j±dra
66 Microsoft Windows poprzez wykorzystanie oryginalnego ntoskrnl.exe,
67 czê¶ci ReactOS-a lub w³asne implementacje z tego projektu w zale¿no¶ci
68 od danego przypadku. Projekt zawiera pierwsze API j±dra MS-Windows z
69 otwartymi ¼ród³ami dla wolnodostêpnych systemów operacyjnych. Wybrano
70 wykorzystanie plików oryginalnego sterownika aby osi±gn±æ lepsz±
71 kompatybilno¶æ i bezpieczeñstwo.
72
73 %package devel
74 Summary:        Header files for captive library
75 Summary(pl):    Pliki nag³ówkowe biblioteki captive
76 Group:          Development/Libraries
77 Requires:       %{name} = %{version}-%{release}
78
79 %description devel
80 This is the package containing the header files for captive.
81
82 %description devel -l pl
83 Ten pakiet zawiera pliki nag³ówkowe biblioteki captive.
84
85 %package gnome
86 Summary:        Gnome vfs data for captive support
87 Summary(pl):    Dane dla Gnome vfs z obs³ug± captive
88 Group:          Development/Libraries
89 Requires:       %{name} = %{version}-%{release}
90 Requires:       gnome-vfs2 >= 2.0
91
92 %description gnome
93 Gnome vfs data for captive support.
94
95 %description gnome -l pl
96 Dane dla Gnome vfs z obs³ug± captive.
97
98 %prep
99 %setup -q
100 %patch0 -p1
101
102 # Fix not finished moving captive-sandbox-server to libdir
103 sed -i -e 's/--sandbox-server=@sbindir@/--sandbox-server=@libdir@/g' src/client/gnomevfs/captive.conf.in
104
105 %build
106 %{__libtoolize}
107 %{__aclocal} -I macros
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112         --enable-shared \
113         --disable-static \
114         --with-readline \
115         --disable-bug-replay \
116         --enable-lufs=no \
117         --enable-fuse=yes \
118         --disable-install-pkg \
119         --enable-sandbox-setuid=captive \
120         --enable-sandbox-setgid=captive \
121         --enable-sandbox-chroot=/var/lib/captive \
122         --enable-man-pages \
123         --enable-sbin-mountdir=/sbin \
124         --enable-sbin-mount-fs=ntfs:fastfat:cdfs:ext2fsd \
125         --with-oribt-line=link} \
126         --with-tmpdir=/tmp
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs.la
137
138 %find_lang %{name}
139
140 %clean
141 rm -rf $RPM_BUILD_ROOT
142
143 %pre
144 %groupadd -g 141 captive
145 %useradd -u 141 -r -d /var/lib/captive -s /bin/false -c "Captive User" -g captive captive
146
147 %postun 
148 if [ "$1" = "0" ]; then
149         %userremove captive
150         %groupremove captive
151 fi
152
153 %files -f %{name}.lang
154 %defattr(644,root,root,755)
155 %doc AUTHORS NEWS README THANKS TODO
156 %attr(755,root,root) /sbin/*
157 %attr(755,root,root) %{_bindir}/captive-cmdline
158 #%attr(755,root,root) %{_bindir}/captive-bug-replay was here earlier.
159 %attr(755,root,root) %{_libdir}/captive-sandbox-server
160 %{_sysconfdir}/w32-mod-id.captivemodid.xml
161 %attr(755,root,root) %{_libdir}/libcaptive-*.so
162 %{_mandir}/man?/*
163 %{_var}/lib/captive
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libcaptive.so
168 %{_libdir}/libcaptive.la
169 %{_includedir}/captive
170
171 #%if %{with vfs}
172 %files gnome
173 %defattr(644,root,root,755)
174 %{_sysconfdir}/gnome-vfs-2.0/modules/*
175 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs*.so
176 #%endif
This page took 0.438334 seconds and 4 git commands to generate.