]> git.pld-linux.org Git - packages/captive.git/blob - captive.spec
- BR: rpmbuild(macros) >= 1.202
[packages/captive.git] / captive.spec
1 #
2 #
3 Summary:        Captive - NTFS read/write filesystem for Linux
4 Summary(pl):    Captive - obs³uga NTFS dla Linuksa z odczytem i zapisem
5 Name:           captive
6 Version:        1.1.6.1
7 Release:        1
8 License:        GPL
9 Group:          Base/Kernel
10 Source0:        http://www.jankratochvil.net/project/captive/dist/%{name}-%{version}.tar.gz
11 # Source0-md5:  81fcc21997cf46ad9440d1a1464a384e
12 Patch0:         %{name}-non_root_install.patch
13 Patch1:         %{name}-popt_link.patch
14 Patch2:         %{name}-configure_ac.patch
15 URL:            http://www.jankratochvil.net/project/captive/
16 BuildRequires:  ORBit2-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gettext-devel
20 BuildRequires:  gnome-vfs2-devel >= 2.0
21 BuildRequires:  libxml2-devel >= 2.5.9
22 BuildRequires:  libfuse-devel >= 2.4.1
23 BuildRequires:  openssl-devel
24 BuildRequires:  perl-tools-pod
25 BuildRequires:  pkgconfig
26 BuildRequires:  readline-devel
27 BuildRequires:  rpmbuild(macros) >= 1.202
28 Provides:       group(captive)
29 Provides:       user(captive)
30 Requires(postun):       /usr/sbin/groupdel
31 Requires(postun):       /usr/sbin/userdel
32 Requires(pre):  /bin/id
33 Requires(pre):  /usr/bin/getgid
34 Requires(pre):  /usr/sbin/groupadd
35 Requires(pre):  /usr/sbin/useradd
36 Requires:       ntfsprogs >= 1.8.0
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 Captive project implements the first full read/write free access to
41 NTFS disk drives. You can mount your Microsoft Windows NT, 200x or XP
42 partition as a transparently accessible volume for your GNU/Linux.
43
44 This compatibility was achieved in the Wine way by using the original
45 Microsoft Windows ntfs.sys driver. It emulates the required subsystems
46 of the Microsoft Windows kernel by reusing one of the original
47 ntoskrnl.exe, ReactOS parts, or this project's own reimplementations,
48 on a case by case basis. Project includes the first open source
49 MS-Windows kernel API for Free operating systems. Involvement of the
50 original driver files was chosen to achieve the best and unprecedented
51 filesystem compatibility and safety.
52
53 %description -l pl
54 Projekt Captive implementuje pierwszy pe³ny, swobodny dostêp z
55 odczytem i zapisem do partycji NTFS. Pozwala zamontowaæ partycje z
56 Microsoft Windows NT, 200x i XP jako dostêpny w sposób przezroczysty
57 wolumen pod Linuksem.
58
59 Kompatybilno¶æ osi±gniêto metod± Wine poprzez u¿ycie oryginalnego
60 sterownika ntfs.sys. Captive emuluje wymagane podsystemy j±dra
61 Microsoft Windows poprzez wykorzystanie oryginalnego ntoskrnl.exe,
62 czê¶ci ReactOS-a lub w³asne implementacje z tego projektu w zale¿no¶ci
63 od danego przypadku. Projekt zawiera pierwsze API j±dra MS-Windows z
64 otwartymi ¼ród³ami dla wolnodostêpnych systemów operacyjnych. Wybrano
65 wykorzystanie plików oryginalnego sterownika aby osi±gn±æ lepsz±
66 kompatybilno¶æ i bezpieczeñstwo.
67
68 %package devel
69 Summary:        Header files for captive library
70 Summary(pl):    Pliki nag³ówkowe biblioteki captive
71 Group:          Development/Libraries
72 Requires:       %{name} = %{version}-%{release}
73
74 %description devel
75 This is the package containing the header files for captive.
76
77 %description devel -l pl
78 Ten pakiet zawiera pliki nag³ówkowe biblioteki captive.
79
80 %prep
81 %setup -q
82 %patch0 -p1
83 %patch1 -p1
84 %patch2 -p1
85 # Fix not finished moving captive-sandbox-server to libdir
86 sed -i -e 's/--sandbox-server=@sbindir@/--sandbox-server=@libdir@/g' src/client/gnomevfs/captive.conf.in
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I macros
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 cp -f /usr/share/automake/config.sub .
95
96 %configure \
97         --enable-shared \
98         --disable-static \
99         --with-readline \
100         --disable-bug-replay \
101         --enable-lufs=no \
102         --enable-fuse=yes \
103         --disable-install-pkg \
104         --enable-sandbox-setuid=captive \
105         --enable-sandbox-setgid=captive \
106         --enable-sandbox-chroot=/var/lib/captive \
107         --enable-man-pages \
108         --enable-sbin-mountdir=/sbin \
109         --enable-sbin-mount-fs=ntfs:fastfat:cdfs:ext2fsd \
110         --with-oribt-line=link \
111         --with-tmpdir=/tmp
112
113 %{__make}
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT
120
121 rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs.la
122
123 %find_lang %{name}
124
125 %clean
126 #rm -rf $RPM_BUILD_ROOT
127
128 %pre
129 %groupadd -g 141 captive
130 %useradd -u 141 -r -d /var/lib/captive -s /bin/false -c "Captive User" -g captive captive
131
132 %postun 
133 if [ "$1" = "0" ]; then
134         %userremove captive
135         %groupremove captive
136 fi
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc AUTHORS NEWS README THANKS TODO
141 %attr(755,root,root) /sbin/*
142 %attr(755,root,root) %{_bindir}/captive-cmdline
143 #%attr(755,root,root) %{_bindir}/captive-bug-replay was here earlier.
144 %%attr(755,root,root) %{_libdir}/captive-sandbox-server
145 %{_sysconfdir}/gnome-vfs-2.0/modules/*
146 %{_sysconfdir}/w32-mod-id.captivemodid.xml
147 %attr(755,root,root) %{_libdir}/libcaptive-*.so
148 %attr(755,root,root) %{_libdir}/gnome-vfs-2.0/modules/libcaptive-gnomevfs*.so
149 %{_mandir}/man?/*
150 %{_var}/lib/captive
151
152 %files devel
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libcaptive.so
155 %{_libdir}/libcaptive.la
156 %{_includedir}/captive
This page took 0.096398 seconds and 4 git commands to generate.