]> git.pld-linux.org Git - packages/captive-drivers.git/blob - captive-drivers.spec
- don't use %{without ...}, it may not work after inverting bcond
[packages/captive-drivers.git] / captive-drivers.spec
1 # the drivers that were supposed to work, didn't.
2 # so these drivers didn't work for me.
3 #
4 # Conditional build:
5 %bcond_with     license_agreement       # generates package
6 %define         source_url      http://download.microsoft.com/download/9/7/6/9763833d-bd58-41e2-9911-50f64c7252a3/
7 #
8 Summary:        NTFS Drivers
9 Summary(pl):    Sterowniki NTFS
10 %define         base_name       captive-drivers
11 %if %{with license_agreement}
12 Name:           %{base_name}
13 %else
14 Name:           %{base_name}-installer
15 %endif
16 Version:        0.2
17 %define         _rel    1
18 Release:        %{_rel}%{?with_license_agreement:wla}
19 Group:          Libraries
20 License:        restricted, non-distributable
21 %if %{with license_agreement}
22 # NB! This is 145M download.
23 Source0:        %{source_url}xpsp1a_en_x86_CHK.exe
24 BuildRequires:  cabextract
25 Requires:       captive
26 %else
27 Source0:        license-installer.sh
28 Requires:       cpio
29 Requires:       rpm-build-tools
30 Requires:       wget
31 Provides:       %{base_name}
32 %endif
33 ExclusiveArch:  %{ix86}
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Contains ntfs.sys and ntoskrnl.exe from Windows XP SP1.
38 %if !%{with license_agreement}
39 License issues made us not to include inherent files into this package
40 by default. If you want to create full working package please build it
41 with the following command:
42
43 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
44 %endif
45
46 %description -l pl
47 Pakiet zawieraj±cy ntfs.sys i ntoskrnl.exe z Windows XP SP1.
48 %if !%{with license_agreement}
49 Kwestie licencji zmusi³y nas do niedo³±czania do tego pakietu istotnych
50 plików. Je¶li chcesz stworzyæ w pe³ni funkcjonalny pakiet, zbuduj go za
51 pomoc± polecenia:
52
53 %{base_name}.install --with license_agreement %{_datadir}/%{base_name}/%{base_name}.spec
54 %endif
55
56 %prep
57 %setup -q -c -T
58 %if %{with license_agreement}
59 cabextract %{SOURCE0} -F ntfs.sys
60 cabextract %{SOURCE0} -F ntoskrnl.ex_
61 cabextract ntoskrnl.ex_
62 %endif
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %if !%{with license_agreement}
68 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
69
70 sed -e '
71         s/@BASE_NAME@/%{base_name}/g
72         s/@TARGET_CPU@/%{_target_cpu}/g
73         s-@VERSION@-%{version}-g
74         s-@RELEASE@-%{release}-g
75         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
76 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
77
78 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
79 %else
80 install -d $RPM_BUILD_ROOT/var/lib/captive
81 install ntfs.sys ntoskrnl.exe $RPM_BUILD_ROOT/var/lib/captive
82 %endif
83
84 %if !%{with license_agreement}
85 %post
86 %{_bindir}/%{base_name}.install
87 %endif
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %if %{with license_agreement}
95 /var/lib/captive/*
96 %else
97 %attr(755,root,root) %{_bindir}/%{base_name}.install
98 %{_datadir}/%{base_name}
99 %endif
This page took 0.054739 seconds and 3 git commands to generate.