]> git.pld-linux.org Git - packages/candl.git/commitdiff
- apply update to 0.6.3 as patch applied on top of git patch auto/th/candl-0.6.3-1.20140806.1
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 3 Dec 2015 14:54:29 +0000 (15:54 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 3 Dec 2015 14:54:29 +0000 (15:54 +0100)
candl-0.6.3.patch
candl.spec

index 392e2dc858db9ffde0d492a1c4cf6c0310c1f3c9..0174e296accc6041e7d0499ba52012259d97f6ab 100644 (file)
@@ -13,62 +13,46 @@ diff -Nur candl-0.6.2/ChangeLog candl-0.6.3/ChangeLog
  2012-03-09  Louis-Noel Pouchet  <pouchet@cse.ohio-state.edu>
  
        * configure.in: Bump to candl-0.6.2.
-diff -Nur candl-0.6.2/configure.in candl-0.6.3/configure.in
---- candl-0.6.2/configure.in   2012-03-12 17:45:26.000000000 +0100
-+++ candl-0.6.3/configure.in   2013-02-19 06:27:35.000000000 +0100
-@@ -34,7 +34,7 @@
+--- candl-0.6.2/configure.ac.orig      2015-12-02 21:54:57.513138868 +0100
++++ candl-0.6.3/configure.ac   2015-12-02 21:57:50.153131623 +0100
+@@ -38,7 +38,7 @@
+ AC_PREREQ(2.53)
  
- AC_PREREQ(2.13)
  dnl Fill here the @bug email adress.
 -AC_INIT([candl], [0.6.2], [cedric.bastoul@inria.fr,pouchet@cse.ohio-state.edu])
 +AC_INIT([candl], [0.6.3], [cedric.bastoul@inria.fr,pouchet@cs.ucla.edu])
- dnl A common file, which serve as a test.
- AC_CONFIG_SRCDIR([include/candl/program.h])
- dnl Put as most as possible configuration files to an auxialiry
-diff -Nur candl-0.6.2/include/candl/candl.h candl-0.6.3/include/candl/candl.h
---- candl-0.6.2/include/candl/candl.h  2012-03-12 17:45:37.000000000 +0100
-+++ candl-0.6.3/include/candl/candl.h  2013-02-19 06:40:15.000000000 +0100
-@@ -42,7 +42,7 @@
- #ifndef CANDL_H
- # define CANDL_H
  
--# define CANDL_RELEASE "0.6.2"
-+# define CANDL_RELEASE "0.6.3"
- # define CANDL_VERSION "64"
- # define CANDL_SUPPORTS_SCOPLIB
- # define CANDL_SUPPORTS_ISL
-diff -Nur candl-0.6.2/source/dependence.c candl-0.6.3/source/dependence.c
---- candl-0.6.2/source/dependence.c    2012-03-12 17:19:37.000000000 +0100
-+++ candl-0.6.3/source/dependence.c    2013-02-19 06:27:31.000000000 +0100
-@@ -2261,14 +2261,17 @@
-               pred->next = next;
-             free (tmp);
-           }
--        pred = tmp;
-+        else
-+          pred = tmp;
-         tmp = next;
+ AC_CONFIG_SRCDIR([include/candl/candl.h])
  
--        continue;
-       }
--      /* Go to the next victim. */
+--- candl-0.6.2/source/dependence.c.orig       2015-12-02 21:54:57.516472201 +0100
++++ candl-0.6.3/source/dependence.c    2015-12-02 22:01:56.763121274 +0100
+@@ -1899,14 +1899,15 @@
+           pred->next = next;
+         free(tmp);
+       }
 -      pred = tmp;
--      tmp = tmp->next;
 +      else
-+      {
-+        /* Go to the next victim. */
-+        pred = tmp;
-+        tmp = tmp->next;
-+      }
++        pred = tmp;
+       tmp = next;
+-      continue;
++    } else {
++      /* Go to the next victim. */
++      pred = tmp;
++      tmp = tmp->next;
      }
+-    /* Go to the next victim. */
+-    pred = tmp;
+-    tmp = tmp->next;
+   }
  }
  
-@@ -2455,7 +2458,7 @@
-                         for (l = 0; l < priv_buff_size; ++l)
-                           program->scalars_privatizable[l] = -1;
-                       }
--                    if (nb_priv == priv_buff_size)
-+                    if (nb_priv == priv_buff_size - 2)
-                       {
-                         program->scalars_privatizable =
-                           realloc(program->scalars_privatizable,
+@@ -2122,7 +2123,7 @@
+                 scop_usr->scalars_privatizable[k] = -1;
+             }
+-            if (nb_priv == priv_buff_size) {
++            if (nb_priv == priv_buff_size - 2) {
+               CANDL_realloc(scop_usr->scalars_privatizable, 
+                             int*, (priv_buff_size *= 2) * sizeof(int));
+               for (k = nb_priv; k < priv_buff_size; ++k)
index 96a4d43f6fbf367473bbb71ff7fabef595ddc732..0b6b37f78da007be99db77ba0649cfcbbbba98db 100644 (file)
@@ -1,13 +1,14 @@
-%define                rel     2
 Summary:       Candl - Data Dependence Analysis Tool in the Polyhedral Model
 Summary(pl.UTF-8):     Candl - narzędzie do analizy zależności danych w modelu wielościennym
 Name:          candl
-Version:       0.6.2
-%define        snap    20140806
+Version:       0.6.3
+%define        snap    20140806
+%define        rel     1
 Release:       1.%{snap}.%{rel}
 License:       LGPL v3+
 Group:         Libraries
-Source0:       http://web.cse.ohio-state.edu/~pouchet/software/pocc/download/modules/%{name}-%{version}.tar.gz
+#Source0:      http://web.cse.ohio-state.edu/~pouchet/software/pocc/download/modules/%{name}-0.6.3.tar.gz
+Source0:       http://web.cse.ohio-state.edu/~pouchet/software/pocc/download/modules/%{name}-0.6.2.tar.gz
 # Source0-md5: 4e86392fa46a514b03532f93d9c83f8d
 # git clone git://repo.or.cz/candl.git
 # git diff 0.6.2
@@ -15,6 +16,8 @@ Patch0:               %{name}-git.patch
 Patch1:                %{name}-isl.patch
 Patch2:                %{name}-info.patch
 Patch3:                %{name}-system-libs.patch
+# diff -Nur candl-0.6.2 candl-0.6.3 ; with autogenerated files removed, updated to apply on top of git patch
+Patch4:                %{name}-0.6.3.patch
 URL:           http://icps.u-strasbg.fr/people/bastoul/public_html/development/candl/
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1:1.9
@@ -65,10 +68,11 @@ Static Candl library.
 Statyczna biblioteka Candl.
 
 %prep
-%setup -q
+%setup -q -n %{name}-0.6.2
 # clean after make dist to allow git patch
 %{__rm} include/candl/candl.h
 %patch0 -p1
+%patch4 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
This page took 0.121367 seconds and 4 git commands to generate.