]> git.pld-linux.org Git - packages/cancd.git/blob - cancd.spec
- used template.init from rc-scripts
[packages/cancd.git] / cancd.spec
1 Summary:        The CA NetConsole Daemon
2 Name:           cancd
3 Version:        0.1.0
4 Release:        0.1
5 License:        GPL
6 Group:          Applications/File
7 Source0:        http://oss.oracle.com/projects/cancd/dist/files/source/%{name}-%{version}.tar.gz
8 # Source0-md5:  3eb4a75cfa4d1a860ea547fdc76c6d4d
9 Patch0:         %{name}-make.patch
10 URL:            http://oss.oracle.com/projects/cancd/
11 BuildRequires:  rpmbuild(macros) >= 1.228
12 Requires(post,preun):   /sbin/chkconfig
13 Requires:       /sbin/chkconfig
14 Requires:       rc-scripts
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 This is the CA NetConsole Daemon, a daemon to receive output from the
19 Linux netconsole driver.
20
21 %prep
22 %setup -q
23 %patch0 -p1
24
25 %build
26 %{__make} \
27         CC="%{__cc}" \
28         OPTFLAGS="%{rpmcflags}"
29
30 %install
31 rm -rf $RPM_BUILD_ROOT
32 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
33 %{__make} install \
34         DESTDIR=$RPM_BUILD_ROOT
35
36 > $RPM_BUILD_ROOT/etc/sysconfig/cancd
37
38 %clean
39 rm -rf "$RPM_BUILD_ROOT"
40
41 %post
42 /sbin/chkconfig --add cancd
43 %service cancd restart
44
45 %preun
46 if [ "$1" = "0" ]; then
47         %service cancd stop
48         /sbin/chkconfig --del cancd
49 fi
50
51 %files
52 %defattr(644,root,root,755)
53 %attr(755,root,root) %{_sbindir}/cancd
54 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/cancd
55 %attr(754,root,root) %config /etc/rc.d/init.d/cancd
This page took 0.087902 seconds and 3 git commands to generate.