]> git.pld-linux.org Git - packages/camorama.git/commitdiff
- patches from fedora auto/th/camorama-0.19-2
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 29 Dec 2011 21:10:20 +0000 (21:10 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    camorama.spec -> 1.20
    fixes.patch -> 1.1
    libv4l.patch -> 1.1
    new-glib.patch -> 1.1
    no-more-videodev_h.patch -> 1.1

camorama.spec
fixes.patch [new file with mode: 0644]
libv4l.patch [new file with mode: 0644]
new-glib.patch [new file with mode: 0644]
no-more-videodev_h.patch [new file with mode: 0644]

index 7ac3e4e9a310a6abe2219529623521067db66163..5e96e0cb94ab23284fbd0b8421a91efd453cd9e1 100644 (file)
@@ -2,13 +2,17 @@ Summary:      GNOME webcam program
 Summary(pl.UTF-8):     Program do kamer internetowych dla GNOME
 Name:          camorama
 Version:       0.19
-Release:       1
+Release:       2
 License:       GPL v2
 Group:         X11/Applications
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/camorama/0.19/%{name}-%{version}.tar.bz2
 # Source0-md5: 75025ba37d1dd1c398d92ba2dbef43ee
 Patch0:                %{name}-schemas.patch
 Patch1:                %{name}-desktop.patch
+Patch2:                fixes.patch
+Patch3:                libv4l.patch
+Patch4:                no-more-videodev_h.patch
+Patch5:                new-glib.patch
 URL:           http://camorama.fixedgear.org/
 BuildRequires: GConf2-devel
 BuildRequires: autoconf >= 2.53
@@ -40,8 +44,12 @@ innymi kamerami.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
-sed -i -e s#sr\@Latn#sr\@latin# configure.in
+%{__sed} -i -e s#sr\@Latn#sr\@latin# configure.in
 mv -f po/sr\@{Latn,latin}.po
 
 %build
diff --git a/fixes.patch b/fixes.patch
new file mode 100644 (file)
index 0000000..efc30a3
--- /dev/null
@@ -0,0 +1,105 @@
+--- camorama-0.19/src/callbacks.c      2007-09-16 15:36:55.000000000 +0200
++++ camorama-0.19.new/src/callbacks.c  2008-06-29 22:22:44.000000000 +0200
+@@ -387,9 +387,6 @@
+         }
+     }
+-    cam->pixmap = gdk_pixmap_new (NULL, cam->x, cam->y, cam->desk_depth);
+-    gtk_widget_set_size_request (glade_xml_get_widget (cam->xml, "da"),
+-                                 cam->x, cam->y);
+     /*
+      * if(cam->read == FALSE) {
+@@ -441,6 +438,11 @@
+      * * } 
+      */
+     get_win_info (cam);
++
++    cam->pixmap = gdk_pixmap_new (NULL, cam->x, cam->y, cam->desk_depth);
++    gtk_widget_set_size_request (glade_xml_get_widget (cam->xml, "da"),
++                                 cam->x, cam->y);
++
+     frame = 0;
+     gtk_window_resize (GTK_WINDOW
+                        (glade_xml_get_widget (cam->xml, "main_window")), 320,
+@@ -520,8 +522,14 @@
+     gtk_widget_show (about);
+ }
++void
++camorama_filter_color_filter(void* filter, guchar *image, int x, int y, int depth);
++
+ static void
+ apply_filters(cam* cam) {
++      /* v4l has reverse rgb order from what camora expect so call the color
++         filter to fix things up before running the user selected filters */
++      camorama_filter_color_filter(NULL, cam->pic_buf, cam->x, cam->y, cam->depth);
+       camorama_filter_chain_apply(cam->filter_chain, cam->pic_buf, cam->x, cam->y, cam->depth);
+ #warning "FIXME: enable the threshold channel filter"
+ //    if((effect_mask & CAMORAMA_FILTER_THRESHOLD_CHANNEL)  != 0) 
+--- camorama-0.19/src/filter.c 2007-09-16 14:48:50.000000000 +0200
++++ camorama-0.19.new/src/filter.c     2008-06-29 22:11:42.000000000 +0200
+@@ -151,12 +151,12 @@
+ static void
+ camorama_filter_color_init(CamoramaFilterColor* self) {}
+-static void
++void
+ camorama_filter_color_filter(CamoramaFilterColor* filter, guchar *image, int x, int y, int depth) {
+       int i;
+       char tmp;
+       i = x * y;
+-      while (--i) {
++      while (i--) {
+               tmp = image[0];
+               image[0] = image[2];
+               image[2] = tmp;
+--- camorama-0.19/src/main.c   2007-09-16 15:36:55.000000000 +0200
++++ camorama-0.19.new/src/main.c       2008-06-29 22:20:04.000000000 +0200
+@@ -224,8 +224,7 @@
+     /* get picture attributes */
+     get_pic_info (cam);
+-//    set_pic_info(cam);
+-    /* set_pic_info(cam); */
++    set_pic_info (cam);
+     cam->contrast = cam->vid_pic.contrast;
+     cam->brightness = cam->vid_pic.brightness;
+     cam->colour = cam->vid_pic.colour;
+--- camorama-0.19/src/v4l.c    2007-09-16 14:48:05.000000000 +0200
++++ camorama-0.19.new/src/v4l.c        2008-06-29 22:20:23.000000000 +0200
+@@ -158,8 +158,8 @@
+       if(cam->debug) {
+               g_message("SET PIC");
+       }
+-      //cam->vid_pic.palette = VIDEO_PALETTE_RGB24;
+-      //cam->vid_pic.depth = 24;
++      cam->vid_pic.palette = VIDEO_PALETTE_RGB24;
++      cam->vid_pic.depth = 24;
+       //cam->vid_pic.palette = VIDEO_PALETTE_YUV420P;
+       if(ioctl(cam->dev, VIDIOCSPICT, &cam->vid_pic) == -1) {
+               if(cam->debug) {
+@@ -232,6 +232,8 @@
+       exit(0);
+    }
++   cam->x = cam->vid_win.width;
++   cam->y = cam->vid_win.height;
+ }
+ void set_buffer(cam * cam)
+--- camorama-0.19/src/camorama-window.c~       2007-09-16 15:36:55.000000000 +0200
++++ camorama-0.19/src/camorama-window.c        2009-06-23 20:19:16.000000000 +0200
+@@ -209,11 +209,7 @@ load_interface(cam* cam) {
+     logo = gtk_icon_theme_load_icon(gtk_icon_theme_get_for_screen(gtk_widget_get_screen(glade_xml_get_widget(cam->xml, "main_window"))), CAMORAMA_STOCK_WEBCAM, 24, 0, NULL);
+     gtk_window_set_default_icon(logo);
+-    logo = (GdkPixbuf *) create_pixbuf (PACKAGE_DATA_DIR "/pixmaps/camorama.png");
+-    if (logo == NULL) {
+-        printf ("\n\nLOGO NO GO\n\n");
+-    }
+-
++    logo = gtk_icon_theme_load_icon(gtk_icon_theme_get_for_screen(gtk_widget_get_screen(glade_xml_get_widget(cam->xml, "main_window"))), "camorama", 48, 0, NULL);
+     if (cam->show_adjustments == FALSE) {
+         gtk_widget_hide (glade_xml_get_widget
+                          (cam->xml, "adjustments_table"));
diff --git a/libv4l.patch b/libv4l.patch
new file mode 100644 (file)
index 0000000..b4c0e55
--- /dev/null
@@ -0,0 +1,196 @@
+--- camorama-0.19/src/Makefile.am      2007-09-16 14:48:05.000000000 +0200
++++ camorama-0.19.new/src/Makefile.am  2009-06-24 15:01:37.000000000 +0200
+@@ -36,7 +36,7 @@
+       filter.h        \
+       $(BUILT_SOURCES)\
+       $(NULL)
+-camorama_LDADD = $(PACKAGE_LIBS)
++camorama_LDADD = $(PACKAGE_LIBS) -lv4l1
+ DISTCLEANFILES=$(BUILT_SOURCES)
+--- camorama-0.19/src/Makefile.in      2007-10-06 21:06:28.000000000 +0200
++++ camorama-0.19.new/src/Makefile.in  2009-06-24 15:01:50.000000000 +0200
+@@ -248,7 +248,7 @@
+       $(BUILT_SOURCES)\
+       $(NULL)
+-camorama_LDADD = $(PACKAGE_LIBS)
++camorama_LDADD = $(PACKAGE_LIBS) -lv4l1
+ DISTCLEANFILES = $(BUILT_SOURCES)
+ all: $(BUILT_SOURCES)
+       $(MAKE) $(AM_MAKEFLAGS) all-am
+--- camorama-0.19/src/callbacks.c      2009-06-24 15:01:55.000000000 +0200
++++ camorama-0.19.new/src/callbacks.c  2009-06-24 14:55:42.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include <libgnomeui/gnome-propertybox.h>
+ #include <libgnomeui/gnome-window-icon.h>
+ #include <pthread.h>
++#include <libv4l1.h>
+ extern GtkWidget *main_window, *prefswindow;
+ //extern state func_state;
+@@ -390,7 +391,7 @@
+     /*
+      * if(cam->read == FALSE) {
+-     *  cam->pic = mmap(0, cam->vid_buf.size, PROT_READ | PROT_WRITE, MAP_SHARED, cam->dev, 0);
++     *  cam->pic = v4l1_mmap(0, cam->vid_buf.size, PROT_READ | PROT_WRITE, MAP_SHARED, cam->dev, 0);
+      *  
+      *  if((unsigned char *) -1 == (unsigned char *) cam->pic) {
+      *   if(cam->debug == TRUE) {
+@@ -401,7 +402,7 @@
+      *  }
+      *  }else{
+      *   cam->pic_buf = malloc(cam->x * cam->y * cam->depth);
+-     *   read(cam->dev,cam->pic,(cam->x * cam->y * 3));
++     *   v4l1_read(cam->dev,cam->pic,(cam->x * cam->y * 3));
+      *  } 
+      */
+@@ -427,7 +428,7 @@
+      * if(cam->read == FALSE) {
+      * * for(frame = 0; frame < cam->vid_buf.frames; frame++) {
+      * * cam->vid_map.frame = frame;
+-     * * if(ioctl(cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
++     * * if(v4l1_ioctl(cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
+      * * if(cam->debug == TRUE) {
+      * * fprintf(stderr, "Unable to capture image (VIDIOCMCAPTURE) during resize.\n");
+      * * }
+@@ -547,7 +548,7 @@
+     int i, count = 0;
+     GdkGC *gc;
+-    read (cam->dev, cam->pic, (cam->x * cam->y * 3));
++    v4l1_read (cam->dev, cam->pic, (cam->x * cam->y * 3));
+     frames2++;
+     /*
+      * update_rec.x = 0;
+@@ -588,7 +589,7 @@
+     i = -1;
+     while (i < 0) {
+-        i = ioctl (cam->dev, VIDIOCSYNC, &frame);
++        i = v4l1_ioctl (cam->dev, VIDIOCSYNC, &frame);
+         if (i < 0 && errno == EINTR) {
+             if (cam->debug == TRUE) {
+@@ -630,7 +631,7 @@
+                                 0, cam->x, cam->y);
+     cam->vid_map.frame = frame;
+-    if (ioctl (cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
++    if (v4l1_ioctl (cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
+         if (cam->debug == TRUE) {
+             fprintf (stderr, "Unable to capture image (VIDIOCMCAPTURE)\n");
+         }
+@@ -677,7 +678,7 @@
+ void init_cam (GtkWidget * capture, cam * cam)
+ {
+     cam->pic =
+-        mmap (0, cam->vid_buf.size, PROT_READ | PROT_WRITE,
++        v4l1_mmap (0, cam->vid_buf.size, PROT_READ | PROT_WRITE,
+               MAP_SHARED, cam->dev, 0);
+     if ((unsigned char *) -1 == (unsigned char *) cam->pic) {
+@@ -692,7 +693,7 @@
+     cam->vid_map.format = cam->vid_pic.palette;
+     for (frame = 0; frame < cam->vid_buf.frames; frame++) {
+         cam->vid_map.frame = frame;
+-        if (ioctl (cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
++        if (v4l1_ioctl (cam->dev, VIDIOCMCAPTURE, &cam->vid_map) < 0) {
+             if (cam->debug == TRUE) {
+                 fprintf (stderr,
+                          "Unable to capture image (VIDIOCMCAPTURE).\n");
+--- camorama-0.19/src/main.c   2009-06-24 15:01:55.000000000 +0200
++++ camorama-0.19.new/src/main.c       2009-06-24 14:59:35.000000000 +0200
+@@ -9,6 +9,7 @@
+ #include <gdk-pixbuf-xlib/gdk-pixbuf-xlib.h>
+ #include <gdk-pixbuf-xlib/gdk-pixbuf-xlibrgb.h>
+ #include <locale.h>
++#include <libv4l1.h>
+ #include "camorama-display.h"
+ #include "camorama-stock-items.h"
+@@ -206,7 +207,7 @@
+     gdk_pixbuf_xlib_init (display, 0);
+     cam->desk_depth = xlib_rgb_get_depth ();
+-    cam->dev = open (cam->video_dev, O_RDWR);
++    cam->dev = v4l1_open (cam->video_dev, O_RDWR);
+     camera_cap (cam);
+     get_win_info (cam);
+@@ -284,5 +285,8 @@
+     gtk_timeout_add (2000, (GSourceFunc) fps, cam->status);
+     gtk_main ();
++    v4l1_munmap(cam->pic, cam->vid_buf.size);
++    v4l1_close(cam->dev);
++    
+     return 0;
+ }
+--- camorama-0.19/src/v4l.c    2009-06-24 15:01:55.000000000 +0200
++++ camorama-0.19.new/src/v4l.c        2009-06-24 14:54:09.000000000 +0200
+@@ -2,6 +2,7 @@
+ #include<time.h>
+ #include<errno.h>
+ #include<gnome.h>
++#include <libv4l1.h>
+ #include "support.h"
+ extern int frame_number;
+@@ -87,7 +88,7 @@
+ void camera_cap(cam * cam)
+ {
+    char *msg;
+-   if(ioctl(cam->dev, VIDIOCGCAP, &cam->vid_cap) == -1) {
++   if(v4l1_ioctl(cam->dev, VIDIOCGCAP, &cam->vid_cap) == -1) {
+       if(cam->debug == TRUE) {
+          fprintf(stderr, "VIDIOCGCAP  --  could not get camera capabilities, exiting.....\n");
+       }
+@@ -161,7 +162,7 @@
+       cam->vid_pic.palette = VIDEO_PALETTE_RGB24;
+       cam->vid_pic.depth = 24;
+       //cam->vid_pic.palette = VIDEO_PALETTE_YUV420P;
+-      if(ioctl(cam->dev, VIDIOCSPICT, &cam->vid_pic) == -1) {
++      if(v4l1_ioctl(cam->dev, VIDIOCSPICT, &cam->vid_pic) == -1) {
+               if(cam->debug) {
+                       g_message("VIDIOCSPICT  --  could not set picture info, exiting....");
+               }
+@@ -176,7 +177,7 @@
+ //set_pic_info(cam);
+    char *msg;
+       
+-   if(ioctl(cam->dev, VIDIOCGPICT, &cam->vid_pic) == -1) {
++   if(v4l1_ioctl(cam->dev, VIDIOCGPICT, &cam->vid_pic) == -1) {
+       msg = g_strdup_printf(_("Could not connect to video device (%s).\nPlease check connection."), cam->video_dev);
+       error_dialog(msg);
+       if(cam->debug == TRUE) {
+@@ -201,7 +202,7 @@
+ void get_win_info(cam * cam)
+ {
+    gchar *msg;
+-   if(ioctl(cam->dev, VIDIOCGWIN, &cam->vid_win) == -1) {
++   if(v4l1_ioctl(cam->dev, VIDIOCGWIN, &cam->vid_win) == -1) {
+       msg = g_strdup_printf(_("Could not connect to video device (%s).\nPlease check connection."), cam->video_dev);
+       error_dialog(msg);
+       if(cam->debug == TRUE) {
+@@ -222,7 +223,7 @@
+ void set_win_info(cam * cam)
+ {
+    gchar *msg;
+-   if(ioctl(cam->dev, VIDIOCSWIN, &cam->vid_win) == -1) {
++   if(v4l1_ioctl(cam->dev, VIDIOCSWIN, &cam->vid_win) == -1) {
+       msg = g_strdup_printf(_("Could not connect to video device (%s).\nPlease check connection."), cam->video_dev);
+       error_dialog(msg);
+       if(cam->debug == TRUE) {
+@@ -239,7 +240,7 @@
+ void set_buffer(cam * cam)
+ {
+    char *msg;
+-   if(ioctl(cam->dev, VIDIOCGMBUF, &cam->vid_buf) == -1) {
++   if(v4l1_ioctl(cam->dev, VIDIOCGMBUF, &cam->vid_buf) == -1) {
+       msg = g_strdup_printf(_("Could not connect to video device (%s).\nPlease check connection."), cam->video_dev);
+       error_dialog(msg);
+       if(cam->debug == TRUE) {
diff --git a/new-glib.patch b/new-glib.patch
new file mode 100644 (file)
index 0000000..407700c
--- /dev/null
@@ -0,0 +1,32 @@
+--- camorama-0.19/src/camorama-stock-items.h   2007-06-14 16:05:33.000000000 +0200
++++ camorama-0.19.new/src/camorama-stock-items.h       2011-12-10 08:32:09.856317100 +0100
+@@ -1,7 +1,7 @@
+ #ifndef CAMORAMA_STOCK_ITEMS_H
+ #define CAMORAMA_STOCK_ITEMS_H
+-#include <glib/gmacros.h>
++#include <glib.h>
+ G_BEGIN_DECLS
+--- camorama-0.19/src/camorama-window.c        2011-12-10 08:51:10.552056445 +0100
++++ camorama-0.19.new/src/camorama-window.c    2011-12-10 08:50:52.068287522 +0100
+@@ -28,6 +28,7 @@
+ # include <config.h>
+ #endif
++#include <glib.h>
+ #include <glib/gi18n.h>
+ #include <libgnomeui/gnome-file-entry.h>
+ #include "callbacks.h"
+--- camorama-0.19/src/glib-helpers.h   2007-06-14 16:05:33.000000000 +0200
++++ camorama-0.19.new/src/glib-helpers.h       2011-12-10 08:33:22.534408498 +0100
+@@ -24,7 +24,7 @@
+ #ifndef GLIB_HELPERS_H
+ #define GLIB_HELPERS_H
+-#include <glib/gmacros.h>
++#include <glib.h>
+ G_BEGIN_DECLS
diff --git a/no-more-videodev_h.patch b/no-more-videodev_h.patch
new file mode 100644 (file)
index 0000000..8769678
--- /dev/null
@@ -0,0 +1,13 @@
+diff -up camorama-0.19/src/v4l.h~ camorama-0.19/src/v4l.h
+--- camorama-0.19/src/v4l.h~   2007-09-16 15:36:55.000000000 +0200
++++ camorama-0.19/src/v4l.h    2011-02-09 22:48:17.317513026 +0100
+@@ -12,8 +12,7 @@
+ #include <sys/mman.h>
+ #include <fcntl.h>
+ #include <gtk/gtk.h>
+-#include <linux/types.h>
+-#include <linux/videodev.h>
++#include <libv4l1.h>
+ #include <signal.h>
+ #include <png.h>
+ #include <glade/glade.h>
This page took 0.309698 seconds and 4 git commands to generate.