]> git.pld-linux.org Git - packages/camlp5.git/blame_incremental - camlp5.spec
- updated to 6.15
[packages/camlp5.git] / camlp5.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_without ocaml_opt # skip building native optimized binaries (bytecode is always built)
4
5# not yet available on x32 (ocaml 4.02.1), update when upstream will support it
6%ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9
7%undefine with_ocaml_opt
8%endif
9
10Summary: Objective Caml Preprocessor
11Summary(pl.UTF-8): Preprocesor OCamla
12Name: camlp5
13Version: 6.15
14Release: 1
15License: distributable
16Group: Development/Languages
17Source0: http://camlp5.gforge.inria.fr/distrib/src/%{name}-%{version}.tgz
18# Source0-md5: ad79f4b4384109fbb92b1b3bcb105224
19Source1: http://camlp5.gforge.inria.fr/doc/pdf/%{name}-6.00.pdf
20# Source1-md5: b241eabfeb48f22b0fbd3e497198a76a
21URL: http://caml.inria.fr/
22BuildRequires: db-devel >= 4.1
23BuildRequires: ocaml
24%requires_eq ocaml-runtime
25Requires: %{name} = %{epoch}:%{version}-%{release}
26BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28%description
29Camlp5 is a Pre-Processor-Pretty-Printer for Objective Caml. It offers
30tools for syntax (grammars) and the ability to modify the concrete
31syntax of the language (quotations, syntax extensions).
32
33Camlp5 can parse normal Ocaml concrete syntax or any other
34user-definable syntax. As an example, an alternative syntax is
35provided, named revised, because it tries to fix some small problems
36of the normal syntax.
37
38Camlp5 can pretty print the normal Ocaml concrete syntax or the
39revised one. It is therefore always possible to have a version of your
40sources compilable by the Objective Caml compiler without
41preprocessing.
42
43%description -l pl.UTF-8
44Camlp5 jest preprocesorem OCamla. Oferuje narzędzia do manipulowania
45składnią (gramatyki) oraz możliwość modyfikowania oryginalnej składni
46języka (cytowania, rozszerzenia).
47
48Camlp5 może sparsować oryginalną składnię Ocamla lub dowolną inną
49definiowalną przez użytkownika. Jako przykład podana jest alternatywna
50składnia (revised syntax), która próbuje poprawić drobne problemy
51występujące w składni oryginalnej.
52
53Camlp5 umie ładnie formatować źródła zarówno w oryginalnej jak i
54poprawionej składni OCamla. Potrafi także tłumaczyć programy z jednej
55składni na drugą.
56
57%package doc-html
58Summary: Objective Caml Preprocessor - HTML documentation
59Summary(pl.UTF-8): Preprocesor OCamla - dokumentacja HTML
60Group: Development/Languages
61
62%description doc-html
63Objective Caml Preprocessor - HTML documentation.
64
65%description doc-html -l pl.UTF-8
66Preprocesor OCamla - dokumentacja HTML.
67
68%prep
69%setup -q
70
71cp %{SOURCE1} doc/camlp4.pdf
72
73%build
74./configure \
75 -bindir %{_bindir} \
76 -libdir %{_libdir}/ocaml \
77 -mandir %{_mandir}/man1 \
78 -transitional
79
80%{__make} -j1 world%{?with_ocaml_opt:.opt}
81%{__make} -j1 -C doc/htmlp
82
83%install
84rm -rf $RPM_BUILD_ROOT
85
86%{__make} install \
87 BINDIR=$RPM_BUILD_ROOT%{_bindir} \
88 LIBDIR=$RPM_BUILD_ROOT%{_libdir}/ocaml \
89 MANDIR=$RPM_BUILD_ROOT%{_mandir}
90
91# broken build system
92for f in mkcamlp5.1 ocpp5.1 camlp5o.1 camlp5r.1 camlp5sch.1 \
93 %{?with_ocaml_opt:camlp5o.opt.1 camlp5r.opt.1 mkcamlp5.opt.1} ; do
94 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/$f
95 echo '.so camlp5.1' >$RPM_BUILD_ROOT%{_mandir}/man1/$f
96done
97
98%clean
99rm -rf $RPM_BUILD_ROOT
100
101%files
102%defattr(644,root,root,755)
103%doc CHANGES DEVEL ICHANGES MODE README UPGRADING doc/camlp4.pdf
104%attr(755,root,root) %{_bindir}/camlp5*
105%attr(755,root,root) %{_bindir}/mkcamlp5*
106%attr(755,root,root) %{_bindir}/ocpp5
107%{_libdir}/ocaml/%{name}
108%{_mandir}/man1/camlp5*.1*
109%{_mandir}/man1/mkcamlp5*.1*
110%{_mandir}/man1/ocpp5.1*
111
112%files doc-html
113%defattr(644,root,root,755)
114%doc doc/html/*
This page took 0.063386 seconds and 4 git commands to generate.