]> git.pld-linux.org Git - packages/callback.git/commitdiff
- initial
authorSebastian Zagrodzki <sebek@zagrodzki.net>
Tue, 23 Nov 1999 14:50:28 +0000 (14:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    callback-Makefiles.patch -> 1.1
    callback.FAQ -> 1.1

callback-Makefiles.patch [new file with mode: 0644]
callback.FAQ [new file with mode: 0644]

diff --git a/callback-Makefiles.patch b/callback-Makefiles.patch
new file mode 100644 (file)
index 0000000..761def7
--- /dev/null
@@ -0,0 +1,202 @@
+diff -Naur callback/Makefile callback3/Makefile
+--- callback/Makefile  Thu Jan  1 01:00:00 1970
++++ callback3/Makefile Tue Nov 23 14:39:05 1999
+@@ -0,0 +1,25 @@
++MAKE  =make
++CC    =gcc
++CFLAGS        =-O2
++LDFLAGS       =-s
++
++all: cblib cbcb cbmgetty cblogin
++
++cblib:
++      $(MAKE) -C lib
++
++cbcb:
++      $(MAKE) -C cb
++
++cbmgetty:
++      $(MAKE) -C mgetty
++      
++cblogin:
++      $(MAKE) -C login
++
++clean:
++      $(MAKE) -C lib clean
++      $(MAKE) -C cb clean
++      $(MAKE) -C mgetty clean
++      $(MAKE) -C login clean
++
+diff -Naur callback/cb/Makefile callback3/cb/Makefile
+--- callback/cb/Makefile       Thu Jan  1 01:00:00 1970
++++ callback3/cb/Makefile      Tue Nov 23 14:39:05 1999
+@@ -0,0 +1,15 @@
++MAKE  =make
++CC    =gcc
++CFLAGS        =-O2
++LDFLAGS       =-s
++
++CBSOU =cb.c enable.c list.c needcbmode.c task.c \
++         cbdata.c error.c logging.c preusage.c usage.c \
++         disable.c force.c maybeforce.c state.c usettyline.c
++
++cb:   $(CBSOU)
++              $(CC) $(CFLAGS) -c $(CBSOU)
++              $(CC) $(LDFLAGS) -o cb *.o -lrss -L. -L../lib
++
++clean:
++      rm -f *.o cb
+diff -Naur callback/lib/Makefile callback3/lib/Makefile
+--- callback/lib/Makefile      Thu Jan  1 01:00:00 1970
++++ callback3/lib/Makefile     Tue Nov 23 14:39:05 1999
+@@ -0,0 +1,112 @@
++MAKE  =make
++CC    =gcc
++CFLAGS        =-O2
++LDFLAGS       =-s
++
++DBASE =activefiles.c enablestate.c makeactive.c states.c \
++       ageof.c fgetline.c makeconfigfile.c tellstate.c \
++       appendline.c getfile.c makefilenames.c toactivefile.c \
++       assignfilenames.c getmaxage.c modemfile.c unlinkfiles.c \
++       copyfile.c getstate.c nologin.c updatecbstate.c \
++       cpfile.c linename.c setcallback.c writestate.c \
++       dbasedata.c load.c setmaxage.c xfopen.c
++
++PARSER        =lexer.c parser.c parsesetupfile.c yysemantic.c \
++       parseerror.c parserdata.c yyerror.c
++
++START =getprogname.c setprogname.c startup.c startupdata.c
++
++TTYL  =activatettyline.c getdefaulttty.c lookuptty.c \
++       activatettylines.c gettyline.c resetactivetty.c \
++       getactivetty.c lineindex.c settyline.c ttylinedata.c
++
++DGR   =addgroup.c dgroupindex.c lookgroup.c \
++       dgroupdata.c dgroupname.c newgroup.c
++
++DES   =askextranumber.c getdgroupindex.c getphone.c setmode.c \
++       definedest.c getdnameindex.c listdestinations.c setphone.c \
++       destdata.c getfilename.c setdname.c setphonenr.c \
++       getbuf.c getlinetouse.c setfile.c tagdnames.c \
++       getdestmode.c getndestinations.c setline.c
++
++USR   =combine.c lastuser.c lastusergroupindex.c userdata.c username.c \
++       defineuser.c lastusergroup.c lookuser.c usergroup.c userngroups.c
++
++DNAME =checkdname.c dnamedata.c dnameindex.c getdname.c initdnames.c \
++       lookdname.c
++
++PROC  =availlinelist.c killinit.c modemrespawn.c switchtty.c \
++       getanothertty.c linestate.c processdata.c
++
++MEM   =memdata.c xmalloc.c xrealloc.c xstrdup.c
++
++LOG   =getdiallogfilename.c log.c setdiallogfilename.c setpanicfilename.c \
++       getlogfilename.c logdata.c setlog.c \
++       getlogtypestring.c logdefaults.c setlogdefaults.c \
++       getpanicfilename.c logv.c setlogfilename.c \
++
++CONF  =checkconfig.c getmode.c hidedestinations.c setmodembase.c \
++       configdata.c getmodembase.c setbase.c setntries.c \
++       getbase.c getntries.c setcall.c showdestinations.c \
++       getcall.c givedestinations.c setemailaddress.c showdirect.c \
++       getemailaddress.c givedirect.c setloginprogram.c showextra.c \
++       getlogin.c giveextra.c setmgettypath.c showphonenumbers.c \
++       getmgettypath.c givephonenumbers.c setmode.c
++
++librss.a: cbdbase cbparser cbstartup cbttyline cbdgroup cbdest cbuser \
++        cbdname cbprocess cbconfig cbmem cblog cbversion
++        ar rs librss.a *.o */*.o
++
++cbversion:
++      $(CC) $(CFLAGS) -c version.c
++
++cbconfig:
++      ( cd config ; \
++      $(CC) $(CFLAGS) -c $(CONF) )
++
++cbdbase:
++      ( cd dbase ; \
++      $(CC) $(CFLAGS) -c $(DBASE) )
++
++cbparser:
++      ( cd parser ; \
++      $(CC) $(CFLAGS) -c $(PARSER) )
++
++cbstartup:
++      ( cd startup ; \
++      $(CC) $(CFLAGS) -c $(START) )
++
++cbttyline:
++      ( cd ttyline ; \
++      $(CC) $(CFLAGS) -c $(TTYL) )
++
++cbdgroup:
++      ( cd dgroup ; \
++      $(CC) $(CFLAGS) -c $(DGR) )
++
++cbdest:
++      ( cd dest ; \
++      $(CC) $(CFLAGS) -c $(DES) )
++
++cbuser:
++      ( cd user ; \
++      $(CC) $(CFLAGS) -c $(USR) )
++      
++cbdname:
++      ( cd dname ; \
++      $(CC) $(CFLAGS) -c $(DNAME) )
++
++cbprocess:
++      ( cd process ; \
++      $(CC) $(CFLAGS) -c $(PROC) )
++
++cblog:
++      ( cd log ; \
++      $(CC) $(CFLAGS) -c $(LOG) )
++
++cbmem:
++      ( cd mem ; \
++      $(CC) $(CFLAGS) -c $(MEM) )
++      
++clean:
++      rm -f *.o */*.o librss.a
+diff -Naur callback/login/Makefile callback3/login/Makefile
+--- callback/login/Makefile    Thu Jan  1 01:00:00 1970
++++ callback3/login/Makefile   Tue Nov 23 14:39:05 1999
+@@ -0,0 +1,16 @@
++MAKE  =make
++CC    =gcc
++CFLAGS        =-O2
++LDFLAGS       =-s
++
++LOGSOU        =banner.c   determinetty.c   execlogin.c  login.c  firstlogin.c \
++       validate.c getdestination.c cblogin.c    error.c
++
++cblogin:
++      $(CC) $(CFLAGS) -c $(LOGSOU)
++      $(CC) $(LDFLAGS) -o cblogin *.o -lrss -L. -L../lib
++
++clean:
++      rm -f *.o cblogin
++
++
+diff -Naur callback/mgetty/Makefile callback3/mgetty/Makefile
+--- callback/mgetty/Makefile   Thu Jan  1 01:00:00 1970
++++ callback3/mgetty/Makefile  Tue Nov 23 14:39:05 1999
+@@ -0,0 +1,14 @@
++MAKE  =make
++CC    =gcc
++CFLAGS        =-O2
++LDFLAGS       =-s
++
++MGETSOU       =aux/error.c cbmgetty.c
++
++cbmgetty:
++      $(CC) $(CFLAGS) -c cbmgetty.c
++      ( cd aux; $(CC) $(CFLAGS) -c error.c )
++      $(CC) $(LFLAGS) -o cbmgetty *.o aux/*.o -lrss -L. -L../lib
++
++clean:
++      rm -f *.o aux/*.o cbmgetty
diff --git a/callback.FAQ b/callback.FAQ
new file mode 100644 (file)
index 0000000..425e3d3
--- /dev/null
@@ -0,0 +1,121 @@
+In this file the Callback Frequently Asked Questions are assembled.
+This file is part of the distribution, but not necessarily the most recent
+version of the FAQ. 
+
+The most recent version of the callback FAQ can be found at ftp.icce.rug.nl,
+directory pub/unix, file callback.FAQ
+
+Q:'s are questions, A:'s answers
+
+
+Icmake won't run
+~~~~~~~~~~~~~~~~
+
+Q:
+    The problems I had are the following.
+    I installed the icmake, i download the .bin version I copied all the
+    files within /usr/local/bin. It seems to work.
+    Then I unpacked the callback 4.10, but as soon as I run build
+    I get this:
+
+
+    ICCE Make Utility  Version 6.10
+    Copyright (c) ICCE 1992-1994. All rights reserved.
+    ICMAKE consists of a set of five programs. Together, they can
+    be used for managing program development comparable to, e.g.,
+    the UNIX make facility, or as a SHELL-script language.
+    ...
+
+A:
+    Get the most recent icmake distribution from ftp.icce.rug.nl/pub/unix,
+    icmake-X.Y.bin.tgz, and install the icmake binaries in /usr/local/bin
+    The callback 'build' script assumes the icmake programs in /usr/local/bin,
+    as can be seen from the headerline of the 'build' script:
+    
+    #!/usr/local/bin/icmake -qt /tmp/callback
+
+    Also, you need a /tmp directory that is writable for the user starting the
+    'build' script
+    
+
+the build script doesn't do the compilation
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+Q:
+   I'm just compiling the callback package now, and find that the build
+   didn't go through the first time because I, like many people, don't keep
+   "." in the search path (for security reasons). The script changes
+   directory to lib, then runs "build", and fails to find it. If the script
+   were instead to run "./build"  everything would be fine.
+
+A:
+    the shortest solution is to change your path temporarily so that it
+    takes . as well. Alternatively, change the lines in the build script
+    where other build-scripts are called (e.g.,
+            
+                    system("build");
+
+    into
+                    system("./build");
+
+    It will be repaired in the next release
+    
+the build script won't run
+~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+Q:
+    I'm trying to install callback but during instalation I'can't to run the
+    program 'build'. Such communicate is displying 'No such file or directory'
+    though this program exist in my catalog.
+A:
+    You must have the icmake programs in /usr/local/bin, as you can see 
+    from the first line in the build-script. If you start icmake without 
+    arguments it should show 'Version 6.11'. If you start icmake, and you 
+    get the usage information, then maybe one of the programs used in the 
+    build-script are not on your system. You need:
+        rm, echo, cp, cat, touch, chmod,
+        bison, flex, strip, ar, mkdir, gcc
+    and for the documentation:
+        groff gzip        
+    And, of course, the 'build'-script itself must be in your path. 
+
+    Furthermore, the build-script uses the /tmp directory for temporary files. 
+    This directory must be readable/writable/executable for you. If 
+    you do not have the most recent version of either callback or icmake, 
+    try to upgrade: the most recent version of all our software is at 
+    ftp.icce.rug.nl, /pub/unix.
+
+logv.c won't compile
+~~~~~~~~~~~~~~~~~~~~
+
+Q:
+    When I invoked build, it work for a few seconds, and then.... It was very
+    unhappy about your C++ comment in lib/log/logv.c! (You haven't been
+    commenting your program in last minutes have you? ;-)
+    
+A:
+    Indeed, there is a C++ comment in that source. My compiler (2.7.2) doesn't
+    choke on it, though. Anyway, remove the comment in lib/log/logv.c and it
+    compiles fine. Jesper Pedersen who sent me the mail wrote next:
+    
+        I use 2.7.0....Hmm glad that gcc now likes //, I've often compiled with
+        g++ just to get this feature.
+    
+    So, the compiler version solves the problem as well.
+
+cblogin isn't started
+~~~~~~~~~~~~~~~~~~~~~
+
+Q:
+
+> I beleive that you have forgotten to tell in the manual that if one
+> install mgetty himself, he has to remember to add a line like this:
+> *       -       -       /usr/local/lib/callback/cblogin @
+
+A:
+    the question solves the problem itself. It's in the INSTALL file of
+    the next release, but as of now, I home this will be sufficient.
+    
This page took 0.123234 seconds and 4 git commands to generate.