]> git.pld-linux.org Git - packages/california.git/commitdiff
- fix building with evolution-data-server 3.14+ (patch from fedora) auto/th/california-0.4.0-2
authorJan Rękorajski <baggins@pld-linux.org>
Sun, 12 Apr 2015 07:34:21 +0000 (09:34 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sun, 12 Apr 2015 07:34:21 +0000 (09:34 +0200)
- rel 2

california.spec
evolution-data-server-3.14.patch [new file with mode: 0644]

index 9b4ef190dc2c1e69737d86a346d592de751d42aa..cf02beeaef418b9d1b9b1f49d455dbf9b57f9066 100644 (file)
@@ -2,11 +2,12 @@ Summary:      California - GNOME 3 Calendar
 Summary(pl.UTF-8):     California - kalendarz dla GNOME 3
 Name:          california
 Version:       0.4.0
-Release:       1
+Release:       2
 License:       LGPL v2.1+
 Group:         X11/Applications
 Source0:       http://ftp.gnome.org/pub/GNOME/sources/california/0.4/%{name}-%{version}.tar.xz
 # Source0-md5: cd8fa9cc399ee918e55b051e3b9f3124
+Patch0:                evolution-data-server-3.14.patch
 URL:           https://wiki.gnome.org/Apps/California
 BuildRequires: evolution-data-server-devel >= 3.8.5
 BuildRequires: gettext-tools
@@ -48,6 +49,7 @@ interfejs.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %configure 
diff --git a/evolution-data-server-3.14.patch b/evolution-data-server-3.14.patch
new file mode 100644 (file)
index 0000000..9389439
--- /dev/null
@@ -0,0 +1,39 @@
+diff --git a/configure.ac b/configure.ac
+index 8a94642..1ca6426 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -27,7 +27,7 @@ AC_SUBST(LDFLAGS)
+ GLIB_REQUIRED=2.38.0
+ GTK_REQUIRED=3.12.2
+ GEE_REQUIRED=0.10.5
+-ECAL_REQUIRED=3.8.5
++ECAL_REQUIRED=3.13.90
+ LIBSOUP_REQUIRED=2.44
+ GDATA_REQUIRED=0.14.0
+ GOA_REQUIRED=3.8.3
+diff --git a/src/backing/eds/backing-eds-calendar-source.vala b/src/backing/eds/backing-eds-calendar-source.vala
+index ee6a572..5009b5d 100644
+--- a/src/backing/eds/backing-eds-calendar-source.vala
++++ b/src/backing/eds/backing-eds-calendar-source.vala
+@@ -256,7 +256,7 @@ internal class EdsCalendarSource : CalendarSource {
+     
+     // Invoked by EdsStore prior to making it available outside of unit
+     internal async void open_async(Cancellable? cancellable) throws Error {
+-        client = (E.CalClient) yield E.CalClient.connect(eds_source, E.CalClientSourceType.EVENTS,
++        client = (E.CalClient) yield E.CalClient.connect(eds_source, E.CalClientSourceType.EVENTS, 1,
+             cancellable);
+         
+         client.bind_property("readonly", this, PROP_READONLY, BindingFlags.SYNC_CREATE);
+diff --git a/vapi/libecal-1.2.vapi b/vapi/libecal-1.2.vapi
+index 6ead3ec..46fd711 100644
+--- a/vapi/libecal-1.2.vapi
++++ b/vapi/libecal-1.2.vapi
+@@ -23,7 +23,7 @@ namespace E {
+               public bool check_save_schedules ();
+               public static bool check_timezones (iCal.icalcomponent comp, GLib.List comps, GLib.Callback tzlookup, void* ecalclient, GLib.Cancellable cancellable) throws GLib.Error;
+               [CCode (finish_name = "e_cal_client_connect_finish")]
+-              public static async unowned E.Client connect (E.Source source, E.CalClientSourceType source_type, GLib.Cancellable cancellable) throws GLib.Error;
++              public static async unowned E.Client connect (E.Source source, E.CalClientSourceType source_type, uint32 wait_for_connected_seconds, GLib.Cancellable cancellable) throws GLib.Error;
+               public static unowned E.Client connect_sync (E.Source source, E.CalClientSourceType source_type, GLib.Cancellable cancellable) throws GLib.Error;
+               [CCode (finish_name = "e_cal_client_create_object_finish")]
+               public async void create_object (iCal.icalcomponent icalcomp, GLib.Cancellable? cancellable, out string out_uid) throws GLib.Error;
This page took 0.038648 seconds and 4 git commands to generate.