]> git.pld-linux.org Git - packages/calibre.git/commitdiff
- updated to 2.44.1 auto/th/calibre-2.44.1-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 21 Nov 2015 10:54:10 +0000 (11:54 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 21 Nov 2015 10:55:31 +0000 (11:55 +0100)
calibre.spec
desktop-integration.patch [new file with mode: 0644]

index 9817758b063ae50b68c1ec996358689c4a3e8154..54bed1d68b378cda7959e78207893671b9a23f11 100644 (file)
 Summary:       E-book converter and library management
 Summary(pl.UTF-8):     Konwerter oraz biblioteka dla e-booków
 Name:          calibre
-Version:       2.37.1
+Version:       2.44.1
 Release:       1
 License:       GPL v3+
 Group:         Applications/Multimedia
-Source0:       http://code.calibre-ebook.com/dist/src/%{name}-%{version}.tar.xz
-# Source0-md5: d2e97c9e690ce2d877d6390445b76994
+Source0:       %{name}-%{version}-nofonts.tar.xz
+# Source0-md5: bfd48e59aa9d650a2d305e456a857fe0
 Source1:       generate-tarball.sh
 Source2:       %{name}-mount-helper
 Patch0:                %{name}-prefix.patch
@@ -24,6 +24,7 @@ Patch1:               %{name}-no-update.patch
 Patch2:                %{name}-env_module.patch
 Patch3:                %{name}-locales.patch
 Patch4:                shebang-python-fix.patch
+Patch5:                desktop-integration.patch
 URL:           http://www.calibre-ebook.com/
 %define                baeutifulsoup_ver 3.0.5
 %define                pil_ver 1.1.6
@@ -167,6 +168,7 @@ Pakiet ten dostarcza uzupełnianie nazw dla calibre w powłoce zsh.
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
+%patch5 -p1
 
 # 64bit target build fix
 %{__sed} -i -e "s!'/usr/lib'!'%{_libdir}'!g" setup/build_environment.py
diff --git a/desktop-integration.patch b/desktop-integration.patch
new file mode 100644 (file)
index 0000000..49c6989
--- /dev/null
@@ -0,0 +1,29 @@
+--- calibre-2.44.1/src/calibre/linux.py.orig   2015-11-21 11:22:06.420641478 +0100
++++ calibre-2.44.1/src/calibre/linux.py        2015-11-21 11:20:41.000000000 +0100
+@@ -781,7 +781,7 @@
+                 def install_single_icon(iconsrc, basename, size, context, is_last_icon=False):
+                     filename = '%s-%s.png' % (basename, size)
+                     render_img(iconsrc, filename, width=int(size), height=int(size))
+-                    cmd = ['xdg-icon-resource', 'install', '--noupdate', '--context', context, '--size', str(size), filename, basename]
++                    cmd = ['xdg-icon-resource', 'install', '--noupdate', '--novendor', '--context', context, '--size', str(size), filename, basename]
+                     if is_last_icon:
+                         del cmd[2]
+                     cc(cmd)
+@@ -850,7 +850,7 @@
+                 APPDATA = get_appdata()
+                 for x in des:
+-                    cmd = ['xdg-desktop-menu', 'install', '--noupdate', './'+x]
++                    cmd = ['xdg-desktop-menu', 'install', '--noupdate', '--novendor', './'+x]
+                     cc(' '.join(cmd), shell=True)
+                     self.menu_resources.append(x)
+                     ak = x.partition('.')[0]
+@@ -859,7 +859,7 @@
+                 cc(['xdg-desktop-menu', 'forceupdate'])
+                 MIME = P('calibre-mimetypes.xml')
+                 self.mime_resources.append(MIME)
+-                cc(['xdg-mime', 'install', MIME])
++                cc(['xdg-mime', 'install', '--novendor', MIME])
+         except Exception:
+             if self.opts.fatal_errors:
+                 raise
This page took 0.096952 seconds and 4 git commands to generate.