]> git.pld-linux.org Git - packages/calibre.git/blobdiff - calibre.spec
- up to 3.23.0
[packages/calibre.git] / calibre.spec
index 04f4564a209ce205847f5b8d6328563d12d128f6..ca53f60d0c6c02f7311e205dd35ae5f1667ee153 100644 (file)
@@ -5,25 +5,25 @@
 # NOTE:
 # Upstream packages some unfree fonts which we cannot redistribute,
 # so when upgrading calibre we should download upstream tarball by hand from
-# http://downloads.sourceforge.net/calibre and run generate-tarball.sh script
+# https://download.calibre-ebook.com/ and run generate-tarball.sh script
 # included as SourceX.
 #
 Summary:       E-book converter and library management
 Summary(pl.UTF-8):     Konwerter oraz biblioteka dla e-booków
 Name:          calibre
-Version:       2.5.0
+Version:       3.23.0
 Release:       1
 License:       GPL v3+
 Group:         Applications/Multimedia
 Source0:       %{name}-%{version}-nofonts.tar.xz
-# Source0-md5: b2e63ecac0c28b456f17702cc984bdcd
+# Source0-md5: a723c37703e72fdff6a365e762829191
 Source1:       generate-tarball.sh
 Source2:       %{name}-mount-helper
 Patch0:                %{name}-prefix.patch
-Patch1:                %{name}-no-update.patch
-Patch2:                %{name}-env_module.patch
-Patch3:                %{name}-locales.patch
-Patch4:                shebang-python-fix.patch
+Patch1:                %{name}-env_module.patch
+Patch2:                %{name}-locales.patch
+Patch3:                shebang-python-fix.patch
+Patch4:                desktop-integration.patch
 URL:           http://www.calibre-ebook.com/
 %define                baeutifulsoup_ver 3.0.5
 %define                pil_ver 1.1.6
@@ -40,21 +40,27 @@ URL:                http://www.calibre-ebook.com/
 BuildRequires: ImageMagick-devel >= 6.6.4.7
 BuildRequires: Qt5Core-devel
 BuildRequires: Qt5DBus-devel
+BuildRequires: Qt5EventDispatcherSupport-devel
+BuildRequires: Qt5FontDatabaseSupport-devel
 BuildRequires: Qt5Gui-devel
-BuildRequires: Qt5PlatformSupport-devel
+BuildRequires: Qt5ServiceSupport-devel
+BuildRequires: Qt5ThemeSupport-devel
+BuildRequires: Qt5Widgets-devel
 BuildRequires: chmlib-devel >= 0.40
 BuildRequires: libicu-devel
+BuildRequires: libinput-devel
 BuildRequires: libmtp-devel >= 1.1.5
 BuildRequires: libwmf-devel >= 0.2.8
+BuildRequires: mtdev-devel
 BuildRequires: pkgconfig
 BuildRequires: podofo-devel >= 0.8.2
-BuildRequires: poppler-Qt-devel >= 0.20.2
-BuildRequires: poppler-glib-devel >= 0.20.2
+BuildRequires: poppler-qt5-devel >= 0.28.1
+BuildRequires: poppler-glib-devel >= 0.28.1
 BuildRequires: python-BeautifulSoup >= %{baeutifulsoup_ver}
 BuildRequires: python-PIL >= %{pil_ver}
-BuildRequires: python-PyQt5 >= %{pyqt4_ver}
-BuildRequires: python-PyQt5-devel >= %{pyqt4_ver}
-BuildRequires: python-PyQt5-devel-tools >= %{pyqt4_ver}
+BuildRequires: python-PyQt5 >= %{pyqt5_ver}
+BuildRequires: python-PyQt5-devel-tools >= %{pyqt5_ver}
+BuildRequires: python-PyQt5-uic >= %{pyqt5_ver}
 BuildRequires: python-apsw >= %{apsw_ver}
 BuildRequires: python-cssselect >= %{cssselect_ver}
 BuildRequires: python-cssutils >= %{cssutils_ver}
@@ -62,20 +68,28 @@ BuildRequires:      python-dateutil >= %{dateutil_ver}
 BuildRequires: python-devel >= 1:2.7.1
 BuildRequires: python-dns >= %{dns_ver}
 BuildRequires: python-genshi
+BuildRequires: python-html5-parser
 BuildRequires: python-lxml >= %{lxml_ver}
 BuildRequires: python-mechanize >= %{mechanize_ver}
 BuildRequires: python-modules-sqlite
+BuildRequires: python-msgpack
 BuildRequires: python-netifaces >= %{netifaces_ver}
 BuildRequires: python-psutil >= %{psutil_ver}
+BuildRequires: python-regex
 BuildRequires: python-sip-devel
+BuildRequires: qt5-build
+BuildRequires: qt5-qmake
 BuildRequires: rpm-pythonprov
-BuildRequires: rpmbuild(macros) >= 1.586
+BuildRequires: rpmbuild(macros) >= 1.710
 BuildRequires: sed >= 4.0
 BuildRequires: sqlite3-devel
+BuildRequires: sip-PyQt5
 BuildRequires: tar >= 1:1.22
 BuildRequires: unzip
 BuildRequires: xdg-utils
 BuildRequires: xz >= 1:4.999.7
+Requires:      Qt5Svg
+Requires:      Qt5WebKit
 Requires:      python-BeautifulSoup >= %{baeutifulsoup_ver}
 Requires:      python-PIL >= %{pil_ver}
 Requires:      python-PyQt5 >= %{pyqt5_ver}
@@ -85,11 +99,14 @@ Requires:   python-cssutils >= %{cssutils_ver}
 Requires:      python-dateutil >= %{dateutil_ver}
 Requires:      python-dns >= %{dns_ver}
 Requires:      python-genshi
+Requires:      python-html5-parser
 Requires:      python-lxml >= %{lxml_ver}
 Requires:      python-mechanize >= %{mechanize_ver}
 Requires:      python-modules-sqlite
+Requires:      python-msgpack
 Requires:      python-netifaces >= %{netifaces_ver}
 Requires:      python-psutil >= %{psutil_ver}
+Requires:      python-regex
 Suggests:      ImageMagick-coder-jpeg
 Suggests:      ImageMagick-coder-png
 ### FIXME: libunrar.so is needed for rar-packed files
@@ -175,6 +192,7 @@ CC="%{__cc}" \
 CXX=%{__cxx} \
 OVERRIDE_CFLAGS="%{rpmcflags}" \
 OVERRIDE_LDFLAGS="%{rpmldflags}" \
+QMAKE="%{_bindir}/qmake-qt5" \
 %{__python} setup.py build
 
 %install
@@ -187,8 +205,10 @@ XDG_DATA_DIRS="$RPM_BUILD_ROOT%{_datadir}" \
 XDG_UTILS_INSTALL_MODE="system" \
 LIBPATH="%{_libdir}" \
 %{__python} setup.py install \
+       --no-compile \
+       --prefix=%{_prefix} \
        --root=$RPM_BUILD_ROOT \
-       --libdir="%{_libdir}"
+       --libdir=%{_libdir}
 
 cp -p resources/images/library.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}-gui.png
 cp -p resources/images/viewer.png $RPM_BUILD_ROOT%{_pixmapsdir}/calibre-viewer.png
@@ -225,9 +245,9 @@ done;
 %{__rm} $RPM_BUILD_ROOT%{_bindir}/%{name}-uninstall
 
 # unsupported
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/bn_BD
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/jv
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ltg
-%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/en_AU
 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/sl_SI
 
 install %{SOURCE2} $RPM_BUILD_ROOT%{_bindir}
@@ -278,9 +298,9 @@ fi
 %attr(755,root,root) %{_bindir}/markdown-calibre
 %attr(755,root,root) %{_bindir}/web2disk
 %{_datadir}/%{name}
-%{_datadir}/appdata/calibre-ebook-edit.appdata.xml
-%{_datadir}/appdata/calibre-ebook-viewer.appdata.xml
-%{_datadir}/appdata/calibre-gui.appdata.xml
+%{_datadir}/metainfo/calibre-ebook-edit.appdata.xml
+%{_datadir}/metainfo/calibre-ebook-viewer.appdata.xml
+%{_datadir}/metainfo/calibre-gui.appdata.xml
 %{_libdir}/%{name}
 %{_desktopdir}/calibre-ebook-edit.desktop
 %{_desktopdir}/calibre-ebook-viewer.desktop
This page took 0.047021 seconds and 4 git commands to generate.