]> git.pld-linux.org Git - packages/calibre.git/blame - calibre.spec
- pass our CXXFLAGS
[packages/calibre.git] / calibre.spec
CommitLineData
17e051e1 1#
2# NOTE:
3# Upstream packages some unfree fonts which we cannot redistribute,
4# so when upgrading calibre we should download upstream tarball by hand from
5# http://downloads.sourceforge.net/calibre and run below script in order
6# to remove them:
7#
8# #!/bin/sh
9#
10# VERSION=$1
11#
12# rm -rf calibre
13# tar -xvzf calibre-$VERSION.tar.gz
14# rm -f calibre/resources/fonts/liberation/*
15# rm -f calibre/resources/fonts/prs500/*
16#
17# tar -cvjf calibre-$VERSION-nofonts.tar.bz2 calibre
18#
02229893 19Summary: E-book converter and library management
0e501b81 20Name: calibre
21Version: 0.6.53
bdbd4238 22Release: 0.1
6d15f615 23License: GPL v3+
02229893 24Group: Applications/Multimedia
17e051e1 25Source0: %{name}-%{version}-nofonts.tar.bz2
08290bfe 26# Source0-md5: 7ed89159bbd97db0d2dcf850bb1dd867
0e501b81 27Patch0: %{name}-prefix.patch
7b500ff7 28Patch1: %{name}-manpages.patch
804e0619 29Patch2: %{name}-no-update.patch
02229893 30URL: http://www.calibre-ebook.com/
0e501b81 31BuildRequires: ImageMagick-devel
32BuildRequires: chmlib-devel
33BuildRequires: podofo-devel
34BuildRequires: poppler-Qt-devel
bdbd4238 35BuildRequires: python-BeautifulSoup
307ba398 36BuildRequires: python-PIL
0e501b81 37BuildRequires: python-PyQt4-devel
38BuildRequires: python-cssutils
307ba398 39BuildRequires: python-dateutil
0e501b81 40BuildRequires: python-lxml
41BuildRequires: python-mechanize
6d15f615 42BuildRequires: python-modules-sqlite
0e501b81 43BuildRequires: python-sip-devel
44BuildRequires: rpm-pythonprov
2f356583 45Requires: python-PIL
6d15f615 46Requires: python-cssutils
2f356583 47Requires: python-dateutil
6d15f615 48Requires: python-lxml
49Requires: python-mechanize
50Requires: python-modules-sqlite
0e501b81 51BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53%description
02229893
ER
54Calibre is meant to be a complete e-library solution. It includes
55library management, format conversion, news feeds to ebook conversion
56as well as e-book reader sync features.
57
58Calibre is primarily a ebook cataloging program. It manages your ebook
59collection for you. It is designed around the concept of the logical
60book, i.e. a single entry in the database that may correspond to
61ebooks in several formats. It also supports conversion to and from a
62dozen different ebook formats.
63
64Supported input formats are: MOBI, LIT, PRC, EPUB, CHM, ODT, HTML,
65CBR, CBZ, RTF, TXT, PDF and LRS.
0e501b81 66
67%prep
68%setup -q -n %{name}
69%patch0 -p1
7b500ff7 70%patch1 -p1
804e0619 71%patch2 -p1
0e501b81 72
73%build
08290bfe 74%{__python} setup.py build \
75 OVERRIDE_CFLAGS="%{rpmcxxflags}"
0e501b81 76
77%install
78rm -rf $RPM_BUILD_ROOT
79
80%{__python} setup.py install \
9c8cebf1 81 --root=$RPM_BUILD_ROOT \
82 --libdir=%{_libdir}
0e501b81 83
7b500ff7 84mv $RPM_BUILD_ROOT%{_datadir}/%{name}/man $RPM_BUILD_ROOT%{_mandir}
85
0e501b81 86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(644,root,root,755)
91%doc COPYRIGHT README
92%attr(755,root,root) %{_bindir}/*
93%{_datadir}/%{name}
94%{_libdir}/%{name}
7b500ff7 95%{_mandir}/man1/*.1*
This page took 0.119918 seconds and 4 git commands to generate.