]> git.pld-linux.org Git - packages/cakephp.git/commitdiff
- subpackages for -console, -tests, -demo
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 16 Nov 2009 12:31:58 +0000 (12:31 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    cakephp.spec -> 1.2
    console.patch -> 1.1

cakephp.spec
console.patch [new file with mode: 0644]

index 848813aa12433becdba98dad7f5768945e3e6832..88a0e70930cb0790c771516a0e4242ad0564ba9a 100644 (file)
@@ -1,11 +1,12 @@
 Summary:       OpenSource Rapid Development PHP Framework
 Name:          cakephp
 Version:       1.2.1.8004
-Release:       0.1
+Release:       0.4
 License:       MIT
 Group:         Development/Languages/PHP
 Source0:       http://cakeforge.org/frs/download.php/697/cake_%{version}.tar.bz2/donation=%{name}-%{version}.tar.bz2
 # Source0-md5: 0d01d1bc4e2df9ccf82130a838b06dd6
+Patch0:                console.patch
 URL:           http://www.cakephp.org/
 BuildRequires: rpmbuild(macros) >= 1.461
 Requires:      php-common
@@ -21,16 +22,56 @@ applications. Using commonly known design patterns like MVC and ORM
 within the convention over configuration paradigm, CakePHP reduces
 development costs and helps developers write less code.
 
+%package console
+Summary:       Cake Command-line code generation utility
+Group:         Development/Languages/PHP
+Requires:      %{name} = %{version}-%{release}
+
+%description console
+Cake Command-line code generation utility to automate programmer
+chores.
+
+%package tests
+Summary:       Tests for CakePHP
+Summary(pl.UTF-8):     Testy dla CakePHP
+Group:         Development/Languages/PHP
+Requires:      %{name} = %{version}-%{release}
+AutoProv:      no
+AutoReq:       no
+
+%description tests
+Tests for CakePHP.
+
+%description tests -l pl.UTF-8
+Testy dla CakePHP.
+
+%package demo
+Summary:       Demo for CakePHP
+Summary(pl.UTF-8):     Pliki demonstracyjne dla pakietu CakePHP
+Group:         Documentation
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description demo
+Demonstrations and samples for CakePHP.
+
+%description demo -l pl.UTF-8
+Pliki demonstracyjne i przykłady dla pakietu CakePHP.
+
 %prep
 %setup -q -n cake_%{version}
+%patch0 -p1
 
 mv cake/{LICENSE,VERSION}.txt .
+rm cake/console/cake.bat
+mv cake/console/cake cake.sh
 find -name empty | xargs rm -f
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_appdir}
-cp -a app cake vendors $RPM_BUILD_ROOT%{_appdir}
+install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_examplesdir}/%{name}-%{version}}
+cp -a cake/* $RPM_BUILD_ROOT%{_appdir}
+cp -a app vendors $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
+install -p cake.sh $RPM_BUILD_ROOT%{_bindir}/cake
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -39,3 +80,18 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc README
 %{_appdir}
+%exclude %{_appdir}/tests
+%exclude %{_appdir}/console
+
+%files console
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/cake
+%{_appdir}/console
+
+%files tests
+%defattr(644,root,root,755)
+%{_appdir}/tests
+
+%files demo
+%defattr(644,root,root,755)
+%{_examplesdir}/%{name}-%{version}
diff --git a/console.patch b/console.patch
new file mode 100644 (file)
index 0000000..c6d487e
--- /dev/null
@@ -0,0 +1,25 @@
+--- cake_1.2.1.8004/cake/console/cake~ 2009-11-16 14:25:48.000000000 +0200
++++ cake_1.2.1.8004/cake/console/cake  2009-11-16 14:26:07.636266578 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ ################################################################################
+ #
+ # Bake is a shell script for running CakePHP bake script
+@@ -22,11 +22,9 @@
+ # @license                    http://www.opensource.org/licenses/mit-license.php The MIT License
+ #
+ ################################################################################
+-clear
+-LIB=${0/%cake/}
+-APP=`pwd`
++LIB=/usr/share/php/cake/console
++APP=$(pwd)
+-exec php -q ${LIB}cake.php -working "${APP}" "$@"
+-
+-exit;
+\ No newline at end of file
++exec php -q ${LIB}/cake.php -working "${APP}" "$@"
++exit 1
This page took 0.077327 seconds and 4 git commands to generate.