]> git.pld-linux.org Git - packages/caja-python.git/blob - caja-python.spec
9124c412b0dbdf2dbdef7103027518d49c1f6b3a
[packages/caja-python.git] / caja-python.spec
1 # NOTE: despite upstream name python-caja, it's not a binding from Python to Caja,
2 # but from Caja to Python, allowing to write Caja extensions in Python - thus our Name.
3 Summary:        Python bindings for libcaja-extension library
4 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libcaja-extension
5 Name:           caja-python
6 Version:        1.12.0
7 Release:        2
8 License:        GPL v2+
9 Group:          Libraries/Python
10 Source0:        http://pub.mate-desktop.org/releases/1.12/python-caja-%{version}.tar.xz
11 # Source0-md5:  91039b3dba0609dd8f3087023afb4268
12 URL:            http://mate-desktop.org/
13 BuildRequires:  autoconf >= 2.53
14 BuildRequires:  automake >= 1:1.10
15 BuildRequires:  caja-devel >= 1.6.0
16 BuildRequires:  gtk-doc >= 1.9
17 BuildRequires:  intltool >= 0.35.0
18 BuildRequires:  libtool >= 1:1.4.3
19 BuildRequires:  libxslt-progs
20 BuildRequires:  pkgconfig
21 BuildRequires:  python-devel >= 1:2.7
22 # pygobject3 is preferred over pygobject 2 with no configure switch
23 BuildRequires:  python-pygobject3-devel >= 3.0.0
24 BuildRequires:  rpm-pythonprov
25 BuildRequires:  rpmbuild(macros) >= 1.219
26 BuildRequires:  tar >= 1:1.22
27 BuildRequires:  xz
28 Requires:       caja >= 1.6.0
29 Requires:       python-libs
30 Obsoletes:      mate-file-manager-python
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 Python bindings for libcaja-extension library, allowing to write Caja
35 extensions in Python.
36
37 %description -l pl.UTF-8
38 Wiązania Pythona do biblioteki libcaja-extension, pozwalające na
39 tworzenie rozszerzeń zarządcy plików Caja w Pythonie.
40
41 %package devel
42 Summary:        Development files for Python Caja extensions
43 Summary(pl.UTF-8):      Pliki programistyczne dla pythonowych rozszerzeń zarządcy plików Caja
44 Group:          Development/Libraries
45 # doesn't require base; the only file is pkg-config specific, so let's require it
46 Requires:       pkgconfig
47 Obsoletes:      mate-file-manager-python-devel
48
49 %description devel
50 Development files for Caja extensions written in Python.
51
52 %description devel -l pl.UTF-8
53 Pliki programistyczne dla rozszerzeń zarządcy plików Caja pisanych w
54 Pythonie.
55
56 %package apidocs
57 Summary:        Python Caja API documentation
58 Summary(pl.UTF-8):      Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja
59 Group:          Documentation
60 Obsoletes:      mate-file-manager-python-apidocs
61 %if "%{_rpmversion}" >= "5"
62 BuildArch:      noarch
63 %endif
64
65 %description apidocs
66 Python Caja API documentation.
67
68 %description apidocs -l pl.UTF-8
69 Dokumentacja API Pythona dla rozszerzeń zarządcy plików Caja.
70
71 %package examples
72 Summary:        Example Python extensions for Caja file manager
73 Summary(pl.UTF-8):      Przykładowe pythonowe rozszerzenia dla zarządcy plików Caja
74 Group:          Documentation
75 Obsoletes:      mate-file-manager-python-examples
76
77 %description examples
78 Example Python extensions for Caja file manager.
79
80 %description examples -l pl.UTF-8
81 Przykładowe rozszerzenia dla zarządcy plików Caja napisane w Pythonie.
82
83 %prep
84 %setup -q -n python-caja-%{version}
85
86 %build
87 %{__libtoolize}
88 %{__aclocal} -I m4
89 %{__autoconf}
90 %{__autoheader}
91 %{__automake}
92 %configure \
93         --enable-gtk-doc \
94         --with-html-dir=%{_gtkdocdir}
95
96 %{__make}
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT \
103         HTMLdir=%{_gtkdocdir}/caja-python
104
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/caja/extensions-2.0/*.la
106
107 # not installed because of incomplete docs/Makefile
108 cp -p docs/html/* $RPM_BUILD_ROOT%{_gtkdocdir}/caja-python
109
110 # examples
111 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
112 %{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/README $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
113 %{__mv} $RPM_BUILD_ROOT%{_docdir}/python-caja/examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
114
115 # directory for python plugins for caja - see src/caja-python.c or caja-python.pc
116 install -d $RPM_BUILD_ROOT%{_datadir}/caja-python/extensions
117
118 %find_lang python-caja
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %files -f python-caja.lang
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog NEWS README
126 %attr(755,root,root) %{_libdir}/caja/extensions-2.0/libcaja-python.so
127 %{_datadir}/caja/extensions/libcaja-python.caja-extension
128 %dir %{_datadir}/caja-python
129 %dir %{_datadir}/caja-python/extensions
130
131 %files devel
132 %defattr(644,root,root,755)
133 %{_pkgconfigdir}/caja-python.pc
134
135 %files apidocs
136 %defattr(644,root,root,755)
137 %{_gtkdocdir}/caja-python
138
139 %files examples
140 %defattr(644,root,root,755)
141 %{_examplesdir}/%{name}-%{version}
This page took 0.062415 seconds and 2 git commands to generate.