]> git.pld-linux.org Git - packages/cairo.git/blobdiff - cairo.spec
- updated to 1.8.10
[packages/cairo.git] / cairo.spec
index 4b4117b45b9d7afe34f1e4b3ea626003fc58cc43..c6847b4d825de42babe2d53e87863a1c96c519d4 100644 (file)
@@ -2,44 +2,48 @@
 # Conditional build:
 %bcond_without apidocs         # disable gtk-doc
 %bcond_with    glitz           # build with glitz backend
+%if "%{pld_release}" == "ac"
+%bcond_with    xcb             # XCB backend
+%else
 %bcond_without xcb             # XCB backend
+%endif
 %bcond_with    tests           # perform tests (can fail due to out of memory)
-%bcond_without lcd             # use own LCD filtering instead of freetype's
 #
 Summary:       Cairo - multi-platform 2D graphics library
 Summary(pl.UTF-8):     Cairo - wieloplatformowa biblioteka graficzna 2D
 Name:          cairo
-Version:       1.4.12
+Version:       1.8.10
 Release:       1
 License:       LGPL v2.1 or MPL v1.1
 Group:         Libraries
 Source0:       http://cairographics.org/releases/%{name}-%{version}.tar.gz
-# Source0-md5: 8e50c2c0d56388e4ee94196c0c7a7904
+# Source0-md5: b60a82f405f9400bbfdcf850b1728d25
 Patch0:                %{name}-link.patch
-# updated from http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
-# NOTE: this patch wasn't applied upstream, is unmaintained by its author for
-# about a year and becomes more and more ugly => it's subject to drop soon  --q
-Patch1:                cairo-1.2.4-lcd-filter-1.patch
 URL:           http://cairographics.org/
-BuildRequires: autoconf >= 2.54
-BuildRequires: automake >= 1:1.7
+BuildRequires: autoconf >= 2.58
+BuildRequires: automake >= 1:1.8
 BuildRequires: fontconfig-devel
-%{?with_lcd:BuildRequires:     freetype-devel >= 1:2.3.0}
-%{!?with_lcd:BuildRequires:    freetype-devel >= 1:2.1.10}
+BuildRequires: freetype-devel >= 1:2.3.0
 %{?with_glitz:BuildRequires:   glitz-devel >= 0.5.1}
-%{?with_apidocs:BuildRequires: gtk-doc >= 1.3}
-BuildRequires: libpng-devel
+%{?with_apidocs:BuildRequires: gtk-doc >= 1.6}
+BuildRequires: libpng-devel >= 2:1.4.0
 BuildRequires: libtool
+BuildRequires: pixman-devel >= 0.12.0
 BuildRequires: pkgconfig
+BuildRequires: rpm >= 4.4.9-56
 %if %{with xcb}
 BuildRequires: libxcb-devel >= 0.9.92
 BuildRequires: xcb-util-devel >= 0.2
 %endif
+%if "%{pld_release}" == "ac"
+BuildRequires: xrender-devel >= 0.6
+%else
 BuildRequires: xorg-lib-libXrender-devel >= 0.6
+%endif
 BuildRequires: zlib-devel
-%{!?with_lcd:Requires: freetype >= 1:2.1.10}
-%{?with_lcd:Requires:  freetype >= 1:2.3.0}
+Requires:      freetype >= 1:2.3.0
 %{?with_glitz:Requires:        glitz >= 0.5.1}
+Requires:      pixman >= 0.12.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -76,12 +80,17 @@ Summary(pl.UTF-8):  Pliki programistyczne biblioteki Cairo
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      fontconfig-devel
-Requires:      freetype-devel >= 1:2.1.10
+Requires:      freetype-devel >= 1:2.3.0
 %{?with_glitz:Requires:        glitz-devel >= 0.5.1}
-Requires:      libpng-devel
+Requires:      libpng-devel >= 2:1.4.0
 %{?with_xcb:Requires:  libxcb-devel >= 0.9.92}
+Requires:      pixman-devel >= 0.12.0
 %{?with_xcb:Requires:  xcb-util-devel >= 0.2}
+%if "%{pld_release}" == "ac"
+Requires:      xrender-devel >= 0.6
+%else
 Requires:      xorg-lib-libXrender-devel >= 0.6
+%endif
 
 %description devel
 Development files for Cairo library.
@@ -111,26 +120,27 @@ Requires: gtk-doc-common
 Cairo API documentation.
 
 %description apidocs -l pl.UTF-8
-Dokumentacja API Cairo. 
+Dokumentacja API Cairo.
 
 %prep
 %setup -q
 %patch0 -p1
-%{?with_lcd:%patch1 -p1}
 
 %build
 %{?with_apidocs:%{__gtkdocize}}
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I build
 %{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
-       %{?with_apidocs:--enable-gtk-doc} \
-       %{?with_xcb:--enable-xcb} \
+       --enable-freetype \
        %{?with_glitz:--enable-glitz} \
+       %{?with_apidocs:--enable-gtk-doc} \
+       --enable-pdf=yes \
+       --enable-png \
        --enable-ps \
-       --enable-pdf \
+       %{?with_xcb:--enable-xcb} \
        --with-html-dir=%{_gtkdocdir}
 %{__make}
 %{?with_tests:%{__make} check}
@@ -141,6 +151,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -150,20 +162,31 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 # COPYING contains only notes, not LGPL/MPL texts
-%doc AUTHORS COPYING ChangeLog NEWS README TODO
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%doc AUTHORS COPYING ChangeLog NEWS README
+%attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%{_includedir}/*
-%{_pkgconfigdir}/*.pc
+%attr(755,root,root) %{_libdir}/libcairo.so
+%{_libdir}/libcairo.la
+%{_includedir}/cairo
+%{_pkgconfigdir}/cairo.pc
+%{_pkgconfigdir}/cairo-ft.pc
+%{_pkgconfigdir}/cairo-pdf.pc
+%{_pkgconfigdir}/cairo-png.pc
+%{_pkgconfigdir}/cairo-ps.pc
+%{_pkgconfigdir}/cairo-svg.pc
+%{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
+%{_pkgconfigdir}/cairo-xlib.pc
+%{_pkgconfigdir}/cairo-xlib-xrender.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libcairo.a
 
+%if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/cairo
+%endif
This page took 0.11338 seconds and 4 git commands to generate.