]> git.pld-linux.org Git - packages/cairo.git/blobdiff - cairo.spec
- updated to 1.8.2
[packages/cairo.git] / cairo.spec
index 4676044b5c3a4f0debd7eb5e8b39ca9b34ce2d30..8a900fa1b366fe8f82e44bad2db7fe9f07991b5e 100644 (file)
@@ -2,42 +2,49 @@
 # Conditional build:
 %bcond_without apidocs         # disable gtk-doc
 %bcond_with    glitz           # build with glitz backend
+%if "%{pld_release}" == "ac"
+%bcond_with    xcb             # XCB backend
+%else
 %bcond_without xcb             # XCB backend
+%endif
 %bcond_with    tests           # perform tests (can fail due to out of memory)
-%bcond_without lcd             # use own LCD filtering instead of freetype's
 #
 Summary:       Cairo - multi-platform 2D graphics library
 Summary(pl.UTF-8):     Cairo - wieloplatformowa biblioteka graficzna 2D
 Name:          cairo
-Version:       1.4.8
+Version:       1.8.2
 Release:       1
 License:       LGPL v2.1 or MPL v1.1
 Group:         Libraries
 Source0:       http://cairographics.org/releases/%{name}-%{version}.tar.gz
-# Source0-md5: 5b9db574c9fbb94ce52047600190a1ba
+# Source0-md5: 44d406e199c338cb60f7db32ffb32bdb
 Patch0:                %{name}-link.patch
-# updated from http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
-Patch1:                cairo-1.2.4-lcd-filter-1.patch
 URL:           http://cairographics.org/
-BuildRequires: autoconf >= 2.54
-BuildRequires: automake >= 1:1.7
+BuildRequires: autoconf >= 2.58
+BuildRequires: automake >= 1:1.8
 BuildRequires: fontconfig-devel
-%{?with_lcd:BuildRequires:     freetype-devel >= 1:2.3.0}
-%{!?with_lcd:BuildRequires:    freetype-devel >= 1:2.1.10}
+BuildRequires: freetype-devel >= 1:2.3.0
 %{?with_glitz:BuildRequires:   glitz-devel >= 0.5.1}
-%{?with_apidocs:BuildRequires: gtk-doc >= 1.3}
+%{?with_apidocs:BuildRequires: gtk-doc >= 1.6}
 BuildRequires: libpng-devel
 BuildRequires: libtool
+BuildRequires: pixman-devel >= 0.12.0
 BuildRequires: pkgconfig
+BuildRequires: poppler-glib-devel >= 0.8.0
+BuildRequires: rpm >= 4.4.9-56
 %if %{with xcb}
 BuildRequires: libxcb-devel >= 0.9.92
 BuildRequires: xcb-util-devel >= 0.2
 %endif
+%if "%{pld_release}" == "ac"
+BuildRequires: xrender-devel >= 0.6
+%else
 BuildRequires: xorg-lib-libXrender-devel >= 0.6
+%endif
 BuildRequires: zlib-devel
-%{!?with_lcd:Requires: freetype >= 1:2.1.10}
-%{?with_lcd:Requires:  freetype >= 1:2.3.0}
+Requires:      freetype >= 1:2.3.0
 %{?with_glitz:Requires:        glitz >= 0.5.1}
+Requires:      pixman >= 0.12.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -60,7 +67,7 @@ Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
-przy użyciu rozszerzonego algorytmu mieszania Portera-Duffa, który
+przy użyciu rozszerzonego algorytmu składania Portera-Duffa, który
 można znaleźć w rozszerzeniu X Render.
 
 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
@@ -74,12 +81,17 @@ Summary(pl.UTF-8):  Pliki programistyczne biblioteki Cairo
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 Requires:      fontconfig-devel
-Requires:      freetype-devel >= 1:2.1.10
+Requires:      freetype-devel >= 1:2.3.0
 %{?with_glitz:Requires:        glitz-devel >= 0.5.1}
 Requires:      libpng-devel
 %{?with_xcb:Requires:  libxcb-devel >= 0.9.92}
+Requires:      pixman-devel >= 0.12.0
 %{?with_xcb:Requires:  xcb-util-devel >= 0.2}
+%if "%{pld_release}" == "ac"
+Requires:      xrender-devel >= 0.6
+%else
 Requires:      xorg-lib-libXrender-devel >= 0.6
+%endif
 
 %description devel
 Development files for Cairo library.
@@ -109,26 +121,27 @@ Requires: gtk-doc-common
 Cairo API documentation.
 
 %description apidocs -l pl.UTF-8
-Dokumentacja API Cairo. 
+Dokumentacja API Cairo.
 
 %prep
 %setup -q
 %patch0 -p1
-%{?with_lcd:%patch1 -p1}
 
 %build
 %{?with_apidocs:%{__gtkdocize}}
 %{__libtoolize}
-%{__aclocal}
+%{__aclocal} -I build
 %{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
-       %{?with_apidocs:--enable-gtk-doc} \
-       %{?with_xcb:--enable-xcb} \
+       --enable-freetype \
        %{?with_glitz:--enable-glitz} \
-       --enable-ps \
+       %{?with_apidocs:--enable-gtk-doc} \
        --enable-pdf \
+       --enable-png \
+       --enable-ps \
+       %{?with_xcb:--enable-xcb} \
        --with-html-dir=%{_gtkdocdir}
 %{__make}
 %{?with_tests:%{__make} check}
@@ -139,6 +152,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -148,20 +163,31 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 # COPYING contains only notes, not LGPL/MPL texts
-%doc AUTHORS COPYING ChangeLog NEWS README TODO
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%doc AUTHORS COPYING ChangeLog NEWS README
+%attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%{_includedir}/*
-%{_pkgconfigdir}/*.pc
+%attr(755,root,root) %{_libdir}/libcairo.so
+%{_libdir}/libcairo.la
+%{_includedir}/cairo
+%{_pkgconfigdir}/cairo.pc
+%{_pkgconfigdir}/cairo-ft.pc
+%{_pkgconfigdir}/cairo-pdf.pc
+%{_pkgconfigdir}/cairo-png.pc
+%{_pkgconfigdir}/cairo-ps.pc
+%{_pkgconfigdir}/cairo-svg.pc
+%{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
+%{_pkgconfigdir}/cairo-xlib.pc
+%{_pkgconfigdir}/cairo-xlib-xrender.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libcairo.a
 
+%if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/cairo
+%endif
This page took 0.07487 seconds and 4 git commands to generate.