]> git.pld-linux.org Git - packages/cairo.git/blobdiff - cairo.spec
- rel 1
[packages/cairo.git] / cairo.spec
index 01762ea7ef9c3234715063f2dbf51262ea8ca030..3d0450af98e6b53b329065b46e3757361ea4231d 100644 (file)
@@ -4,33 +4,40 @@
 %bcond_with    glitz           # build with glitz backend
 %bcond_without xcb             # XCB backend
 %bcond_with    tests           # perform tests (can fail due to out of memory)
-%bcond_without lcd             # use own LCD filtering instead of freetype's
+%bcond_with    lcd             # freetype LCD filtering (instead of internal) [not ready]
 #
 Summary:       Cairo - multi-platform 2D graphics library
 Summary(pl.UTF-8):     Cairo - wieloplatformowa biblioteka graficzna 2D
 Name:          cairo
-Version:       1.4.14
+Version:       1.6.4
 Release:       1
 License:       LGPL v2.1 or MPL v1.1
 Group:         Libraries
 Source0:       http://cairographics.org/releases/%{name}-%{version}.tar.gz
-# Source0-md5: e8c442ff821c0719a69508fecba9038f
+# Source0-md5: a198d509f9e3a35b78de8bb02174ebb9
 Patch0:                %{name}-link.patch
-# updated from http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
-# NOTE: this patch wasn't applied upstream, is unmaintained by its author for
-# about a year and becomes more and more ugly => it's subject to drop soon  --q
-Patch1:                cairo-1.2.4-lcd-filter-1.patch
+Patch1:                %{name}-lt.patch
+Patch2:                %{name}-am.patch
+# Updated from http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
+# The lcd patch is being maintained at
+# http://bugs.freedesktop.org/show_bug.cgi?id=10301
+# It is not applied upstream for political reasons (patents) and its fate has
+# not been decided yet AFAIK. -- Qrczak
+# the latest version is for some early 1.5.x and won't be applied upstream to 1.6.x series
+Patch3:                %{name}-1.2.4-lcd-filter-1.patch
 URL:           http://cairographics.org/
-BuildRequires: autoconf >= 2.54
-BuildRequires: automake >= 1:1.7
+BuildRequires: autoconf >= 2.58
+BuildRequires: automake >= 1:1.8
 BuildRequires: fontconfig-devel
-%{?with_lcd:BuildRequires:     freetype-devel >= 1:2.3.0}
 %{!?with_lcd:BuildRequires:    freetype-devel >= 1:2.1.10}
+%{?with_lcd:BuildRequires:     freetype-devel >= 1:2.3.0}
 %{?with_glitz:BuildRequires:   glitz-devel >= 0.5.1}
-%{?with_apidocs:BuildRequires: gtk-doc >= 1.3}
+%{?with_apidocs:BuildRequires: gtk-doc >= 1.6}
 BuildRequires: libpng-devel
 BuildRequires: libtool
+BuildRequires: pixman-devel >= 0.10.0
 BuildRequires: pkgconfig
+BuildRequires: poppler-glib-devel >= 0.8.0
 %if %{with xcb}
 BuildRequires: libxcb-devel >= 0.9.92
 BuildRequires: xcb-util-devel >= 0.2
@@ -39,7 +46,7 @@ BuildRequires:        xorg-lib-libXrender-devel >= 0.6
 BuildRequires: zlib-devel
 %{!?with_lcd:Requires: freetype >= 1:2.1.10}
 %{?with_lcd:Requires:  freetype >= 1:2.3.0}
-%{?with_glitz:Requires:        glitz >= 0.5.1}
+%{?with_glitz:Requires:        glitz:Requires: glitz >= 0.5.1}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -80,6 +87,7 @@ Requires:     freetype-devel >= 1:2.1.10
 %{?with_glitz:Requires:        glitz-devel >= 0.5.1}
 Requires:      libpng-devel
 %{?with_xcb:Requires:  libxcb-devel >= 0.9.92}
+Requires:      pixman-devel >= 0.10.0
 %{?with_xcb:Requires:  xcb-util-devel >= 0.2}
 Requires:      xorg-lib-libXrender-devel >= 0.6
 
@@ -111,12 +119,14 @@ Requires: gtk-doc-common
 Cairo API documentation.
 
 %description apidocs -l pl.UTF-8
-Dokumentacja API Cairo. 
+Dokumentacja API Cairo.
 
 %prep
 %setup -q
 %patch0 -p1
-%{?with_lcd:%patch1 -p1}
+%patch1 -p1
+%patch2 -p1
+%{?with_lcd:%patch3 -p1}
 
 %build
 %{?with_apidocs:%{__gtkdocize}}
@@ -131,6 +141,8 @@ Dokumentacja API Cairo.
        %{?with_glitz:--enable-glitz} \
        --enable-ps \
        --enable-pdf \
+       --enable-png \
+       --enable-freetype \
        --with-html-dir=%{_gtkdocdir}
 %{__make}
 %{?with_tests:%{__make} check}
@@ -141,6 +153,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{!?with_apidocs:rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/cairo}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -150,7 +164,7 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 # COPYING contains only notes, not LGPL/MPL texts
-%doc AUTHORS COPYING ChangeLog NEWS README TODO
+%doc AUTHORS COPYING ChangeLog NEWS README
 %attr(755,root,root) %{_libdir}/libcairo.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libcairo.so.2
 
@@ -165,7 +179,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/cairo-png.pc
 %{_pkgconfigdir}/cairo-ps.pc
 %{_pkgconfigdir}/cairo-svg.pc
-%{_pkgconfigdir}/cairo-xcb.pc
+%{?with_xcb:%{_pkgconfigdir}/cairo-xcb.pc}
 %{_pkgconfigdir}/cairo-xlib.pc
 %{_pkgconfigdir}/cairo-xlib-xrender.pc
 
@@ -173,6 +187,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/libcairo.a
 
+%if %{with apidocs}
 %files apidocs
 %defattr(644,root,root,755)
 %{_gtkdocdir}/cairo
+%endif
This page took 0.032344 seconds and 4 git commands to generate.