]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
cd3fb9f41b743be5dae79a44c32b15bddb1d3072
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_with     xcb     # enable XCB backend (XCB not released yet)
4 #
5 Summary:        Cairo - multi-platform 2D graphics library
6 Summary(pl):    Cairo - wieloplatformowa biblioteka graficzna 2D
7 Name:           cairo
8 Version:        1.0.2
9 Release:        1
10 License:        LGPL v2.1 or MPL v1.1
11 Group:          Libraries
12 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
13 # Source0-md5:  d0b7111a14f90ec3afa777ec40c44984
14 URL:            http://cairographics.org/
15 BuildRequires:  autoconf >= 2.54
16 BuildRequires:  automake >= 1.7
17 BuildRequires:  fontconfig-devel
18 BuildRequires:  freetype-devel >= 2.1.10
19 BuildRequires:  glitz-devel >= 0.4.4
20 BuildRequires:  gtk-doc >= 1.3
21 BuildRequires:  libpng-devel
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 %{?with_xcb:BuildRequires:      xcb-devel}
25 BuildRequires:  xrender-devel >= 0.6
26 BuildRequires:  zlib-devel
27 Requires:       freetype >= 2.1.10
28 Requires:       glitz >= 0.4.4
29 Requires:       xrender >= 0.6
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Cairo provides anti-aliased vector-based rendering for X. Paths
34 consist of line segments and cubic splines and can be rendered at any
35 width with various join and cap styles. All colors may be specified
36 with optional translucence (opacity/alpha) and combined using the
37 extended Porter/Duff compositing algebra as found in the X Render
38 Extension.
39
40 Cairo exports a stateful rendering API similar in spirit to the path
41 construction, text, and painting operators of PostScript, (with the
42 significant addition of translucence in the imaging model). When
43 complete, the API is intended to support the complete imaging model of
44 PDF 1.4.
45
46 Cairo relies on the Xc library for backend rendering. Xc provides an
47 abstract interface for rendering to multiple target types. As of this
48 writing, Xc allows Cairo to target X drawables as well as generic
49 image buffers. Future backends such as PostScript, PDF, and perhaps
50 OpenGL are currently being planned.
51
52 %description -l pl
53 Cairo obs³uguje oparty na wektorach rendering z antyaliasingiem dla X.
54 ¦cie¿ki sk³adaj± siê z odcinków i splajnów kubicznych, a renderowane
55 mog± byæ z dowoln± grubo¶ci± i ró¿nymi stylami po³±czeñ i zakoñczeñ.
56 Wszystkie kolory mog± byæ podane z opcjonaln± pó³przezroczysto¶ci±
57 (podan± przez wspó³czynnik nieprzezroczysto¶ci lub alpha) i ³±czone
58 przy u¿yciu rozszerzonego algorytmu mieszania Portera-Duffa, który
59 mo¿na znale¼æ w rozszerzeniu X Render.
60
61 Cairo eksportuje stanowe API renderuj±ce w duchu podobne do operatorów
62 konstruowania ¶cie¿ek, tekstu i rysowania z PostScriptu (ze znacznym
63 dodatkiem pó³przezroczysto¶ci w modelu obrazu). Kiedy API zostanie
64 ukoñczone, ma obs³ugiwaæ pe³ny model obrazu z PDF w wersji 1.4.
65
66 Cairo do backendowego renderowania wykorzystuje bibliotekê Xc. Xc
67 dostarcza abstrakcyjny interfejs do renderowania na wiele rodzajów
68 wyj¶æ. Aktualnie Xc pozwala Cairo tworzyæ obiekty X, a tak¿e ogólne
69 bufory obrazu. W przysz³o¶ci planowane s± takie backendy jak
70 PostScript, PDF i byæ mo¿e OpenGL.
71
72 %package devel
73 Summary:        Development files for Cairo library
74 Summary(pl):    Pliki programistyczne biblioteki Cairo
75 Group:          Development/Libraries
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       fontconfig-devel
78 Requires:       freetype-devel >= 2.1.10
79 Requires:       glitz-devel >= 0.4.4
80 Requires:       libpng-devel
81 %{?with_xcb:Requires:   xcb-devel}
82 Requires:       xrender-devel >= 0.6
83
84 %description devel
85 Development files for Cairo library.
86
87 %description devel -l pl
88 Pliki programistyczne biblioteki Cairo.
89
90 %package static
91 Summary:        Static Cairo library
92 Summary(pl):    Statyczna biblioteka Cairo
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 Static Cairo library.
98
99 %description static -l pl
100 Statyczna biblioteka Cairo.
101
102 %prep
103 %setup -q
104
105 %build
106 %{__libtoolize}
107 %{__aclocal}
108 %{__autoheader}
109 %{__autoconf}
110 %{__automake}
111 %configure \
112         --enable-gtk-doc \
113         %{?with_xcb:--enable-xcb} \
114         --enable-glitz \
115         --enable-ps \
116         --enable-pdf \
117         --with-html-dir=%{_gtkdocdir}
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122
123 %{__make} install \
124         DESTDIR=$RPM_BUILD_ROOT
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 # COPYING contains only notes, not LGPL/MPL texts
135 %doc AUTHORS COPYING ChangeLog NEWS README TODO
136 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
137
138 %files devel
139 %defattr(644,root,root,755)
140 %attr(755,root,root) %{_libdir}/lib*.so
141 %{_libdir}/lib*.la
142 %{_includedir}/*
143 %{_pkgconfigdir}/*.pc
144 %{_gtkdocdir}/cairo
145
146 %files static
147 %defattr(644,root,root,755)
148 %{_libdir}/lib*.a
This page took 0.480503 seconds and 2 git commands to generate.