]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
95337fd3b39a9a72064d5680baf070aa2317b012
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_with     xcb             # enable XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 #
8 Summary:        Cairo - multi-platform 2D graphics library
9 Summary(pl):    Cairo - wieloplatformowa biblioteka graficzna 2D
10 Name:           cairo
11 Version:        1.2.2
12 Release:        1
13 License:        LGPL v2.1 or MPL v1.1
14 Group:          Libraries
15 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  2460487b1257a5583c889b1b9d2033ec
17 URL:            http://cairographics.org/
18 BuildRequires:  autoconf >= 2.54
19 BuildRequires:  automake >= 1.7
20 BuildRequires:  fontconfig-devel
21 BuildRequires:  freetype-devel >= 1:2.1.10
22 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
23 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
24 BuildRequires:  libpng-devel
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 %{?with_xcb:BuildRequires:      libxcb-devel}
28 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
29 BuildRequires:  zlib-devel
30 Requires:       freetype >= 1:2.1.10
31 %{?with_glitz:Requires: glitz >= 0.5.1}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 Cairo provides anti-aliased vector-based rendering for X. Paths
36 consist of line segments and cubic splines and can be rendered at any
37 width with various join and cap styles. All colors may be specified
38 with optional translucence (opacity/alpha) and combined using the
39 extended Porter/Duff compositing algebra as found in the X Render
40 Extension.
41
42 Cairo exports a stateful rendering API similar in spirit to the path
43 construction, text, and painting operators of PostScript, (with the
44 significant addition of translucence in the imaging model). When
45 complete, the API is intended to support the complete imaging model of
46 PDF 1.4.
47
48 Cairo relies on the Xc library for backend rendering. Xc provides an
49 abstract interface for rendering to multiple target types. As of this
50 writing, Xc allows Cairo to target X drawables as well as generic
51 image buffers. Future backends such as PostScript, PDF, and perhaps
52 OpenGL are currently being planned.
53
54 %description -l pl
55 Cairo obs³uguje oparty na wektorach rendering z antyaliasingiem dla X.
56 ¦cie¿ki sk³adaj± siê z odcinków i splajnów kubicznych, a renderowane
57 mog± byæ z dowoln± grubo¶ci± i ró¿nymi stylami po³±czeñ i zakoñczeñ.
58 Wszystkie kolory mog± byæ podane z opcjonaln± pó³przezroczysto¶ci±
59 (podan± przez wspó³czynnik nieprzezroczysto¶ci lub alpha) i ³±czone
60 przy u¿yciu rozszerzonego algorytmu mieszania Portera-Duffa, który
61 mo¿na znale¼æ w rozszerzeniu X Render.
62
63 Cairo eksportuje stanowe API renderuj±ce w duchu podobne do operatorów
64 konstruowania ¶cie¿ek, tekstu i rysowania z PostScriptu (ze znacznym
65 dodatkiem pó³przezroczysto¶ci w modelu obrazu). Kiedy API zostanie
66 ukoñczone, ma obs³ugiwaæ pe³ny model obrazu z PDF w wersji 1.4.
67
68 Cairo do backendowego renderowania wykorzystuje bibliotekê Xc. Xc
69 dostarcza abstrakcyjny interfejs do renderowania na wiele rodzajów
70 wyj¶æ. Aktualnie Xc pozwala Cairo tworzyæ obiekty X, a tak¿e ogólne
71 bufory obrazu. W przysz³o¶ci planowane s± takie backendy jak
72 PostScript, PDF i byæ mo¿e OpenGL.
73
74 %package devel
75 Summary:        Development files for Cairo library
76 Summary(pl):    Pliki programistyczne biblioteki Cairo
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       fontconfig-devel
80 Requires:       freetype-devel >= 1:2.1.10
81 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
82 Requires:       libpng-devel
83 %{?with_xcb:Requires:   libxcb-devel}
84 Requires:       xorg-lib-libXrender-devel >= 0.6
85
86 %description devel
87 Development files for Cairo library.
88
89 %description devel -l pl
90 Pliki programistyczne biblioteki Cairo.
91
92 %package static
93 Summary:        Static Cairo library
94 Summary(pl):    Statyczna biblioteka Cairo
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{version}-%{release}
97
98 %description static
99 Static Cairo library.
100
101 %description static -l pl
102 Statyczna biblioteka Cairo.
103
104 %package apidocs
105 Summary:        Cairo API documentation
106 Summary(pl):    Dokumentacja API Cairo
107 Group:          Documentation
108 Requires:       gtk-doc-common
109
110 %description apidocs
111 Cairo API documentation.
112
113 %description apidocs -l pl
114 Dokumentacja API Cairo. 
115
116 %prep
117 %setup -q
118
119 %build
120 %{?with_apidocs:%{__gtkdocize}}
121 %{__libtoolize}
122 %{__aclocal}
123 %{__autoheader}
124 %{__autoconf}
125 %{__automake}
126 %configure \
127         %{?with_apidocs:--enable-gtk-doc} \
128         %{?with_xcb:--enable-xcb} \
129         %{?with_glitz:--enable-glitz} \
130         --enable-ps \
131         --enable-pdf \
132         --with-html-dir=%{_gtkdocdir}
133 %{__make}
134 %{?with_tests:%{__make} check}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138
139 %{__make} install \
140         DESTDIR=$RPM_BUILD_ROOT
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files
149 %defattr(644,root,root,755)
150 # COPYING contains only notes, not LGPL/MPL texts
151 %doc AUTHORS COPYING ChangeLog NEWS README TODO
152 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/lib*.so
157 %{_libdir}/lib*.la
158 %{_includedir}/*
159 %{_pkgconfigdir}/*.pc
160
161 %files static
162 %defattr(644,root,root,755)
163 %{_libdir}/lib*.a
164
165 %files apidocs
166 %defattr(644,root,root,755)
167 %{_gtkdocdir}/cairo
This page took 0.066162 seconds and 2 git commands to generate.