]> git.pld-linux.org Git - packages/cairo.git/blob - cairo.spec
856d093c22541d279efc9933860b4f6ed7f8160a
[packages/cairo.git] / cairo.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     glitz           # build with glitz backend
5 %bcond_without  xcb             # XCB backend
6 %bcond_with     tests           # perform tests (can fail due to out of memory)
7 %bcond_without  lcd             # use own LCD filtering instead of freetype's
8 #
9 Summary:        Cairo - multi-platform 2D graphics library
10 Summary(pl.UTF-8):      Cairo - wieloplatformowa biblioteka graficzna 2D
11 Name:           cairo
12 Version:        1.4.4
13 Release:        1
14 License:        LGPL v2.1 or MPL v1.1
15 Group:          Libraries
16 Source0:        http://cairographics.org/releases/%{name}-%{version}.tar.gz
17 # Source0-md5:  a609118644e1d958d977821c6fd765a9
18 Patch0:         %{name}-link.patch
19 Patch1:         http://david.freetype.org/lcd/cairo-1.2.4-lcd-filter-1.patch
20 URL:            http://cairographics.org/
21 BuildRequires:  autoconf >= 2.54
22 BuildRequires:  automake >= 1:1.7
23 BuildRequires:  fontconfig-devel
24 %{?with_lcd:BuildRequires:      freetype-devel >= 1:2.3.0}
25 %{!?with_lcd:BuildRequires:     freetype-devel >= 1:2.1.10}
26 %{?with_glitz:BuildRequires:    glitz-devel >= 0.5.1}
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.3}
28 BuildRequires:  libpng-devel
29 BuildRequires:  libtool
30 BuildRequires:  pkgconfig
31 %if %{with xcb}
32 BuildRequires:  libxcb-devel >= 0.9.92
33 BuildRequires:  xcb-util-devel >= 0.2
34 %endif
35 BuildRequires:  xorg-lib-libXrender-devel >= 0.6
36 BuildRequires:  zlib-devel
37 %{!?with_lcd:Requires:  freetype >= 1:2.1.10}
38 %{?with_lcd:Requires:   freetype >= 1:2.3.0}
39 %{?with_glitz:Requires: glitz >= 0.5.1}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Cairo provides anti-aliased vector-based rendering for X. Paths
44 consist of line segments and cubic splines and can be rendered at any
45 width with various join and cap styles. All colors may be specified
46 with optional translucence (opacity/alpha) and combined using the
47 extended Porter/Duff compositing algebra as found in the X Render
48 Extension.
49
50 Cairo exports a stateful rendering API similar in spirit to the path
51 construction, text, and painting operators of PostScript, (with the
52 significant addition of translucence in the imaging model). When
53 complete, the API is intended to support the complete imaging model of
54 PDF 1.4.
55
56 %description -l pl.UTF-8
57 Cairo obsługuje oparty na wektorach rendering z antyaliasingiem dla X.
58 Ścieżki składają się z odcinków i splajnów kubicznych, a renderowane
59 mogą być z dowolną grubością i różnymi stylami połączeń i zakończeń.
60 Wszystkie kolory mogą być podane z opcjonalną półprzezroczystością
61 (podaną przez współczynnik nieprzezroczystości lub alpha) i łączone
62 przy użyciu rozszerzonego algorytmu mieszania Portera-Duffa, który
63 można znaleźć w rozszerzeniu X Render.
64
65 Cairo eksportuje stanowe API renderujące w duchu podobne do operatorów
66 konstruowania ścieżek, tekstu i rysowania z PostScriptu (ze znacznym
67 dodatkiem półprzezroczystości w modelu obrazu). Kiedy API zostanie
68 ukończone, ma obsługiwać pełny model obrazu z PDF w wersji 1.4.
69
70 %package devel
71 Summary:        Development files for Cairo library
72 Summary(pl.UTF-8):      Pliki programistyczne biblioteki Cairo
73 Group:          Development/Libraries
74 Requires:       %{name} = %{version}-%{release}
75 Requires:       fontconfig-devel
76 Requires:       freetype-devel >= 1:2.1.10
77 %{?with_glitz:Requires: glitz-devel >= 0.5.1}
78 Requires:       libpng-devel
79 %{?with_xcb:Requires:   libxcb-devel >= 0.9.92}
80 %{?with_xcb:Requires:   xcb-util-devel >= 0.2}
81 Requires:       xorg-lib-libXrender-devel >= 0.6
82
83 %description devel
84 Development files for Cairo library.
85
86 %description devel -l pl.UTF-8
87 Pliki programistyczne biblioteki Cairo.
88
89 %package static
90 Summary:        Static Cairo library
91 Summary(pl.UTF-8):      Statyczna biblioteka Cairo
92 Group:          Development/Libraries
93 Requires:       %{name}-devel = %{version}-%{release}
94
95 %description static
96 Static Cairo library.
97
98 %description static -l pl.UTF-8
99 Statyczna biblioteka Cairo.
100
101 %package apidocs
102 Summary:        Cairo API documentation
103 Summary(pl.UTF-8):      Dokumentacja API Cairo
104 Group:          Documentation
105 Requires:       gtk-doc-common
106
107 %description apidocs
108 Cairo API documentation.
109
110 %description apidocs -l pl.UTF-8
111 Dokumentacja API Cairo. 
112
113 %prep
114 %setup -q
115 %patch0 -p1
116 %{?with_lcd:%patch1 -p1}
117
118 %build
119 %{?with_apidocs:%{__gtkdocize}}
120 %{__libtoolize}
121 %{__aclocal}
122 %{__autoheader}
123 %{__autoconf}
124 %{__automake}
125 %configure \
126         %{?with_apidocs:--enable-gtk-doc} \
127         %{?with_xcb:--enable-xcb} \
128         %{?with_glitz:--enable-glitz} \
129         --enable-ps \
130         --enable-pdf \
131         --with-html-dir=%{_gtkdocdir}
132 %{__make}
133 %{?with_tests:%{__make} check}
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post   -p /sbin/ldconfig
145 %postun -p /sbin/ldconfig
146
147 %files
148 %defattr(644,root,root,755)
149 # COPYING contains only notes, not LGPL/MPL texts
150 %doc AUTHORS COPYING ChangeLog NEWS README TODO
151 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
152
153 %files devel
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_libdir}/lib*.so
156 %{_libdir}/lib*.la
157 %{_includedir}/*
158 %{_pkgconfigdir}/*.pc
159
160 %files static
161 %defattr(644,root,root,755)
162 %{_libdir}/lib*.a
163
164 %files apidocs
165 %defattr(644,root,root,755)
166 %{_gtkdocdir}/cairo
This page took 0.195044 seconds and 2 git commands to generate.