]> git.pld-linux.org Git - packages/cacti-plugin-rrdclean.git/commitdiff
- respect paths set from configuration
authorElan Ruusamäe <glen@pld-linux.org>
Tue, 14 Dec 2010 07:40:27 +0000 (07:40 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fix wrong param reference as well

Changed files:
    cacti-plugin-rrdclean.spec -> 1.10
    fix-paths-handling.patch -> 1.1

cacti-plugin-rrdclean.spec
fix-paths-handling.patch [new file with mode: 0644]

index ecb40a0f18a75c107fa7adc66c7aaf25effe5cbd..89138d866269ee82467f8f24676134719c839846 100644 (file)
@@ -2,12 +2,13 @@
 Summary:       Cacti RRD File Cleaner
 Name:          cacti-plugin-%{plugin}
 Version:       0.40
-Release:       0.3
+Release:       0.4
 License:       GPL v2
 Group:         Applications/WWW
 Source0:       http://docs.cacti.net/_media/plugin:rrdclean-v%{version}.tgz
 # Source0-md5: afd7ae246482fbee883485e0430041e8
 Patch0:                paths.patch
+Patch1:                fix-paths-handling.patch
 URL:           http://docs.cacti.net/plugin:rrdclean
 Requires:      cacti >= 0.8.6j
 Requires:      php-common >= 3:4.3.0
@@ -27,6 +28,7 @@ files.
 %setup -qc
 mv %{plugin}/* .; rmdir %{plugin}
 %patch0 -p1
+%patch1 -p1
 
 %install
 rm -rf $RPM_BUILD_ROOT
diff --git a/fix-paths-handling.patch b/fix-paths-handling.patch
new file mode 100644 (file)
index 0000000..4155919
--- /dev/null
@@ -0,0 +1,28 @@
+--- cacti-plugin-rrdclean-0.40/rrdmove.php     2010-06-19 17:24:22.000000000 +0300
++++ cacti-plugin-rrdclean-0.40/rrdmove.php     2010-12-14 09:28:27.185477958 +0200
+@@ -117,7 +116,7 @@
+       cacti_log("RRDClean is now running on " . sizeof($file_array) . " items", true, "RRDCLEAN");
+       /* determine the location of the RRA files */
+-      if (isset ($config["path_rra"])) {
++      if (isset($config["rra_path"])) {
+               $rra_path = $config["rra_path"];
+       } else {
+               $rra_path = $config["base_path"] . "/rra";
+@@ -128,12 +127,12 @@
+       $rrd_archive = read_config_option("rrd_archive", TRUE);
+       if ($rrd_backup == "")
+-              $rrd_backup = $rra_path . "/backup/";
++              $rrd_backup = $rra_path . "/backup";
+       if ($rrd_archive == "")
+-              $rrd_archive = $rra_path . "/archive/";
++              $rrd_archive = $rra_path . "/archive";
+-      rrdclean_create_path($rra_path . "/backup/");
+-      rrdclean_create_path($rra_path . "/archive/");
++      rrdclean_create_path($rrd_backup);
++      rrdclean_create_path($rrd_archive);
+       /* now scan the files */
+       foreach ($file_array as $file) {
This page took 0.066586 seconds and 4 git commands to generate.