]> git.pld-linux.org Git - packages/cacti-plugin-configmanager.git/blob - cacti-plugin-configmanager.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/cacti-plugin-configmanager.git] / cacti-plugin-configmanager.spec
1 %define         plugin configmanager
2 %define         php_min_version 5.0.0
3 Summary:        Plugin for Cacti - download/upload routers and switches configuration
4 Summary(pl.UTF-8):      Wtyczka do Cacti - ściąganie/wysyłanie konfiguracji routerów/switchy
5 Name:           cacti-plugin-%{plugin}
6 Version:        0.826
7 Release:        2
8 License:        GPL v2
9 Group:          Applications/WWW
10 # http://forums.cacti.net/download.php?id=6449
11 Source0:        http://forums.cacti.net/download/file.php?id=21891#/%{plugin}-%{version}.zip
12 # Source0-md5:  d3cdb035a4d47ff464916774dd953457
13 # http://forums.cacti.net/download.php?id=10980
14 Source1:        sharednetworkclass0.40.zip
15 # Source1-md5:  b438751d7b696a10a8958ea6e0f407f3
16 URL:            http://docs.cacti.net/userplugin:configmanager
17 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
18 BuildRequires:  rpmbuild(macros) >= 1.553
19 BuildRequires:  unzip
20 Requires:       cacti
21 Requires:       cacti(pia) >= 2.0
22 Requires:       php(core) >= %{php_min_version}
23 Requires:       php(date)
24 Requires:       php(mysql)
25 Requires:       php(pcre)
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         cactidir                /usr/share/cacti
30 %define         plugindir               %{cactidir}/plugins/%{plugin}
31
32 # bad depsolver
33 %define         _noautopear     pear(include/config.php)
34
35 # put it together for rpmbuild
36 %define         _noautoreq      %{?_noautophp} %{?_noautopear}
37
38 %description
39 With Cacti configmanager plugin you can easily schedule the
40 download/upload of the configuration of your routers, switches and any
41 devices (or change in one click some parameters of a hundred of
42 switches... dangerous but possible now). It should function for all
43 type of router or switches.
44
45 There are two methods:
46 - "TFTP" (based of "pancho" <http://www.pancho.org/>); with "pure PHP"
47   option there is no need of pancho installation (depreciated after
48   v0.9)
49 - "multi" can use any scripts or SCP, FTP, SFTP or what you want.
50
51 %description -l pl.UTF-8
52 Przy użyciu wtyczki Cacti configmanager można łatwo zaszeregować
53 ściąganie lub wysyłanie konfiguracji routerów, switchy i innych
54 urządzeń (lub zmieniać jednym kliknięciem pewne parametry w setce
55 switchy... co jest niebezpieczne, ale teraz wykonalne). Wtyczka
56 powinna działać z dowolnymi routerami i switchami.
57
58 Istnieją dwie metody:
59 - "TFTP" (oparta na "pancho" <http://www.pancho.org/>); z opcją "pure
60   PHP" nie ma potrzeby instalacji pancho
61 - "multi", potrafiąca używać dowolne skrypty lub SCP, FTP, SFTP
62
63 %prep
64 %setup -qc -a1
65 %undos -f php,inc,txt
66
67 mv %{plugin}/{Manual.txt,template.txt,configmanager_trap_list.txt} .
68
69 # bad os
70 %{__rm} %{plugin}/scripts/*.cmd
71
72 # unwanted junk
73 mv %{plugin}/OLD .
74
75 # deprecated since 0.9, but package for now (see Manual.txt)
76 mv sharednetworkclass{0.40,}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{plugindir}
81 cp -a %{plugin}/* $RPM_BUILD_ROOT%{plugindir}
82 cp -a sharednetworkclass $RPM_BUILD_ROOT%{cactidir}/plugins
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc Manual.txt template.txt configmanager_trap_list.txt
90 %{plugindir}
91 %{cactidir}/plugins/sharednetworkclass
This page took 0.064228 seconds and 3 git commands to generate.