]> git.pld-linux.org Git - packages/cabextract.git/commitdiff
- changed configure patch to The Right Way(tm) RA-1_0 STABLE cabextract-0_6-2
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 26 Aug 2002 18:54:22 +0000 (18:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- segv patch: kill SEGV on compression type change
- release 2

Changed files:
    cabextract-configure.patch -> 1.2
    cabextract-segv.patch -> 1.1
    cabextract.spec -> 1.8

cabextract-configure.patch
cabextract-segv.patch [new file with mode: 0644]
cabextract.spec

index 2f111f0eafb1c59f7ca7af180b46a46cb4b83db1..5b9f10d2f516c283a3543bd87975875fc0850f81 100644 (file)
@@ -9,12 +9,11 @@ diff -uNr cabextract-0.6.orig/configure.in cabextract-0.6/configure.in
  AC_EXEEXT
  
  dnl Checks for libraries.
-@@ -29,6 +30,7 @@
+@@ -29,6 +30,6 @@
  AC_REPLACE_FUNCS(mktime)
  
  dnl check for getopt in standard library
 -AC_CHECK_FUNCS(getopt_long , , [LIBOBJS="$LIBOBJS getopt.o getopt1.o"] ) 
-+AC_LIBOBJ(getopt)
-+AC_LIBOBJ(getopt1)
++AC_CHECK_FUNCS(getopt_long , , [AC_LIBOBJ(getopt); AC_LIBOBJ(getopt1)] )
  
  AC_OUTPUT(Makefile cabextract.spec)
diff --git a/cabextract-segv.patch b/cabextract-segv.patch
new file mode 100644 (file)
index 0000000..ab3975e
--- /dev/null
@@ -0,0 +1,11 @@
+--- cabextract-0.6/cabextract.c.orig   Mon Aug 12 03:39:05 2002
++++ cabextract-0.6/cabextract.c        Mon Aug 26 20:31:50 2002
+@@ -2732,6 +2732,8 @@
+       }
+       break;
+       }
++      /* and clear method state - it's an union! */
++      memset(&decomp_state.methods,0,sizeof(decomp_state.methods));
+     }
+     switch (ct1) {
index 4f8537c9ff2a0cf09592631c29068bd2414c4978..fb2b7cd86b5a2ac13cb0393d5f6a277ca3c095c9 100644 (file)
@@ -2,11 +2,12 @@ Summary:      A program to extract Microsoft Cabinet files
 Summary(pl):   Program do rozpakowywania plików MS Cabinet
 Name:          cabextract
 Version:       0.6
-Release:       1
+Release:       2
 License:       GPL
 Group:         Applications/Archiving
 Source0:       http://www.kyz.uklinux.net/downloads/%{name}-%{version}.tar.gz
 Patch0:                %{name}-configure.patch
+Patch1:                %{name}-segv.patch
 URL:           http://www.kyz.uklinux.net/cabextract.php3
 BuildRequires: autoconf
 BuildRequires: automake
@@ -26,6 +27,7 @@ cabextract mo
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 rm -f missing
This page took 0.044218 seconds and 4 git commands to generate.