]> git.pld-linux.org Git - packages/c-ares.git/blob - c-ares.spec
c3cdde8d46f3c9f32915f09b013a089238ec462a
[packages/c-ares.git] / c-ares.spec
1 Summary:        A library that performs asynchronous DNS operations
2 Summary(pl.UTF-8):      Biblioteka do wykonywania asynchronicznych zapytań DNS
3 Name:           c-ares
4 Version:        1.17.2
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 #Source0Download: https://c-ares.haxx.se/
9 Source0:        https://c-ares.haxx.se/download/%{name}-%{version}.tar.gz
10 # Source0-md5:  3802264830c6886411dac606c66fdbf8
11 Patch0:         %{name}-resolv.conf-reading-is-not-fatal.patch
12 URL:            https://c-ares.haxx.se/
13 BuildRequires:  autoconf >= 2.57
14 BuildRequires:  automake >= 1:1.9.6
15 # for tests
16 #BuildRequires: libstdc++-devel >= 6:4.7
17 BuildRequires:  libtool >= 2:2
18 BuildRequires:  sed >= 4.0
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 c-ares is a C library that performs DNS requests and name resolves
23 asynchronously. c-ares is a fork of the library named 'ares', written
24 by Greg Hudson at MIT.
25
26 %description -l pl.UTF-8
27 c-ares jest napisaną w C biblioteką do asynchronicznego wykonywania
28 zapytań DNS. c-ares jest to fork biblioteki 'ares' napisanej przez
29 Grega Hudsona w MIT.
30
31 %package devel
32 Summary:        Development files for c-ares library
33 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki c-ares
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for c-ares library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki c-ares.
42
43 %package static
44 Summary:        Static c-ares library
45 Summary(pl.UTF-8):      Statyczna biblioteka c-ares
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static c-ares library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka c-ares.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 # we want our own debug flags, if any
60 %{__sed} -i -e 's/flags_dbg_off=".*"/flags_dbg_off="%{rpmcflags}"/' m4/cares-compilers.m4
61 %{__sed} -i -e 's/flags_opt_yes=".*"/flags_opt_yes="%{rpmcflags}"/' m4/cares-compilers.m4
62
63 %build
64 %{__libtoolize}
65 %{__aclocal} -I m4
66 %{__autoconf}
67 %{__autoheader}
68 %{__automake}
69 cd test
70 %{__libtoolize}
71 %{__aclocal} -I ../m4
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 cd ..
76 %configure \
77         --disable-silent-rules \
78         --disable-tests \
79         --enable-optimize="%{rpmcflags}" \
80         --enable-shared
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86
87 %{__make} install \
88         DESTDIR=$RPM_BUILD_ROOT
89
90 # no external dependencies + obsoleted by pkg-config
91 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libcares.la
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc AUTHORS CHANGES LICENSE.md NEWS README.cares README.md RELEASE-NOTES TODO
102 %attr(755,root,root) %{_libdir}/libcares.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libcares.so.2
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libcares.so
108 %{_includedir}/ares.h
109 %{_includedir}/ares_build.h
110 %{_includedir}/ares_dns.h
111 %{_includedir}/ares_rules.h
112 %{_includedir}/ares_version.h
113 %{_mandir}/man3/ares_*.3*
114 %{_pkgconfigdir}/libcares.pc
115
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/libcares.a
This page took 0.046286 seconds and 2 git commands to generate.