]> git.pld-linux.org Git - packages/c-ares.git/blob - c-ares.spec
- 1.7.1-post snapshot, for ares_parse_mx etc
[packages/c-ares.git] / c-ares.spec
1 %define snap 20100523
2 Summary:        A library that performs asynchronous DNS operations
3 Summary(pl.UTF-8):      Biblioteka do wykonywania asynchronicznych zapytań DNS
4 Name:           c-ares
5 Version:        1.7.1
6 Release:        1.%{snap}.0
7 License:        MIT
8 Group:          Libraries
9 Source0:        http://c-ares.haxx.se/daily-snapshot/c-ares-%{version}-%{snap}.tar.gz
10 # Source0-md5:  2c8ccd846a933c78b9dbe38bed815be9
11 Patch0:         %{name}-resolv.conf-reading-is-not-fatal.patch
12 URL:            http://daniel.haxx.se/projects/c-ares/
13 BuildRequires:  autoconf >= 2.57
14 BuildRequires:  automake
15 BuildRequires:  libtool
16 BuildRequires:  sed >= 4.0
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 c-ares is a C library that performs DNS requests and name resolves
21 asynchronously. c-ares is a fork of the library named 'ares', written
22 by Greg Hudson at MIT.
23
24 %description -l pl.UTF-8
25 c-ares jest napisaną w C biblioteką do asynchronicznego wykonywania
26 zapytań DNS. c-ares jest to fork biblioteki 'ares' napisanej przez
27 Grega Hudsona w MIT.
28
29 %package devel
30 Summary:        Development files for c-ares library
31 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki c-ares
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Header files for c-ares library.
37
38 %description devel -l pl.UTF-8
39 Pliki nagłówkowe biblioteki c-ares.
40
41 %package static
42 Summary:        Static c-ares library
43 Summary(pl.UTF-8):      Statyczna biblioteka c-ares
44 Group:          Development/Libraries
45 Requires:       %{name}-devel = %{version}-%{release}
46
47 %description static
48 Static c-ares library.
49
50 %description static -l pl.UTF-8
51 Statyczna biblioteka c-ares.
52
53 %prep
54 %setup -q -n %{name}-%{version}-%{snap}
55 %patch0 -p1
56
57 # we want our own debug flags, if any
58 sed -i -e 's/flags_dbg_off=".*"/flags_dbg_off="%{rpmcflags}"/' m4/cares-compilers.m4
59 sed -i -e 's/flags_opt_yes=".*"/flags_opt_yes="%{rpmcflags}"/' m4/cares-compilers.m4
60
61 %build
62 %{__libtoolize}
63 %{__aclocal} -I m4
64 %{__autoheader}
65 %{__autoconf}
66 %{__automake}
67 %configure \
68         --enable-optimize="%{rpmcflags}" \
69         --enable-shared
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc README README.cares CHANGES NEWS
87 %attr(755,root,root) %{_libdir}/libcares.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libcares.so.2
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libcares.so
93 %{_libdir}/libcares.la
94 %{_includedir}/ares.h
95 %{_includedir}/ares_build.h
96 %{_includedir}/ares_dns.h
97 %{_includedir}/ares_rules.h
98 %{_includedir}/ares_version.h
99 %{_mandir}/man3/ares_*.3*
100 %{_pkgconfigdir}/libcares.pc
101
102 %files static
103 %defattr(644,root,root,755)
104 %{_libdir}/libcares.a
This page took 0.083455 seconds and 3 git commands to generate.