]> git.pld-linux.org Git - packages/c-ares.git/blob - c-ares.spec
- build with our debugflags to get proper debuginfo package
[packages/c-ares.git] / c-ares.spec
1 Summary:        A library that performs asynchronous DNS operations
2 Summary(pl.UTF-8):      Biblioteka do wykonywania asynchronicznych zapytań DNS
3 Name:           c-ares
4 Version:        1.6.0
5 Release:        1
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://daniel.haxx.se/projects/c-ares/%{name}-%{version}.tar.gz
9 # Source0-md5:  4503b0db3dd79d3c1f58d87722dbab46
10 URL:            http://daniel.haxx.se/projects/c-ares/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libtool
14 BuildRequires:  sed >= 4.0
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 c-ares is a C library that performs DNS requests and name resolves
19 asynchronously. c-ares is a fork of the library named 'ares', written
20 by Greg Hudson at MIT.
21
22 %description -l pl.UTF-8
23 c-ares jest napisaną w C biblioteką do asynchronicznego wykonywania
24 zapytań DNS. c-ares jest to fork biblioteki 'ares' napisanej przez
25 Grega Hudsona w MIT.
26
27 %package devel
28 Summary:        Development files for c-ares library
29 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki c-ares
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32
33 %description devel
34 Header files for c-ares library.
35
36 %description devel -l pl.UTF-8
37 Pliki nagłówkowe biblioteki c-ares.
38
39 %package static
40 Summary:        Static c-ares library
41 Summary(pl.UTF-8):      Statyczna biblioteka c-ares
42 Group:          Development/Libraries
43 Requires:       %{name}-devel = %{version}-%{release}
44
45 %description static
46 Static c-ares library.
47
48 %description static -l pl.UTF-8
49 Statyczna biblioteka c-ares.
50
51 %prep
52 %setup -q
53
54 # we want our own debug flags, if any
55 sed -i -e 's/flags_dbg_off=".*"/flags_dbg_off="%{rpmcflags}"/' m4/cares-compilers.m4
56 sed -i -e 's/flags_opt_yes=".*"/flags_opt_yes="%{rpmcflags}"/' m4/cares-compilers.m4
57
58 %build
59 %{__libtoolize}
60 %{__aclocal} -I m4
61 %{__autoconf}
62 %{__automake}
63 %configure \
64         --enable-optimize="%{rpmcflags}" \
65         --enable-shared
66
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 %{__make} install \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 %clean
75 rm -rf $RPM_BUILD_ROOT
76
77 %post   -p /sbin/ldconfig
78 %postun -p /sbin/ldconfig
79
80 %files
81 %defattr(644,root,root,755)
82 %doc README README.cares CHANGES NEWS
83 %attr(755,root,root) %{_libdir}/libcares.so.*.*.*
84 %attr(755,root,root) %ghost %{_libdir}/libcares.so.2
85
86 %files devel
87 %defattr(644,root,root,755)
88 %{_libdir}/libcares.so
89 %{_libdir}/libcares.la
90 %{_includedir}/ares*.h
91 %{_mandir}/man3/ares_*.3*
92 %{_pkgconfigdir}/libcares.pc
93
94 %files static
95 %defattr(644,root,root,755)
96 %{_libdir}/libcares.a
This page took 0.092555 seconds and 3 git commands to generate.