]> git.pld-linux.org Git - packages/c-ares.git/blob - c-ares.spec
- treat not readable resolv.conf (and other /etc files) as if it was empty, not give...
[packages/c-ares.git] / c-ares.spec
1 Summary:        A library that performs asynchronous DNS operations
2 Summary(pl.UTF-8):      Biblioteka do wykonywania asynchronicznych zapytań DNS
3 Name:           c-ares
4 Version:        1.6.0
5 Release:        2
6 License:        MIT
7 Group:          Libraries
8 Source0:        http://daniel.haxx.se/projects/c-ares/%{name}-%{version}.tar.gz
9 # Source0-md5:  4503b0db3dd79d3c1f58d87722dbab46
10 Patch0:         %{name}-resolv.conf-reading-is-not-fatal.patch
11 URL:            http://daniel.haxx.se/projects/c-ares/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libtool
15 BuildRequires:  sed >= 4.0
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 c-ares is a C library that performs DNS requests and name resolves
20 asynchronously. c-ares is a fork of the library named 'ares', written
21 by Greg Hudson at MIT.
22
23 %description -l pl.UTF-8
24 c-ares jest napisaną w C biblioteką do asynchronicznego wykonywania
25 zapytań DNS. c-ares jest to fork biblioteki 'ares' napisanej przez
26 Grega Hudsona w MIT.
27
28 %package devel
29 Summary:        Development files for c-ares library
30 Summary(pl.UTF-8):      Pliki nagłówkowe dla biblioteki c-ares
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33
34 %description devel
35 Header files for c-ares library.
36
37 %description devel -l pl.UTF-8
38 Pliki nagłówkowe biblioteki c-ares.
39
40 %package static
41 Summary:        Static c-ares library
42 Summary(pl.UTF-8):      Statyczna biblioteka c-ares
43 Group:          Development/Libraries
44 Requires:       %{name}-devel = %{version}-%{release}
45
46 %description static
47 Static c-ares library.
48
49 %description static -l pl.UTF-8
50 Statyczna biblioteka c-ares.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55
56 # we want our own debug flags, if any
57 sed -i -e 's/flags_dbg_off=".*"/flags_dbg_off="%{rpmcflags}"/' m4/cares-compilers.m4
58 sed -i -e 's/flags_opt_yes=".*"/flags_opt_yes="%{rpmcflags}"/' m4/cares-compilers.m4
59
60 %build
61 %{__libtoolize}
62 %{__aclocal} -I m4
63 %{__autoconf}
64 %{__automake}
65 %configure \
66         --enable-optimize="%{rpmcflags}" \
67         --enable-shared
68
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc README README.cares CHANGES NEWS
85 %attr(755,root,root) %{_libdir}/libcares.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libcares.so.2
87
88 %files devel
89 %defattr(644,root,root,755)
90 %{_libdir}/libcares.so
91 %{_libdir}/libcares.la
92 %{_includedir}/ares*.h
93 %{_mandir}/man3/ares_*.3*
94 %{_pkgconfigdir}/libcares.pc
95
96 %files static
97 %defattr(644,root,root,755)
98 %{_libdir}/libcares.a
This page took 0.069313 seconds and 3 git commands to generate.