]> git.pld-linux.org Git - packages/bzrtp.git/commitdiff
- updated to 5.2.51 auto/th/bzrtp-5.2.51-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 19 Apr 2023 04:33:10 +0000 (06:33 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 19 Apr 2023 04:33:10 +0000 (06:33 +0200)
- added patch to restore resetBzrtpContext function (used by linphone 5.1.x suite)

bzrtp-resetBzrtpContext.patch [new file with mode: 0644]
bzrtp.spec

diff --git a/bzrtp-resetBzrtpContext.patch b/bzrtp-resetBzrtpContext.patch
new file mode 100644 (file)
index 0000000..505a988
--- /dev/null
@@ -0,0 +1,31 @@
+--- bzrtp-5.2.51/include/bzrtp/bzrtp.h.orig    2023-02-22 10:01:18.000000000 +0100
++++ bzrtp-5.2.51/include/bzrtp/bzrtp.h 2023-04-18 21:56:42.215384029 +0200
+@@ -272,6 +272,8 @@ BZRTP_EXPORT bzrtpContext_t *bzrtp_creat
+  */
+ BZRTP_EXPORT int bzrtp_initBzrtpContext(bzrtpContext_t *context, uint32_t selfSSRC);
++BZRTP_EXPORT void bzrtp_resetBzrtpContext(bzrtpContext_t *context);
++
+ /**
+  * Free memory of context structure to a channel, if all channels are freed, free the global zrtp context
+  * @param[in] context         Context hosting the channel to be destroyed.(note: the context zrtp context itself is destroyed with the last channel)
+--- bzrtp-5.2.51/src/bzrtp.c.orig      2023-02-22 10:01:18.000000000 +0100
++++ bzrtp-5.2.51/src/bzrtp.c   2023-04-18 21:59:34.831115556 +0200
+@@ -181,6 +181,17 @@ int bzrtp_setZIDCache_lock(bzrtpContext_
+ #endif /* ZIDCACHE_ENABLED */
+ }
++void bzrtp_resetBzrtpContext(bzrtpContext_t *context) {
++      int i;
++      for (i=0; i<ZRTP_MAX_CHANNEL_NUMBER; i++) {
++              if (context->channelContext[i]) {
++                      void * clientData = context->channelContext[i]->clientData;
++                      bzrtp_initChannelContext(context, context->channelContext[i], context->channelContext[i]->selfSSRC, context->channelContext[i]->isMainChannel);
++                      context->channelContext[i]->clientData = clientData;
++              }
++      }
++}
++
+ /**
+  * @brief Perform some initialisation which can't be done without some callback functions:
+  *  This function is called once per session when the first channel is created.
index 476c1c59eee06716e671de796c9f4a408efb15f7..b3edc99a9a54eb30d6670469f4cda36994a4b9b1 100644 (file)
@@ -5,14 +5,15 @@
 Summary:       Open source implementation of ZRTP keys exchange protocol
 Summary(pl.UTF-8):     Mająca otwarte źródła implementacja protokołu wymiany kluczy ZRTP
 Name:          bzrtp
-Version:       5.2.49
+Version:       5.2.51
 Release:       1
 License:       GPL v3+
 Group:         Libraries
 #Source0Download: https://gitlab.linphone.org/BC/public/bzrtp/tags
 Source0:       https://gitlab.linphone.org/BC/public/bzrtp/-/archive/%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: 30ed3cd6347609129eb71a3b7246eee0
+# Source0-md5: 6b6957011c7f82a37af2407645a204e5
 Patch0:                %{name}-static.patch
+Patch1:                %{name}-resetBzrtpContext.patch
 URL:           http://www.linphone.org/
 BuildRequires: CUnit
 BuildRequires: bctoolbox-devel >= 4.4.0
@@ -62,6 +63,7 @@ Statyczna biblioteka bzrtp.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 install -d builddir
This page took 0.61413 seconds and 4 git commands to generate.