]> git.pld-linux.org Git - packages/bzr-gtk.git/commitdiff
- Release 2. Fix for detecting dbus availability. auto/th/bzr-gtk-0_95_0-2
authorMateusz Korniak <matkor@pld-linux.org>
Wed, 6 Aug 2008 06:52:21 +0000 (06:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bzr-gtk-dbus_detection_fix.patch -> 1.1
    bzr-gtk.spec -> 1.18

bzr-gtk-dbus_detection_fix.patch [new file with mode: 0644]
bzr-gtk.spec

diff --git a/bzr-gtk-dbus_detection_fix.patch b/bzr-gtk-dbus_detection_fix.patch
new file mode 100644 (file)
index 0000000..8944bc5
--- /dev/null
@@ -0,0 +1,17 @@
+=== modified file 'seahorse.py'
+--- old/seahorse.py    2008-07-23 00:07:09 +0000
++++ new/seahorse.py    2008-08-05 13:55:03 +0000
+@@ -40,6 +40,12 @@
+         name = get_name()
+     else:
+         name = getattr(e, '_dbus_error_name', None)
++        
++    if name is None:
++        args = getattr(e, 'args', None) # This is case for old python-dbus-0.62
++        if args == ("Unable to determine the address of the message bus (try 'man dbus-launch' and 'man dbus-daemon' for help)",):
++            raise ImportError
++        
+     # DBus sometimes fails like this, just treat it as if seahorse is not
+     # available rather than crashing.
+     if name in ("org.freedesktop.DBus.Error.Spawn.ExecFailed", 
+
index a5ed550072f7c55d2717d18e72325b5154671f99..d97c7b88dfa2af240ee84005ba853a600e239221 100644 (file)
@@ -5,12 +5,13 @@ Name:         bzr-gtk
 %define                ver     0.95
 %define                minor   0
 Version:       %{ver}.%{minor}
 %define                ver     0.95
 %define                minor   0
 Version:       %{ver}.%{minor}
-Release:       1
+Release:       2
 License:       GPL v2+
 Group:         Development/Version Control
 # Source0:     https://launchpad.net/bzr-gtk/%{ver}/%{version}/+download/bzr-gtk-%{version}.tar.gz
 Source0:       http://samba.org/~jelmer/bzr/bzr-gtk-%{version}.tar.gz
 # Source0-md5: 00aedce625672abca13d2d962b047ac0
 License:       GPL v2+
 Group:         Development/Version Control
 # Source0:     https://launchpad.net/bzr-gtk/%{ver}/%{version}/+download/bzr-gtk-%{version}.tar.gz
 Source0:       http://samba.org/~jelmer/bzr/bzr-gtk-%{version}.tar.gz
 # Source0-md5: 00aedce625672abca13d2d962b047ac0
+Patch0:                %{name}-dbus_detection_fix.patch
 URL:           http://bazaar-vcs.org/bzr-gtk
 BuildRequires: python >= 1:2.4
 BuildRequires: rpm-pythonprov
 URL:           http://bazaar-vcs.org/bzr-gtk
 BuildRequires: python >= 1:2.4
 BuildRequires: rpm-pythonprov
@@ -45,6 +46,8 @@ Bazaar. Dostępnymi poleceniami są:
 
 %prep
 %setup 
 
 %prep
 %setup 
+%patch0 -p1
+
 
 %build
 %{__python} setup.py build
 
 %build
 %{__python} setup.py build
This page took 0.085308 seconds and 4 git commands to generate.