]> git.pld-linux.org Git - packages/bzr-gtk.git/blob - bzr-gtk.spec
- Removed dbus patch, included upstream
[packages/bzr-gtk.git] / bzr-gtk.spec
1 # TODO:
2 # - Add locale files
3 # - Add new package for Olive, previously included here now it's own project: http://wiki.bazaar.canonical.com/Olive/
4 %define         ver     0.99
5 %define         minor   1
6 Summary:        Plugin for Bazaar-NG (bzr)
7 Summary(pl.UTF-8):      Wtyczka do Bazaar-NG (bzr)
8 Name:           bzr-gtk
9 Version:        %{ver}.%{minor}
10 Release:        8
11 License:        GPL v2+
12 Group:          Development/Version Control
13 # Source0:      https://launchpad.net/bzr-gtk/%{ver}/%{version}/+download/bzr-gtk-%{version}.tar.gz
14 Source0:        http://samba.org/~jelmer/bzr/%{name}-%{version}.tar.gz
15 # Source0-md5:  68354924f3104ab1ba7efc8bfe15ae0b
16 URL:            http://bazaar-vcs.org/bzr-gtk
17 BuildRequires:  gettext-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  python >= 1:2.4
20 BuildRequires:  python-devel
21 BuildRequires:  rpm-pythonprov
22 BuildRequires:  rpmbuild(macros) >= 1.219
23 Requires(post,postun):  desktop-file-utils
24 %pyrequires_eq  python
25 Requires:       bzr >= %{ver}
26 Requires:       python-pygtk-glade >= 2:2.10
27 Requires:       python-pygtk-gtk >= 2:2.10
28 Suggests:       python-gnome
29 Suggests:       python-pycairo
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 bzr-gtk is a plugin for Bazaar-NG (bzr) that aims to provide GTK+
34 interfaces to most Bazaar operations. Provided commands are:
35 - gcommit
36 - gdiff
37 - visualise
38 - gannotate
39 - gbranch
40
41 %description -l pl.UTF-8
42 bzr-gtk jest wtyczką dla Bazaar-NG (bzr), która ma na celu
43 dostarczenie graficznego interfejsu GTK+ dla większości poleceń
44 Bazaar. Dostępnymi poleceniami są:
45 - gcommit
46 - gdiff
47 - visualise
48 - gannotate
49 - gbranch
50
51 %prep
52 %setup -q
53
54 %build
55 %{__python} setup.py build
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__python} setup.py install \
61         --install-purelib %{py_sitedir} \
62         --optimize=2 \
63         --root=$RPM_BUILD_ROOT
64
65 %py_postclean
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 %update_desktop_database_post
72 %banner %{name} -e << EOF
73 For full functionality, you need to install:
74 - python-pycairo (for graphs in the visualisation tool)
75 - python-gnome (for Nautilus integration)
76 EOF
77
78 %postun
79 %update_desktop_database_postun
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS NEWS README TODO
84 %attr(755,root,root) %{_bindir}/bzr-handle-patch
85 %attr(755,root,root) %{_bindir}/bzr-notify
86 %{py_sitedir}/bzrlib/plugins/gtk
87 %{_datadir}/bzr-gtk
88 %{_desktopdir}/bazaar-properties.desktop
89 %{_desktopdir}/bzr-notify.desktop
90 %{_desktopdir}/bzr-handle-patch.desktop
91 %{_pixmapsdir}/bzr-icon-64.png
92 %{_iconsdir}/hicolor/scalable/emblems
93 %{_datadir}/application-registry/bzr-gtk.applications
This page took 0.072751 seconds and 4 git commands to generate.