]> git.pld-linux.org Git - packages/byobu.git/commitdiff
up to 5.97
authorElan Ruusamäe <glen@delfi.ee>
Sun, 3 Apr 2016 17:54:58 +0000 (20:54 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 3 Apr 2016 17:54:58 +0000 (20:54 +0300)
byobu.spec

index 51d0b3d6c60dd859b3a34072482752c755042e75..ce56d3b44572719c49a7d120206888e373c166c9 100644 (file)
@@ -2,21 +2,25 @@ Summary:      A set of useful profiles and a profile-switcher for GNU screen
 Summary(hu.UTF-8):     Hasznos profilok és profilváltó gyűjteménye a GNU screen-hez
 Summary(pl.UTF-8):     Zestaw przydatnych profili oraz przełącznik profili dla GNU screena
 Name:          byobu
-Version:       2.36
+Version:       5.97
 Release:       0.1
-License:       GPL
+License:       GPL v3
 Group:         Applications/System
-Source0:       http://code.launchpad.net/byobu/trunk/2.36/+download/%{name}_%{version}.orig.tar.gz
-# Source0-md5: 6dd84835ec1e7b3b4bf7f7e2da952896
-URL:           https://code.launchpad.net/byobu
+Source0:       https://code.launchpad.net/byobu/trunk/%{version}/+download/%{name}_%{version}.orig.tar.gz
+# Source0-md5: 06fc9398700de1ecba576e0819fe5626
+URL:           https://launchpad.net/byobu
 BuildRequires: gettext-tools
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.596
+Requires:      desktop-file-utils
 Requires:      newt
 Requires:      python >= 1:2.5
 Requires:      screen
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _libexecdir     %{_prefix}/lib
+
 %description
 Byobu is an elegant enhancement of the otherwise functional, plain,
 practical GNU Screen. Byobu includes an enhanced profile and
@@ -36,54 +40,84 @@ narzędzia konfiguracyjne dla zarządcy okien, jakim jest GNU screen
 - takie jak przełączane powiadomienia o stanie systemu.
 
 %prep
-%setup -q -n %{name}_%{version}.orig
+%setup -q
 
 %build
-profiles_generator/generate
+%configure
+%{__make}
+
+for po in po/*.po; do
+       lang=${po#po/}
+       lang=${lang%.po}
+       mkdir -p locale/${lang}/LC_MESSAGES/
+       msgfmt ${po} -o locale/${lang}/LC_MESSAGES/%{name}.mo
+done
 
 %install
 rm -rf $RPM_BUILD_ROOT
+%{__make} install \
+       INSTALL="install -p" \
+       CP="cp -p" \
+       docdir=%{_docdir}/%{name} \
+       DESTDIR=$RPM_BUILD_ROOT
+
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
 
-debian/rules install-po
-install -d $RPM_BUILD_ROOT%{_libdir}/byobu
-install -d $RPM_BUILD_ROOT%{_datadir}/locale
-install -d $RPM_BUILD_ROOT%{_datadir}/byobu/profiles
-install -d $RPM_BUILD_ROOT%{_datadir}/byobu/keybindings
-install -d $RPM_BUILD_ROOT%{_datadir}/byobu/windows
-install -d $RPM_BUILD_ROOT%{_bindir}
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/byobu
-install -d $RPM_BUILD_ROOT%{_mandir}/man1
-%{__cp} bin/* $RPM_BUILD_ROOT%{_libdir}/byobu
-%{__cp} -r po/locale/* $RPM_BUILD_ROOT%{_datadir}/locale
-%{__cp} profiles/{byoburc,common,NONE,black,dark,light} $RPM_BUILD_ROOT%{_datadir}/byobu/profiles
-ln -sf f-keys $RPM_BUILD_ROOT%{_datadir}/byobu/keybindings/common
-%{__cp} keybindings/{f-keys,none} $RPM_BUILD_ROOT%{_datadir}/byobu/keybindings
-%{__cp} windows/common $RPM_BUILD_ROOT%{_datadir}/byobu/windows
-%{__cp} byobu byobu-{select-profile,config,launcher,janitor,export,status,status-detail} \
-       motd+shell $RPM_BUILD_ROOT%{_bindir}
-%{__cp} byobu-launcher-{,un}install $RPM_BUILD_ROOT%{_datadir}/byobu
-%{__cp} profiles/*_* $RPM_BUILD_ROOT%{_datadir}/byobu/profiles
-%{__cp} statusrc $RPM_BUILD_ROOT%{_sysconfdir}/byobu
-%{__cp} *.1 $RPM_BUILD_ROOT%{_mandir}/man1
+install -d $RPM_BUILD_ROOT%{_localedir}
+cp -a locale/* $RPM_BUILD_ROOT%{_localedir}
 
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post
+%update_desktop_database
+
+%postun
+%update_desktop_database
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/motd+shell
-%attr(755,root,root) %{_bindir}/byobu-launcher
-%attr(755,root,root) %{_bindir}/byobu-janitor
+%doc README
+%doc usr/share/doc/byobu/*.txt
+%dir %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/backend
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/socketdir
 %attr(755,root,root) %{_bindir}/byobu
 %attr(755,root,root) %{_bindir}/byobu-config
+%attr(755,root,root) %{_bindir}/byobu-ctrl-a
+%attr(755,root,root) %{_bindir}/byobu-disable
+%attr(755,root,root) %{_bindir}/byobu-disable-prompt
+%attr(755,root,root) %{_bindir}/byobu-enable
+%attr(755,root,root) %{_bindir}/byobu-enable-prompt
 %attr(755,root,root) %{_bindir}/byobu-export
+%attr(755,root,root) %{_bindir}/byobu-janitor
+%attr(755,root,root) %{_bindir}/byobu-keybindings
+%attr(755,root,root) %{_bindir}/byobu-launch
+%attr(755,root,root) %{_bindir}/byobu-launcher
+%attr(755,root,root) %{_bindir}/byobu-launcher-install
+%attr(755,root,root) %{_bindir}/byobu-launcher-uninstall
+%attr(755,root,root) %{_bindir}/byobu-layout
+%attr(755,root,root) %{_bindir}/byobu-prompt
+%attr(755,root,root) %{_bindir}/byobu-quiet
+%attr(755,root,root) %{_bindir}/byobu-reconnect-sockets
+%attr(755,root,root) %{_bindir}/byobu-screen
+%attr(755,root,root) %{_bindir}/byobu-select-backend
+%attr(755,root,root) %{_bindir}/byobu-select-profile
+%attr(755,root,root) %{_bindir}/byobu-select-session
+%attr(755,root,root) %{_bindir}/byobu-shell
+%attr(755,root,root) %{_bindir}/byobu-silent
 %attr(755,root,root) %{_bindir}/byobu-status
 %attr(755,root,root) %{_bindir}/byobu-status-detail
-%attr(755,root,root) %{_bindir}/byobu-select-profile
-%{_libdir}/byobu
-%{_datadir}/byobu
-%{_sysconfdir}/byobu
-%doc README doc/help.txt debian/changelog
-%{_mandir}/man1/*
+%attr(755,root,root) %{_bindir}/byobu-tmux
+%attr(755,root,root) %{_bindir}/byobu-ugraph
+%attr(755,root,root) %{_bindir}/byobu-ulevel
+%attr(755,root,root) %{_bindir}/col1
+%attr(755,root,root) %{_bindir}/ctail
+%attr(755,root,root) %{_bindir}/vigpg
+%attr(755,root,root) %{_bindir}/wifi-status
+%{_mandir}/man1/*.1*
+%{_libexecdir}/%{name}
+%{_datadir}/%{name}
+%{_desktopdir}/%{name}.desktop
This page took 0.084537 seconds and 4 git commands to generate.