]> git.pld-linux.org Git - packages/byaccj.git/blob - byaccj.spec
- up to 1.15
[packages/byaccj.git] / byaccj.spec
1 Summary:        Parser Generator with Java Extension
2 Summary(pl.UTF-8):      Generator analizatorów rozszerzony o Javę
3 Name:           byaccj
4 Version:        1.15
5 Release:        1
6 License:        Public Domain
7 Group:          Development/Languages/Java
8 Source0:        http://dl.sourceforge.net/byaccj/%{name}%{version}_src.tar.gz
9 # Source0-md5:  5ee9959af35f245ac2c4355f85fdf351
10 Patch0:         %{name}-cflags.patch
11 Patch1:         %{name}-mkstemp.patch
12 URL:            http://byaccj.sourceforge.net/
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 BYACC/J is an extension of the Berkeley v 1.8 YACC-compatible parser
17 generator. Standard YACC takes a YACC source file, and generates one
18 or more C files from it, which if compiled properly, will produce a
19 LALR-grammar parser. This is useful for expression parsing,
20 interactive command parsing, and file reading. Many megabytes of YACC
21 code have been written over the years. This is the standard YACC tool
22 that is in use every day to produce C/C++ parsers, but it has added a
23 "-J" flag which will cause BYACC to generate Java source code,
24 instead. So there finally is a YACC for Java now!
25
26 %description -l pl.UTF-8
27 BYACC/J to rozszerzenie generatora analizatorów kompatybilnego z
28 Berkeley YACC 1.8. Standardowy YACC pobiera plik źródłowy YAC i tworzy
29 z niego jeden lub więcej plików C, które po skompilowaniu tworzą
30 analizator gramatyki LALR. Jest on przydatny do analizy wyrażeń,
31 analizy interaktywnych poleceń oraz czytania plików. Na przestrzeni
32 lat powstało wiele megabajtów kodu YACC. Ten pakiet zawiera
33 standardowe narzędzie YACC używane na co dzień do tworzenia
34 analizatorów C/C++, ale ma dodaną flagę "-J", która powoduje
35 generowanie kodu źródłowego w Javie zamiast C/C++. W ten sposób
36 powstał YACC dla Javy.
37
38 %prep
39 %setup -q -n %{name}%{version}
40
41 %patch0 -p1
42 %patch1 -p1
43
44 %build
45 %{__make} -C src linux \
46         CC="%{__cc}" \
47         CFLAGS="%{rpmcflags}" \
48         LDFLAGS="%{rpmldflags}"
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52 install -d $RPM_BUILD_ROOT%{_bindir}
53 install src/yacc.linux $RPM_BUILD_ROOT%{_bindir}/%{name}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc docs/* src/{new_features,no_warranty}
61 %attr(755,root,root) %{_bindir}/%{name}
This page took 0.067254 seconds and 3 git commands to generate.