]> git.pld-linux.org Git - packages/busybox.git/commitdiff
Reenable RPC and NFS mount.
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 15 Jun 2022 09:27:29 +0000 (11:27 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 15 Jun 2022 09:27:29 +0000 (11:27 +0200)
busybox.config
busybox.spec

index 6d13500ac7d892b20ea61f951d0aa5ccb402ece9..ebdc61a1a1b6b98e543bee180ace5fddaffcd0ea 100644 (file)
@@ -49,7 +49,7 @@ CONFIG_FEATURE_PREFER_APPLETS=y
 CONFIG_BUSYBOX_EXEC_PATH="/bin/busybox"
 CONFIG_FEATURE_SYSLOG=y
 CONFIG_FEATURE_SYSLOG_INFO=y
-# CONFIG_FEATURE_HAVE_RPC is not set
+CONFIG_FEATURE_HAVE_RPC=y
 CONFIG_PLATFORM_LINUX=y
 
 #
@@ -722,7 +722,7 @@ CONFIG_FEATURE_MOUNT_FAKE=y
 CONFIG_FEATURE_MOUNT_VERBOSE=y
 CONFIG_FEATURE_MOUNT_HELPERS=y
 CONFIG_FEATURE_MOUNT_LABEL=y
-# CONFIG_FEATURE_MOUNT_NFS is not set
+CONFIG_FEATURE_MOUNT_NFS=y
 CONFIG_FEATURE_MOUNT_CIFS=y
 CONFIG_FEATURE_MOUNT_FLAGS=y
 CONFIG_FEATURE_MOUNT_FSTAB=y
@@ -941,7 +941,7 @@ CONFIG_FEATURE_INETD_SUPPORT_BUILTIN_DISCARD=y
 CONFIG_FEATURE_INETD_SUPPORT_BUILTIN_TIME=y
 CONFIG_FEATURE_INETD_SUPPORT_BUILTIN_DAYTIME=y
 CONFIG_FEATURE_INETD_SUPPORT_BUILTIN_CHARGEN=y
-# CONFIG_FEATURE_INETD_RPC is not set
+CONFIG_FEATURE_INETD_RPC=y
 CONFIG_IP=y
 CONFIG_FEATURE_IP_ADDRESS=y
 CONFIG_FEATURE_IP_LINK=y
index 99b49d70e74b8194124000e9874d378c56b06cdb..803783aa3c78d829019c4a1cf164c262a93250d6 100644 (file)
@@ -1,5 +1,4 @@
 # TODO:
-# - RPC/NFS with uClibc doesn't build (due to tirpc linking), so it's currently disabled
 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
 #   if it still serves a purpose
 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
@@ -112,14 +111,15 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                filterout_ld    -Wl,-z,(combreloc|relro)
 
-%if %{with glibc}
 %define                tirpccflags     %(pkg-config --cflags libtirpc)
+%if %{with glibc}
 %if %{with initrd} || %{with static}
 %define                tirpcslibs      %(pkg-config --libs --static libtirpc krb5 krb5-gssapi openssl sqlite3|sed 's/-l//g')
 %endif
-%if %{with dynamic}
-%define                tirpcdlibs      %(pkg-config --libs libtirpc|sed s/-l//g)
 %endif
+
+%if %{with dynamic}
+%define         tirpcdlibs      %(pkg-config --libs libtirpc|sed s/-l//g)
 %endif
 
 %description
@@ -204,7 +204,7 @@ echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcslibs}}"' >> .config
 %{__make} oldconfig
 %{__make} \
        %{?with_verbose:V=1} \
-       EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} -Os -D_GNU_SOURCE %{!?with_glibc:-fno-stack-protector}" \
+       EXTRA_CFLAGS="%{rpmcflags} %{tirpccflags} -Os -D_GNU_SOURCE %{!?with_glibc:-fno-stack-protector}" \
        EXTRA_LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack" \
 %if %{with dietlibc}
        LIBRARIES="-lrpc" \
@@ -235,7 +235,7 @@ echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcslibs}}"' >> .config
 %{__make} oldconfig
 %{__make} \
        %{?with_verbose:V=1} \
-       EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} -Os -D_GNU_SOURCE %{!?with_glibc:-fno-stack-protector}" \
+       EXTRA_CFLAGS="%{rpmcflags} %{tirpccflags} -Os -D_GNU_SOURCE %{!?with_glibc:-fno-stack-protector}" \
        EXTRA_LDFLAGS="%{rpmldflags} -static -Wl,-z,noexecstack" \
 %if %{with dietlibc}
        LIBRARIES="-lrpc" \
@@ -261,13 +261,13 @@ mv -f busybox built/busybox.static
 install %{SOURCE3} .config
 %else
 install %{SOURCE1} .config
-echo 'CONFIG_EXTRA_LDLIBS="%{?with_glibc:%{tirpcdlibs}}"' >> .config
+echo 'CONFIG_EXTRA_LDLIBS="%{tirpcdlibs}"' >> .config
 %endif
 %{__make} oldconfig
 %{__make} \
        %{?with_verbose:V=1} \
        %{CrossOpts} \
-       EXTRA_CFLAGS="%{rpmcflags} %{?with_glibc:%{tirpccflags}} %{!?with_glibc:-fno-stack-protector}" \
+       EXTRA_CFLAGS="%{rpmcflags} %{tirpccflags} %{!?with_glibc:-fno-stack-protector}" \
        EXTRA_LDFLAGS="%{rpmldflags} -Wl,-z,noexecstack" \
        CC="%{__cc}"
 %{__make} busybox.links docs/busybox.1
This page took 0.234676 seconds and 4 git commands to generate.