]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- add cvs-20050604.patch - now build with gcc4
[packages/busybox.git] / busybox.spec
1 #
2 # TODO:
3 #       - sparc64 modules support in sparc(32) version
4 #       - make internal commands work even if busybox is not in /bin/busybox
5
6 #
7 # Conditional build:
8 # alternative busybox config file (replaces default one) you should
9 # define cfgfile macro, i.e.
10 #
11 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
12 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
13 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
14 # Options below are useful, when you want fileutils and grep providing.
15 # For example, ash package requires fileutils and grep.
16 %bcond_with     fileutl_prov    # adds fileutils providing
17 %bcond_with     grep_prov       # adds grep providing
18 # Option below is useful, when busybox is built with shell support.
19 %bcond_with     sh_prov         # adds /bin/sh providing
20 # WARNING! Shell, filetuils and grep providing may depend on config file!
21 # Fileutils, grep and shell provided with busybox have not such
22 # functionality as their GNU countenders.
23 #
24 %bcond_without  static          # don't build static version
25 %bcond_without  initrd          # don't build initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 #
29 %ifnarch %{ix86}
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common unix utils for embeded systems
33 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 Version:        1.00
37 Release:        3
38 License:        GPL
39 Group:          Applications
40 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
41 # Source0-md5:  5c7ea9b5d3b3677dfcdcec38b281a756
42 Source1:        %{name}.config
43 Source2:        %{name}-initrd.config
44 %{?with_altconfig:Source3:      %{cfgfile}}
45 Patch0:         %{name}-logconsole.patch
46 Patch1:         %{name}-printf-gettext.patch
47 Patch2:         %{name}-loadfont.patch
48 Patch3:         %{name}-pivot_root.patch
49 Patch4:         %{name}-raid_start.patch
50 Patch5:         %{name}-force-dietlibc.patch
51 Patch6:         %{name}-ash_exec.patch
52 Patch7:         %{name}-kernel_headers.patch
53 Patch8:         %{name}-insmod-morearchs.patch
54 Patch9:         %{name}-dhcp.patch
55 Patch10:        %{name}-switchroot.patch
56 Patch11:        %{name}-fix_64_archs.patch
57 Patch12:        %{name}-LFS.patch
58 Patch13:        %{name}-ftpput.patch
59 #http://www.zelow.no/floppyfw/download/Development/Patches/busybox-snapshot/busybox-lzmacat.diff
60 Patch14:        %{name}-lzmacat.diff
61 Patch15:        %{name}-cvs-20050604.patch
62 URL:            http://www.busybox.net/
63 BuildRequires:  gcc >= 3.2
64 %{?with_static:BuildRequires:   glibc-static}
65 %if %{with initrd}
66         %if %{with dietlibc}
67 BuildRequires:  dietlibc-static
68         %else
69                 %if %{with glibc}
70 BuildRequires:  glibc-static
71                 %else
72 BuildRequires:  uClibc-static >= 0.9.21
73                 %endif
74         %endif
75 %endif
76 %{?with_fileutl_prov:Provides:  fileutils}
77 %{?with_grep_prov:Provides:     grep}
78 %{?with_sh_prov:Provides:       /bin/sh}
79 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
80
81
82 %define         _bindir         /bin
83 %define         _initrd_bindir  /bin
84
85 %description
86 BusyBox combines tiny versions of many common UNIX utilities into a
87 single small executable. It provides minimalist replacements for most
88 of the utilities you usually find in fileutils, shellutils, findutils,
89 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
90 POSIX environment for any small or embedded system. The utilities in
91 BusyBox generally have fewer options than their full-featured GNU
92 cousins; however, the options that are included provide the expected
93 functionality and behave very much like their GNU counterparts.
94
95 BusyBox has been written with size-optimization and limited resources
96 in mind. It is also extremely modular so you can easily include or
97 exclude commands (or features) at compile time. This makes it easy to
98 customize your embedded systems. To create a working system, just add
99 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
100 ae).
101
102 %description -l pl
103 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
104 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
105 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
106 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
107 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
108 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
109 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
110 (np. elvis-tiny albo ae).
111
112 %description -l pt_BR
113 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
114 executável, fornecendo substitutos minimalistas para muitos dos
115 executáveis encontrados em pacotes como fileutils, shellutils,
116 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
117 em geral têm menos opções que os utilitários GNU, mas as opções
118 implementadas comportam-se de maneira similar aos equivalentes GNU.
119
120 %package static
121 Summary:        Static busybox
122 Summary(pl):    Statycznie skonsolidowany busybox
123 Group:          Applications
124
125 %description static
126 Static busybox.
127
128 %description static -l pl
129 Statycznie skonsolidowany busybox.
130
131 %package initrd
132 Summary:        Static busybox for initrd
133 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
134 Group:          Applications
135 Conflicts:      geninitrd < 3075
136
137 %description initrd
138 Static busybox for initrd.
139
140 %description initrd -l pl
141 Statycznie skonsolidowany busybox dla initrd.
142
143 %prep
144 %setup -q
145 %patch15 -p1
146 %patch0 -p1
147 %patch1 -p1
148 %patch2 -p1
149 %patch3 -p1
150 %patch4 -p1
151 %patch5 -p1
152 %patch6 -p1
153 %patch7 -p1
154 %patch8 -p1
155 %patch9 -p1
156 %patch10 -p1
157 %patch11 -p1
158 %patch12 -p1
159 %patch13 -p1
160 %patch14 -p1
161
162 %build
163 install %{SOURCE1} .config
164
165 %if %{with initrd}
166 install %{SOURCE2} .config
167 %{__make} oldconfig
168 %{__make} \
169         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
170         LDFLAGS="%{rpmldflags} -static" \
171 %if %{with dietlibc}
172         LIBRARIES="-lrpc" \
173         CC="diet gcc"
174 %else
175 %if %{with glibc}
176         CC="%{__cc}"
177 %else
178         CC="%{_target_cpu}-uclibc-gcc"
179 %endif
180 %endif
181
182 mv -f busybox busybox.initrd
183 %{__make} clean
184 install %{SOURCE1} .config
185 %endif
186
187 %if %{with altconfig}
188 install %{SOURCE3} .config
189 %endif
190
191 %if %{with static}
192 %{__make} oldconfig
193 %{__make} \
194         CFLAGS_EXTRA="%{rpmcflags}" \
195         LDFLAGS="%{rpmldflags} -static" \
196         CC="%{__cc}"
197 mv -f busybox busybox.static
198 %{__make} clean
199 %endif
200
201 %{__make} oldconfig
202 %{__make} \
203         CFLAGS_EXTRA="%{rpmcflags}" \
204         LDFLAGS="%{rpmldflags}" \
205         CC="%{__cc}"
206
207 %install
208 rm -rf $RPM_BUILD_ROOT
209 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
210
211 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
212 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
213
214 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
215 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
216 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
217
218 # install links to busybox binary, when linkfl is defined
219 %if %{with linkfl}
220 %{__make} install \
221         PREFIX=$RPM_BUILD_ROOT
222 %else
223 install busybox $RPM_BUILD_ROOT%{_bindir}
224 %endif
225
226 %clean
227 rm -rf $RPM_BUILD_ROOT
228
229 %files
230 %defattr(644,root,root,755)
231 %doc AUTHORS Changelog README .config
232
233 %if %{with linkfl}
234 %attr(755,root,root) /bin/*
235 %attr(755,root,root) /sbin/*
236 %attr(755,root,root) %{_bindir}/*
237 %attr(755,root,root) %{_sbindir}/*
238 %else
239 %attr(755,root,root) %{_bindir}/busybox
240 %endif
241
242 %{_libdir}/busybox
243 %{_mandir}/man1/*
244
245 %if %{with static}
246 %files static
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{_bindir}/busybox.static
249 %endif
250
251 %if %{with initrd}
252 %files initrd
253 %defattr(644,root,root,755)
254 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
255 %endif
This page took 0.316476 seconds and 4 git commands to generate.