]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- 1.5.1 - bugfix-only release, with fixes to hdparm, hush, ifupdown, ps and sed.
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 # Options below are useful, when you want fileutils and grep providing.
14 # For example, ash package requires fileutils and grep.
15 %bcond_with     fileutl_prov    # adds fileutils providing
16 %bcond_with     grep_prov       # adds grep providing
17 # Option below is useful, when busybox is built with shell support.
18 %bcond_with     sh_prov         # adds /bin/sh providing
19 # WARNING! Shell, fileutils and grep providing may depend on config file!
20 # Fileutils, grep and shell provided with busybox have not such
21 # functionality as their GNU countenders.
22 #
23 %bcond_without  static          # don't build static version
24 %bcond_without  initrd          # don't build initrd version
25 #%%bcond_with   dietlibc        # build dietlibc-based initrd version
26 %bcond_with     glibc           # build glibc-based initrd version
27 #
28 %ifnarch %{ix86} %{x8664} ppc sparc64
29 %define with_glibc 1
30 %endif
31 %ifarch ppc
32 %undefine       with_dietlibc
33 %endif
34 Summary:        Set of common unix utils for embeded systems
35 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
36 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
37 Name:           busybox
38 Version:        1.5.1
39 Release:        1
40 License:        GPL
41 Group:          Applications
42 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
43 # Source0-md5:  30df6f796b350fd126c07cff7c33b538
44 Source1:        %{name}.config
45 Source2:        %{name}-initrd.config
46 %{?with_altconfig:Source3:      %{cfgfile}}
47 Patch1:         %{name}-logconsole.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-ash_exec.patch
51 Patch5:         %{name}-kernel_headers.patch
52 Patch6:         %{name}-insmod-morearchs.patch
53 Patch7:         %{name}-dhcp.patch
54 Patch8:         %{name}-fix_64_archs.patch
55 URL:            http://www.busybox.net/
56 BuildRequires:  gcc >= 3.2
57 BuildRequires:  perl-tools-pod
58 BuildRequires:  rpmbuild(macros) >= 1.333
59 %{?with_static:BuildRequires:   glibc-static}
60 %if %{with initrd}
61         %if %{with dietlibc}
62 BuildRequires:  dietlibc-static
63         %else
64                 %if %{with glibc}
65 BuildRequires:  glibc-static
66                 %else
67 %if "%{_target_base_arch}" != "%{_arch}"
68 BuildRequires:  cross%{_target_base_arch}-uClibc-static
69 %else
70         %ifarch ppc %{x8664}
71 BuildRequires:  uClibc-static >= 2:0.9.29
72         %else
73 BuildRequires:  uClibc-static >= 2:0.9.21
74         %endif
75 %endif
76                 %endif
77         %endif
78 %endif
79 %{?with_fileutl_prov:Provides:  fileutils}
80 %{?with_grep_prov:Provides:     grep}
81 %{?with_sh_prov:Provides:       /bin/sh}
82 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
83
84 %define         _bindir         /bin
85 %define         _initrd_bindir  /bin
86
87 %if "%{_target_base_arch}" != "%{_arch}"
88         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
89 %else
90         %define CrossOpts %{nil}
91 %endif
92
93 %description
94 BusyBox combines tiny versions of many common UNIX utilities into a
95 single small executable. It provides minimalist replacements for most
96 of the utilities you usually find in fileutils, shellutils, findutils,
97 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
98 POSIX environment for any small or embedded system. The utilities in
99 BusyBox generally have fewer options than their full-featured GNU
100 cousins; however, the options that are included provide the expected
101 functionality and behave very much like their GNU counterparts.
102
103 BusyBox has been written with size-optimization and limited resources
104 in mind. It is also extremely modular so you can easily include or
105 exclude commands (or features) at compile time. This makes it easy to
106 customize your embedded systems. To create a working system, just add
107 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
108 ae).
109
110 %description -l pl.UTF-8
111 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
112 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
113 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
114 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
115 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
116 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
117 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
118 (np. elvis-tiny albo ae).
119
120 %description -l pt_BR.UTF-8
121 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
122 executável, fornecendo substitutos minimalistas para muitos dos
123 executáveis encontrados em pacotes como fileutils, shellutils,
124 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
125 em geral têm menos opções que os utilitários GNU, mas as opções
126 implementadas comportam-se de maneira similar aos equivalentes GNU.
127
128 %package static
129 Summary:        Static busybox
130 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
131 Group:          Applications
132
133 %description static
134 Static busybox.
135
136 %description static -l pl.UTF-8
137 Statycznie skonsolidowany busybox.
138
139 %package initrd
140 Summary:        Static busybox for initrd
141 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
142 Group:          Applications
143 Conflicts:      geninitrd < 3075
144
145 %description initrd
146 Static busybox for initrd.
147
148 %description initrd -l pl.UTF-8
149 Statycznie skonsolidowany busybox dla initrd.
150
151 %prep
152 %setup -q
153 %patch1 -p1
154 %patch2 -p1
155 %patch3 -p1
156 %patch4 -p1
157 %patch5 -p1
158 %patch6 -p1
159 %patch7 -p1
160 %patch8 -p1
161
162 %build
163 install -d built
164 %if %{with initrd}
165 install %{SOURCE2} .config
166 %{__make} oldconfig
167 %{__make} \
168         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
169         LDFLAGS="%{ld_rpmldflags} -static" \
170 %if %{with dietlibc}
171         LIBRARIES="-lrpc" \
172         CC="diet gcc"
173 %else
174 %if %{with glibc}
175         %{CrossOpts} \
176         CC="%{__cc}"
177 %else
178     %if "%{_target_base_arch}" != "%{_arch}"
179         CROSS="%{_target_cpu}-uclibc-" \
180     %endif
181         CC="%{_target_cpu}-uclibc-gcc"
182 %endif
183 %endif
184
185 mv -f busybox built/busybox.initrd
186 %{__make} clean
187 %endif
188
189
190 %if %{with altconfig}
191 install %{SOURCE3} .config
192 %else
193 install %{SOURCE1} .config
194 %endif
195
196 %if %{with static}
197 %{__make} oldconfig
198 %{__make} \
199         %{CrossOpts} \
200         CFLAGS_EXTRA="%{rpmcflags}" \
201         LDFLAGS="%{ld_rpmldflags} -static" \
202         CC="%{__cc}"
203 mv -f busybox built/busybox.static
204 %{__make} clean
205 %endif
206
207 %{__make} oldconfig
208 %{__make} \
209         %{CrossOpts} \
210         CFLAGS_EXTRA="%{rpmcflags}" \
211         LDFLAGS="%{ld_rpmldflags}" \
212         CC="%{__cc}"
213 %{__make} busybox.links docs/BusyBox.1
214
215 %install
216 rm -rf $RPM_BUILD_ROOT
217 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
218
219 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
220 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
221
222 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
223 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
224 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
225
226 # install links to busybox binary, when linkfl is defined
227 %if %{with linkfl}
228 %{__make} install \
229         PREFIX=$RPM_BUILD_ROOT
230 %else
231 install busybox $RPM_BUILD_ROOT%{_bindir}
232 %endif
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237 %files
238 %defattr(644,root,root,755)
239 %doc AUTHORS README .config
240
241 %if %{with linkfl}
242 %attr(755,root,root) /bin/*
243 %attr(755,root,root) /sbin/*
244 %attr(755,root,root) %{_bindir}/*
245 %attr(755,root,root) %{_sbindir}/*
246 %else
247 %attr(755,root,root) %{_bindir}/busybox
248 %endif
249
250 %{_libdir}/busybox
251 %{_mandir}/man1/*
252
253 %if %{with static}
254 %files static
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_bindir}/busybox.static
257 %endif
258
259 %if %{with initrd}
260 %files initrd
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
263 %endif
This page took 0.095388 seconds and 4 git commands to generate.