]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- added --with glibc to compile initrd version with regular glibc-static
[packages/busybox.git] / busybox.spec
1
2 # alternative busybox config file (replaces default one) you should
3 # define cfgfile macro, i.e.
4 #
5 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
6 %bcond_with altconfig
7
8 %bcond_with linkfl # creates links to busybox binary and puts them into file list
9
10 # Options below are useful, when you want fileutils and grep providing.
11 # For example, ash package requires fileutils and grep.
12 %bcond_with fileutl_prov # adds fileutils providing
13 %bcond_with grep_prov    # adds grep providing
14
15 # Option below is useful, when busybox is built with shell support.
16 %bcond_with sh_prov      # adds /bin/sh providing
17
18 # WARNING! Shell, filetuils and grep providing may depend on config file!
19 # Fileutils, grep and shell provided with busybox have not such
20 # functionality as their GNU countenders.
21
22 %bcond_without static  # don't build static version
23 %bcond_without initrd  # don't build initrd version
24
25 %bcond_with dietlibc
26 %bcond_with glibc
27
28 %ifarch %{x86}
29 %else
30 %define with_glibc 1
31 %endif
32
33 %define pre     pre2
34 Summary:        Set of common unix utils for embeded systems
35 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
36 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
37 Name:           busybox
38 Version:        1.00
39 Release:        0.%{pre}.8
40 License:        GPL
41 Group:          Applications
42 Source0:        http://www.busybox.net/downloads/%{name}-%{version}-pre2.tar.bz2
43 # Source0-md5:  06e433389a8b34ce1031a144ba5677d1
44 Source1:        %{name}.config
45 Source2:        %{name}-initrd.config
46 %{?with_altconfig:Source3:      %{cfgfile}}
47 Patch0:         %{name}-logconsole.patch
48 Patch1:         %{name}-tee.patch
49 Patch2:         %{name}-printf-gettext.patch
50 Patch3:         %{name}-loadfont.patch
51 Patch4:         %{name}-pivot_root.patch
52 Patch5:         %{name}-malloc.patch
53 Patch6:         %{name}-raid_start.patch
54 Patch7:         %{name}-insmod_ng.patch
55 Patch8:         %{name}-force-dietlibc.patch
56 Patch9:         %{name}-insmod-gpl.patch
57 Patch10:        %{name}-ash_exec.patch
58 URL:            http://www.busybox.net/
59 %{?with_fileutl_prov:Provides:  fileutils}
60 %{?with_grep_prov:Provides:     grep}
61 %{?with_sh_prov:Provides:       /bin/sh}
62 %{?with_static:BuildRequires:   glibc-static}
63 %if %{with initrd}
64   %if %{with dietlibc}
65 BuildRequires:  dietlibc-static
66   %else
67     %if %{with glibc}
68 BuildRequires:  glibc-static
69     %else
70 BuildRequires:  uClibc-static
71     %endif
72   %endif
73 %endif
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _initrd_bindir  /bin
77
78 %description
79 BusyBox combines tiny versions of many common UNIX utilities into a
80 single small executable. It provides minimalist replacements for most
81 of the utilities you usually find in fileutils, shellutils, findutils,
82 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
83 POSIX environment for any small or embedded system. The utilities in
84 BusyBox generally have fewer options than their full-featured GNU
85 cousins; however, the options that are included provide the expected
86 functionality and behave very much like their GNU counterparts.
87
88 BusyBox has been written with size-optimization and limited resources
89 in mind. It is also extremely modular so you can easily include or
90 exclude commands (or features) at compile time. This makes it easy to
91 customize your embedded systems. To create a working system, just add
92 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
93 ae).
94
95 %description -l pl
96 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
97 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
98 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
99 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
100 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
101 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
102 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
103 (np. elvis-tiny albo ae).
104
105 %description -l pt_BR
106 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
107 executável, fornecendo substitutos minimalistas para muitos dos
108 executáveis encontrados em pacotes como fileutils, shellutils,
109 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
110 em geral têm menos opções que os utilitários GNU, mas as opções
111 implementadas comportam-se de maneira similar aos equivalentes GNU.
112
113 %package static
114 Summary:        Static busybox
115 Summary(pl):    Statycznie linkowany busybox
116 Group:          Applications
117
118 %description static
119 Static busybox.
120
121 %description static -l pl
122 Statycznie linkowany busybox.
123
124 %package initrd
125 Summary:        Static busybox for initrd
126 Summary(pl):    Statycznie linkowany busybox dla initrd
127 Group:          Applications
128
129 %description initrd
130 Static busybox for initrd.
131
132 %description initrd -l pl
133 Statycznie linkowany busybox dla initrd.
134
135 %prep
136 %setup -q -n %{name}-%{version}-%{pre}
137 %patch0 -p1
138 %patch1 -p1
139 #X %patch2 -p1 // UPDATE ME
140 %patch3 -p1
141 %patch4 -p1
142 #%patch5 -p1 // not needed
143 %patch6 -p1
144 %patch7 -p1
145 %patch8 -p1
146 %patch9 -p1
147 %patch10 -p1
148
149 %build
150 install %{SOURCE1} .config
151
152 %if %{with initrd}
153 install %{SOURCE2} .config
154 %{__make} oldconfig
155 %{__make} \
156         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
157         LDFLAGS="%{rpmldflags} -static" \
158 %if %{with dietlibc}
159         LIBRARIES="-lrpc" \
160         CC="diet gcc"
161 %else
162 %if %{with glibc}
163         CC="%{__cc}"
164 %else
165         CC="%{_target_cpu}-uclibc-gcc"
166 %endif
167 %endif
168
169 mv -f busybox busybox.initrd
170 %{__make} clean
171 install %{SOURCE1} .config
172 %endif
173
174 %if %{with altconfig}
175 install %{SOURCE3} .config
176 %endif
177
178 %if %{with static}
179 %{__make} oldconfig
180 %{__make}  \
181         CFLAGS_EXTRA="%{rpmcflags}" \
182         LDFLAGS="%{rpmldflags} -static" \
183         CC="%{__cc}"
184 mv -f busybox busybox.static
185 %{__make} clean
186 %endif
187
188 %{__make} oldconfig
189 %{__make} \
190         CFLAGS_EXTRA="%{rpmcflags}" \
191         LDFLAGS="%{rpmldflags}" \
192         CC="%{__cc}"
193
194 %install
195 rm -rf $RPM_BUILD_ROOT
196 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
197
198 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
199 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
200
201 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
202 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
203 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
204
205 # install links to busybox binary, when linkfl is defined
206 %if %{with linkfl}
207 make install \
208         PREFIX=$RPM_BUILD_ROOT
209 %else
210 install busybox $RPM_BUILD_ROOT%{_bindir}
211 %endif
212
213 %clean
214 rm -rf $RPM_BUILD_ROOT
215
216 %files
217 %defattr(644,root,root,755)
218 %doc AUTHORS TODO Changelog README .config
219
220 %if %{with linkfl}
221 %attr(755,root,root) /bin/*
222 %attr(755,root,root) /sbin/*
223 %attr(755,root,root) %{_bindir}/*
224 %attr(755,root,root) %{_sbindir}/*
225 %else
226 %attr(755,root,root) %{_bindir}/busybox
227 %endif
228
229 %{_libdir}/busybox
230 %{_mandir}/man1/*
231
232 %if %{with static}
233 %files static
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_bindir}/busybox.static
236 %endif
237
238 %if %{with initrd}
239 %files initrd
240 %defattr(644,root,root,755)
241 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
242 %endif
This page took 0.087768 seconds and 4 git commands to generate.