]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- rel 2; drop Werror
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 # Options below are useful, when you want fileutils and grep providing.
14 # For example, ash package requires fileutils and grep.
15 %bcond_with     fileutl_prov    # adds fileutils providing
16 %bcond_with     grep_prov       # adds grep providing
17 # Option below is useful, when busybox is built with shell support.
18 %bcond_with     sh_prov         # adds /bin/sh providing
19 # WARNING! Shell, fileutils and grep providing may depend on config file!
20 # Fileutils, grep and shell provided with busybox have not such
21 # functionality as their GNU countenders.
22 #
23 %bcond_without  static          # don't build static version
24 %bcond_without  initrd          # don't build initrd version
25 #%%bcond_with   dietlibc        # build dietlibc-based initrd version
26 %bcond_with     glibc           # build glibc-based initrd version
27 #
28 %ifnarch %{ix86} %{x8664} ppc sparc64
29 %define with_glibc 1
30 %endif
31 %ifarch ppc
32 %undefine       with_dietlibc
33 %endif
34 Summary:        Set of common unix utils for embeded systems
35 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
36 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
37 Name:           busybox
38 Version:        1.3.1
39 Release:        2
40 License:        GPL
41 Group:          Applications
42 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
43 # Source0-md5:  571531cfa83726947ccb566de017ad4f
44 Source1:        %{name}.config
45 Source2:        %{name}-initrd.config
46 %{?with_altconfig:Source3:      %{cfgfile}}
47 Patch1:         %{name}-logconsole.patch
48 Patch2:         %{name}-printf-gettext.patch
49 Patch3:         %{name}-loadfont.patch
50 Patch4:         %{name}-ash_exec.patch
51 Patch5:         %{name}-kernel_headers.patch
52 Patch6:         %{name}-insmod-morearchs.patch
53 Patch7:         %{name}-dhcp.patch
54 Patch8:         %{name}-fix_64_archs.patch
55 Patch9:         %{name}-LFS.patch
56 Patch10:        %{name}-noshadow.patch
57 Patch11:        %{name}-noerror.patch
58 URL:            http://www.busybox.net/
59 BuildRequires:  gcc >= 3.2
60 BuildRequires:  perl-tools-pod
61 BuildRequires:  rpmbuild(macros) >= 1.333
62 %{?with_static:BuildRequires:   glibc-static}
63 %if %{with initrd}
64         %if %{with dietlibc}
65 BuildRequires:  dietlibc-static
66         %else
67                 %if %{with glibc}
68 BuildRequires:  glibc-static
69                 %else
70 %if "%{_target_base_arch}" != "%{_arch}"
71 BuildRequires:  cross%{_target_base_arch}-uClibc-static
72 %else
73         %ifarch ppc %{x8664}
74 BuildRequires:  uClibc-static >= 2:0.9.29
75         %else
76 BuildRequires:  uClibc-static >= 2:0.9.21
77         %endif
78 %endif
79                 %endif
80         %endif
81 %endif
82 %{?with_fileutl_prov:Provides:  fileutils}
83 %{?with_grep_prov:Provides:     grep}
84 %{?with_sh_prov:Provides:       /bin/sh}
85 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
86
87 %define         _bindir         /bin
88 %define         _initrd_bindir  /bin
89
90 %if "%{_target_base_arch}" != "%{_arch}"
91         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
92 %else
93         %define CrossOpts %{nil}
94 %endif
95
96 %description
97 BusyBox combines tiny versions of many common UNIX utilities into a
98 single small executable. It provides minimalist replacements for most
99 of the utilities you usually find in fileutils, shellutils, findutils,
100 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
101 POSIX environment for any small or embedded system. The utilities in
102 BusyBox generally have fewer options than their full-featured GNU
103 cousins; however, the options that are included provide the expected
104 functionality and behave very much like their GNU counterparts.
105
106 BusyBox has been written with size-optimization and limited resources
107 in mind. It is also extremely modular so you can easily include or
108 exclude commands (or features) at compile time. This makes it easy to
109 customize your embedded systems. To create a working system, just add
110 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
111 ae).
112
113 %description -l pl
114 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
115 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
116 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
117 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
118 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
119 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
120 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
121 (np. elvis-tiny albo ae).
122
123 %description -l pt_BR
124 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
125 executável, fornecendo substitutos minimalistas para muitos dos
126 executáveis encontrados em pacotes como fileutils, shellutils,
127 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
128 em geral têm menos opções que os utilitários GNU, mas as opções
129 implementadas comportam-se de maneira similar aos equivalentes GNU.
130
131 %package static
132 Summary:        Static busybox
133 Summary(pl):    Statycznie skonsolidowany busybox
134 Group:          Applications
135
136 %description static
137 Static busybox.
138
139 %description static -l pl
140 Statycznie skonsolidowany busybox.
141
142 %package initrd
143 Summary:        Static busybox for initrd
144 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
145 Group:          Applications
146 Conflicts:      geninitrd < 3075
147
148 %description initrd
149 Static busybox for initrd.
150
151 %description initrd -l pl
152 Statycznie skonsolidowany busybox dla initrd.
153
154 %prep
155 %setup -q
156 %patch1 -p1
157 %patch2 -p1
158 %patch3 -p1
159 %patch4 -p1
160 %patch5 -p1
161 %patch6 -p1
162 %patch7 -p1
163 %patch8 -p1
164 %patch9 -p1
165 %patch10 -p1
166 %patch11 -p1
167
168 %build
169 install -d built
170 %if %{with initrd}
171 install %{SOURCE2} .config
172 %{__make} oldconfig
173 %{__make} \
174         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
175         LDFLAGS="%{ld_rpmldflags} -static" \
176 %if %{with dietlibc}
177         LIBRARIES="-lrpc" \
178         CC="diet gcc"
179 %else
180 %if %{with glibc}
181         %{CrossOpts} \
182         CC="%{__cc}"
183 %else
184     %if "%{_target_base_arch}" != "%{_arch}"
185         CROSS="%{_target_cpu}-uclibc-" \
186     %endif
187         CC="%{_target_cpu}-uclibc-gcc"
188 %endif
189 %endif
190
191 mv -f busybox built/busybox.initrd
192 %{__make} clean
193 %endif
194
195
196 %if %{with altconfig}
197 install %{SOURCE3} .config
198 %else
199 install %{SOURCE1} .config
200 %endif
201
202 %if %{with static}
203 %{__make} oldconfig
204 %{__make} \
205         %{CrossOpts} \
206         CFLAGS_EXTRA="%{rpmcflags}" \
207         LDFLAGS="%{ld_rpmldflags} -static" \
208         CC="%{__cc}"
209 mv -f busybox built/busybox.static
210 %{__make} clean
211 %endif
212
213 %{__make} oldconfig
214 %{__make} \
215         %{CrossOpts} \
216         CFLAGS_EXTRA="%{rpmcflags}" \
217         LDFLAGS="%{ld_rpmldflags}" \
218         CC="%{__cc}"
219 %{__make} busybox.links docs/BusyBox.1
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
224
225 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
226 %{?with_initrd:install built/busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
227
228 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
229 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
230 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
231
232 # install links to busybox binary, when linkfl is defined
233 %if %{with linkfl}
234 %{__make} install \
235         PREFIX=$RPM_BUILD_ROOT
236 %else
237 install busybox $RPM_BUILD_ROOT%{_bindir}
238 %endif
239
240 %clean
241 rm -rf $RPM_BUILD_ROOT
242
243 %files
244 %defattr(644,root,root,755)
245 %doc AUTHORS README .config
246
247 %if %{with linkfl}
248 %attr(755,root,root) /bin/*
249 %attr(755,root,root) /sbin/*
250 %attr(755,root,root) %{_bindir}/*
251 %attr(755,root,root) %{_sbindir}/*
252 %else
253 %attr(755,root,root) %{_bindir}/busybox
254 %endif
255
256 %{_libdir}/busybox
257 %{_mandir}/man1/*
258
259 %if %{with static}
260 %files static
261 %defattr(644,root,root,755)
262 %attr(755,root,root) %{_bindir}/busybox.static
263 %endif
264
265 %if %{with initrd}
266 %files initrd
267 %defattr(644,root,root,755)
268 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
269 %endif
This page took 0.098722 seconds and 4 git commands to generate.