]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- up to 1.24.2
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_without  verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define         with_glibc      1
34 %endif
35 %ifarch x32
36 # until uClibc builds on x32
37 %undefine       with_static
38 %endif
39 Summary:        Set of common Unix utilities for embeded systems
40 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
41 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
42 Name:           busybox
43 # stable line only
44 Version:        1.24.2
45 Release:        1
46 License:        GPL v2
47 Group:          Applications
48 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
49 # Source0-md5:  2eaae519cac1143bcf583636a745381f
50 Source1:        %{name}.config
51 Source2:        %{name}-initrd.config
52 %{?with_altconfig:Source3:      %{cfgfile}}
53 Patch100:       https://busybox.net/downloads/fixes-1.24.2/busybox-1.24.2-CVE-2016-2147.patch
54 # Patch100-md5: c45a85f5ced712743efbb683900f8c1d
55 Patch101:       https://busybox.net/downloads/fixes-1.24.2/busybox-1.24.2-CVE-2016-2148.patch
56 # Patch101-md5: 850a57ca2871e370b4916161a0320a3f
57 Patch102:       https://busybox.net/downloads/fixes-1.24.2/busybox-1.24.2-ash-recursive-heredocs.patch
58 # Patch102-md5: b59eb7536609db1ab5215de860d9e558
59 Patch0:         x32.patch
60 Patch1:         %{name}-logconsole.patch
61 Patch2:         %{name}-printf-gettext.patch
62 Patch3:         %{name}-loadfont.patch
63 Patch4:         %{name}-kernel_headers.patch
64 Patch5:         %{name}-insmod-morearchs.patch
65 Patch6:         %{name}-dhcp.patch
66 Patch7:         %{name}-fix_64_archs.patch
67 Patch9:         %{name}-ash-export-PATH.patch
68 URL:            http://www.busybox.net/
69 BuildRequires:  gcc >= 3.2
70 BuildRequires:  perl-tools-pod
71 BuildRequires:  rpmbuild(macros) >= 1.652
72 %if %{with initrd} || %{with static}
73         %if %{with dietlibc}
74 BuildRequires:  dietlibc-static
75         %else
76                 %if %{with glibc}
77 BuildRequires:  glibc-static
78                 %else
79 %if "%{_target_base_arch}" != "%{_host_base_arch}"
80 BuildRequires:  cross%{_target_base_arch}-uClibc-static
81 %else
82         %ifarch ppc %{x8664}
83 BuildRequires:  uClibc-static >= 3:0.9.30.1
84         %else
85 BuildRequires:  uClibc-static >= 3:0.9.30.1
86         %endif
87 %endif
88                 %endif
89         %endif
90 %endif
91 %{?with_sh_prov:Provides:       /bin/sh}
92 %{?with_fileutl_prov:Provides:  fileutils}
93 %{?with_grep_prov:Provides:     grep}
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %define         _bindir         /bin
97
98 %if "%{_target_base_arch}" != "%{_host_base_arch}"
99         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
100 %else
101         %define CrossOpts %{nil}
102 %endif
103
104 %define         filterout_ld    -Wl,-z,(combreloc|relro)
105
106 %description
107 BusyBox combines tiny versions of many common UNIX utilities into a
108 single small executable. It provides minimalist replacements for most
109 of the utilities you usually find in fileutils, shellutils, findutils,
110 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
111 POSIX environment for any small or embedded system. The utilities in
112 BusyBox generally have fewer options than their full-featured GNU
113 cousins; however, the options that are included provide the expected
114 functionality and behave very much like their GNU counterparts.
115
116 BusyBox has been written with size-optimization and limited resources
117 in mind. It is also extremely modular so you can easily include or
118 exclude commands (or features) at compile time. This makes it easy to
119 customize your embedded systems. To create a working system, just add
120 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
121 ae).
122
123 %description -l pl.UTF-8
124 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
125 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
126 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
127 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
128 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
129 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
130 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
131 (np. elvis-tiny albo ae).
132
133 %description -l pt_BR.UTF-8
134 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
135 executável, fornecendo substitutos minimalistas para muitos dos
136 executáveis encontrados em pacotes como fileutils, shellutils,
137 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
138 em geral têm menos opções que os utilitários GNU, mas as opções
139 implementadas comportam-se de maneira similar aos equivalentes GNU.
140
141 %package static
142 Summary:        Static busybox
143 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
144 Group:          Applications
145
146 %description static
147 Static busybox.
148
149 %description static -l pl.UTF-8
150 Statycznie skonsolidowany busybox.
151
152 %package initrd
153 Summary:        Static busybox for initrd
154 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
155 Group:          Base
156 Conflicts:      geninitrd < 10000.20
157
158 %description initrd
159 Static busybox for initrd.
160
161 %description initrd -l pl.UTF-8
162 Statycznie skonsolidowany busybox dla initrd.
163
164 %prep
165 %setup -q
166 %patch100 -p1
167 %patch101 -p1
168 %patch102 -p1
169
170 %patch0 -p1
171 %patch1 -p1
172 %patch2 -p1
173 #%patch3 -p1
174 %patch4 -p1
175 %patch5 -p1
176 %patch6 -p1
177 %patch7 -p1
178 %patch9 -p1
179
180 %build
181 install -d built
182 %if %{with initrd}
183 install %{SOURCE2} .config
184 %{__make} oldconfig
185 %{__make} \
186         %{?with_verbose:V=1} \
187         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
188         LDFLAGS="%{rpmldflags} -static" \
189 %if %{with dietlibc}
190         LIBRARIES="-lrpc" \
191         CC="diet %{__cc}"
192 %else
193 %if %{with glibc}
194         %{CrossOpts} \
195         CC="%{__cc}"
196 %else
197         %if "%{_target_base_arch}" != "%{_host_base_arch}"
198         CROSS="%{_target_cpu}-uclibc-" \
199         %endif
200         CC="%{_target_cpu}-uclibc-gcc"
201 %endif
202 %endif
203
204 mv -f busybox built/busybox.initrd
205 %{__make} clean
206 %endif
207
208 %if %{with altconfig}
209 install %{SOURCE3} .config
210 %else
211 install %{SOURCE1} .config
212 %endif
213
214 %if %{with static}
215 %{__make} oldconfig
216 %{__make} \
217         %{?with_verbose:V=1} \
218         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
219         LDFLAGS="%{rpmldflags} -static" \
220 %if %{with dietlibc}
221         LIBRARIES="-lrpc" \
222         CC="diet %{__cc}"
223 %else
224 %if %{with glibc}
225         %{CrossOpts} \
226         CC="%{__cc}"
227 %else
228         %if "%{_target_base_arch}" != "%{_host_base_arch}"
229         CROSS="%{_target_cpu}-uclibc-" \
230         %endif
231         CC="%{_target_cpu}-uclibc-gcc"
232 %endif
233 %endif
234
235 mv -f busybox built/busybox.static
236 %{__make} clean
237 %endif
238
239 %if %{with dynamic}
240 %{__make} oldconfig
241 %{__make} \
242         %{?with_verbose:V=1} \
243         %{CrossOpts} \
244         CFLAGS_EXTRA="%{rpmcflags}" \
245         LDFLAGS="%{rpmldflags}" \
246         CC="%{__cc}"
247 %{__make} busybox.links docs/busybox.1
248 %endif
249
250 %install
251 rm -rf $RPM_BUILD_ROOT
252
253 %if %{with static}
254 install -d $RPM_BUILD_ROOT%{_bindir}
255 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
256 %endif
257
258 %if %{with initrd}
259 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
260 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
261 %endif
262
263 %if %{with dynamic}
264 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
265 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
266 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
267
268 # install links to busybox binary, when linkfl is defined
269 %if %{with linkfl}
270 %{__make} install \
271         PREFIX=$RPM_BUILD_ROOT
272 %else
273 install busybox $RPM_BUILD_ROOT%{_bindir}
274 %endif
275 %endif
276
277 %clean
278 rm -rf $RPM_BUILD_ROOT
279
280 %if %{with dynamic}
281 %files
282 %defattr(644,root,root,755)
283 %doc AUTHORS README .config
284
285 %if %{with linkfl}
286 %attr(755,root,root) /bin/*
287 %attr(755,root,root) /sbin/*
288 %attr(755,root,root) %{_bindir}/*
289 %attr(755,root,root) %{_sbindir}/*
290 %else
291 %attr(755,root,root) %{_bindir}/busybox
292 %endif
293
294 %{_libdir}/busybox
295 %{_mandir}/man1/busybox.1*
296 %endif
297
298 %if %{with static}
299 %files static
300 %defattr(644,root,root,755)
301 %attr(755,root,root) %{_bindir}/busybox.static
302 %endif
303
304 %if %{with initrd}
305 %files initrd
306 %defattr(644,root,root,755)
307 %attr(755,root,root) %{_libdir}/initrd/busybox
308 %endif
This page took 0.089683 seconds and 3 git commands to generate.