]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- up to 1.21.1
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_with     verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define with_glibc 1
34 %endif
35 Summary:        Set of common Unix utilities for embeded systems
36 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
37 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
38 Name:           busybox
39 # stable line only
40 Version:        1.21.1
41 Release:        1
42 License:        GPL v2
43 Group:          Applications
44 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
45 # Source0-md5:  795394f83903b5eec6567d51eebb417e
46 Source1:        %{name}.config
47 Source2:        %{name}-initrd.config
48 %{?with_altconfig:Source3:      %{cfgfile}}
49 Patch1:         %{name}-logconsole.patch
50 Patch2:         %{name}-printf-gettext.patch
51 Patch3:         %{name}-loadfont.patch
52 Patch4:         %{name}-kernel_headers.patch
53 Patch5:         %{name}-insmod-morearchs.patch
54 Patch6:         %{name}-dhcp.patch
55 Patch7:         %{name}-fix_64_archs.patch
56 Patch9:         %{name}-ash-export-PATH.patch
57 URL:            http://www.busybox.net/
58 BuildRequires:  gcc >= 3.2
59 BuildRequires:  perl-tools-pod
60 BuildRequires:  rpmbuild(macros) >= 1.652
61 %if %{with initrd} || %{with static}
62         %if %{with dietlibc}
63 BuildRequires:  dietlibc-static
64         %else
65                 %if %{with glibc}
66 BuildRequires:  glibc-static
67                 %else
68 %if "%{_target_base_arch}" != "%{_host_base_arch}"
69 BuildRequires:  cross%{_target_base_arch}-uClibc-static
70 %else
71         %ifarch ppc %{x8664}
72 BuildRequires:  uClibc-static >= 3:0.9.30.1
73         %else
74 BuildRequires:  uClibc-static >= 3:0.9.30.1
75         %endif
76 %endif
77                 %endif
78         %endif
79 %endif
80 %{?with_sh_prov:Provides:       /bin/sh}
81 %{?with_fileutl_prov:Provides:  fileutils}
82 %{?with_grep_prov:Provides:     grep}
83 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
84
85 %define         _bindir         /bin
86
87 %if "%{_target_base_arch}" != "%{_host_base_arch}"
88         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
89 %else
90         %define CrossOpts %{nil}
91 %endif
92
93 %define         filterout_ld    -Wl,-z,(combreloc|relro)
94
95 %description
96 BusyBox combines tiny versions of many common UNIX utilities into a
97 single small executable. It provides minimalist replacements for most
98 of the utilities you usually find in fileutils, shellutils, findutils,
99 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
100 POSIX environment for any small or embedded system. The utilities in
101 BusyBox generally have fewer options than their full-featured GNU
102 cousins; however, the options that are included provide the expected
103 functionality and behave very much like their GNU counterparts.
104
105 BusyBox has been written with size-optimization and limited resources
106 in mind. It is also extremely modular so you can easily include or
107 exclude commands (or features) at compile time. This makes it easy to
108 customize your embedded systems. To create a working system, just add
109 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
110 ae).
111
112 %description -l pl.UTF-8
113 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
114 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
115 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
116 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
117 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
118 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
119 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
120 (np. elvis-tiny albo ae).
121
122 %description -l pt_BR.UTF-8
123 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
124 executável, fornecendo substitutos minimalistas para muitos dos
125 executáveis encontrados em pacotes como fileutils, shellutils,
126 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
127 em geral têm menos opções que os utilitários GNU, mas as opções
128 implementadas comportam-se de maneira similar aos equivalentes GNU.
129
130 %package static
131 Summary:        Static busybox
132 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
133 Group:          Applications
134
135 %description static
136 Static busybox.
137
138 %description static -l pl.UTF-8
139 Statycznie skonsolidowany busybox.
140
141 %package initrd
142 Summary:        Static busybox for initrd
143 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
144 Group:          Base
145 Conflicts:      geninitrd < 10000.20
146
147 %description initrd
148 Static busybox for initrd.
149
150 %description initrd -l pl.UTF-8
151 Statycznie skonsolidowany busybox dla initrd.
152
153 %prep
154 %setup -q
155 %patch1 -p1
156 %patch2 -p1
157 #%patch3 -p1
158 %patch4 -p1
159 %patch5 -p1
160 %patch6 -p1
161 %patch7 -p1
162 %patch9 -p1
163
164 %build
165 install -d built
166 %if %{with initrd}
167 install %{SOURCE2} .config
168 %{__make} oldconfig
169 %{__make} \
170         %{?with_verbose:V=1} \
171         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
172         LDFLAGS="%{rpmldflags} -static" \
173 %if %{with dietlibc}
174         LIBRARIES="-lrpc" \
175         CC="diet %{__cc}"
176 %else
177 %if %{with glibc}
178         %{CrossOpts} \
179         CC="%{__cc}"
180 %else
181         %if "%{_target_base_arch}" != "%{_host_base_arch}"
182         CROSS="%{_target_cpu}-uclibc-" \
183         %endif
184         CC="%{_target_cpu}-uclibc-gcc"
185 %endif
186 %endif
187
188 mv -f busybox built/busybox.initrd
189 %{__make} clean
190 %endif
191
192 %if %{with altconfig}
193 install %{SOURCE3} .config
194 %else
195 install %{SOURCE1} .config
196 %endif
197
198 %if %{with static}
199 %{__make} oldconfig
200 %{__make} \
201         %{?with_verbose:V=1} \
202         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
203         LDFLAGS="%{rpmldflags} -static" \
204 %if %{with dietlibc}
205         LIBRARIES="-lrpc" \
206         CC="diet %{__cc}"
207 %else
208 %if %{with glibc}
209         %{CrossOpts} \
210         CC="%{__cc}"
211 %else
212         %if "%{_target_base_arch}" != "%{_host_base_arch}"
213         CROSS="%{_target_cpu}-uclibc-" \
214         %endif
215         CC="%{_target_cpu}-uclibc-gcc"
216 %endif
217 %endif
218
219 mv -f busybox built/busybox.static
220 %{__make} clean
221 %endif
222
223 %if %{with dynamic}
224 %{__make} oldconfig
225 %{__make} \
226         %{?with_verbose:V=1} \
227         %{CrossOpts} \
228         CFLAGS_EXTRA="%{rpmcflags}" \
229         LDFLAGS="%{rpmldflags}" \
230         CC="%{__cc}"
231 %{__make} busybox.links docs/busybox.1
232 %endif
233
234 %install
235 rm -rf $RPM_BUILD_ROOT
236
237 %if %{with static}
238 install -d $RPM_BUILD_ROOT%{_bindir}
239 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
240 %endif
241
242 %if %{with initrd}
243 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
244 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
245 %endif
246
247 %if %{with dynamic}
248 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
249 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
250 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
251
252 # install links to busybox binary, when linkfl is defined
253 %if %{with linkfl}
254 %{__make} install \
255         PREFIX=$RPM_BUILD_ROOT
256 %else
257 install busybox $RPM_BUILD_ROOT%{_bindir}
258 %endif
259 %endif
260
261 %clean
262 rm -rf $RPM_BUILD_ROOT
263
264 %if %{with dynamic}
265 %files
266 %defattr(644,root,root,755)
267 %doc AUTHORS README .config
268
269 %if %{with linkfl}
270 %attr(755,root,root) /bin/*
271 %attr(755,root,root) /sbin/*
272 %attr(755,root,root) %{_bindir}/*
273 %attr(755,root,root) %{_sbindir}/*
274 %else
275 %attr(755,root,root) %{_bindir}/busybox
276 %endif
277
278 %{_libdir}/busybox
279 %{_mandir}/man1/busybox.1*
280 %endif
281
282 %if %{with static}
283 %files static
284 %defattr(644,root,root,755)
285 %attr(755,root,root) %{_bindir}/busybox.static
286 %endif
287
288 %if %{with initrd}
289 %files initrd
290 %defattr(644,root,root,755)
291 %attr(755,root,root) %{_libdir}/initrd/busybox
292 %endif
This page took 0.058622 seconds and 3 git commands to generate.