]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
c3967182f8d508af886a96b07963adea19b80107
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  static          # don't build static version
17 %bcond_without  initrd          # don't build initrd version
18 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
19 %bcond_with     glibc           # build glibc-based initrd and static versions
20 %bcond_with     verbose         # verbose build
21 # Options below are useful, when you want fileutils and grep providing.
22 # For example, ash package requires fileutils and grep.
23 %bcond_with     fileutl_prov    # adds fileutils providing
24 %bcond_with     grep_prov       # adds grep providing
25 # Option below is useful, when busybox is built with shell support.
26 %bcond_with     sh_prov         # adds /bin/sh providing
27 # WARNING! Shell, fileutils and grep providing may depend on config file!
28 # Fileutils, grep and shell provided with busybox have not such
29 # functionality as their GNU countenders.
30 #
31 %ifnarch %{ix86} %{x8664} ppc
32 %define with_glibc 1
33 %endif
34 Summary:        Set of common Unix utilities for embeded systems
35 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
36 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
37 Name:           busybox
38 # stable line only
39 Version:        1.18.1
40 Release:        1
41 License:        GPL
42 Group:          Applications
43 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
44 # Source0-md5:  f15fe752d8b7012aa5e59f83b88ccb1c
45 Source1:        %{name}.config
46 Source2:        %{name}-initrd.config
47 %{?with_altconfig:Source3:      %{cfgfile}}
48 Patch100:       busybox-1.18.1-bzip2.patch
49 Patch101:       busybox-1.18.1-cpio.patch
50 Patch102:       busybox-1.18.1-hush.patch
51 Patch103:       busybox-1.18.1-mkswap.patch
52 Patch104:       busybox-1.18.1-warning.patch
53 Patch1:         %{name}-logconsole.patch
54 Patch2:         %{name}-printf-gettext.patch
55 Patch3:         %{name}-loadfont.patch
56 Patch4:         %{name}-kernel_headers.patch
57 Patch5:         %{name}-insmod-morearchs.patch
58 Patch6:         %{name}-dhcp.patch
59 Patch7:         %{name}-fix_64_archs.patch
60 Patch9:         %{name}-ash-export-PATH.patch
61 URL:            http://www.busybox.net/
62 BuildRequires:  gcc >= 3.2
63 BuildRequires:  perl-tools-pod
64 BuildRequires:  rpmbuild(macros) >= 1.333
65 %if %{with initrd} || %{with static}
66         %if %{with dietlibc}
67 BuildRequires:  dietlibc-static
68         %else
69                 %if %{with glibc}
70 BuildRequires:  glibc-static
71                 %else
72 %if "%{_target_base_arch}" != "%{_arch}"
73 BuildRequires:  cross%{_target_base_arch}-uClibc-static
74 %else
75         %ifarch ppc %{x8664}
76 BuildRequires:  uClibc-static >= 3:0.9.30.1
77         %else
78 BuildRequires:  uClibc-static >= 3:0.9.30.1
79         %endif
80 %endif
81                 %endif
82         %endif
83 %endif
84 %{?with_sh_prov:Provides:       /bin/sh}
85 %{?with_fileutl_prov:Provides:  fileutils}
86 %{?with_grep_prov:Provides:     grep}
87 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
88
89 %define         _bindir         /bin
90
91 %if "%{_target_base_arch}" != "%{_arch}"
92         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
93 %else
94         %define CrossOpts %{nil}
95 %endif
96
97 %define         filterout_ld    -Wl,-z,(combreloc|relro)
98
99 %description
100 BusyBox combines tiny versions of many common UNIX utilities into a
101 single small executable. It provides minimalist replacements for most
102 of the utilities you usually find in fileutils, shellutils, findutils,
103 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
104 POSIX environment for any small or embedded system. The utilities in
105 BusyBox generally have fewer options than their full-featured GNU
106 cousins; however, the options that are included provide the expected
107 functionality and behave very much like their GNU counterparts.
108
109 BusyBox has been written with size-optimization and limited resources
110 in mind. It is also extremely modular so you can easily include or
111 exclude commands (or features) at compile time. This makes it easy to
112 customize your embedded systems. To create a working system, just add
113 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
114 ae).
115
116 %description -l pl.UTF-8
117 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
118 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
119 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
120 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
121 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
122 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
123 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
124 (np. elvis-tiny albo ae).
125
126 %description -l pt_BR.UTF-8
127 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
128 executável, fornecendo substitutos minimalistas para muitos dos
129 executáveis encontrados em pacotes como fileutils, shellutils,
130 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
131 em geral têm menos opções que os utilitários GNU, mas as opções
132 implementadas comportam-se de maneira similar aos equivalentes GNU.
133
134 %package static
135 Summary:        Static busybox
136 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
137 Group:          Applications
138
139 %description static
140 Static busybox.
141
142 %description static -l pl.UTF-8
143 Statycznie skonsolidowany busybox.
144
145 %package initrd
146 Summary:        Static busybox for initrd
147 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
148 Group:          Base
149 Conflicts:      geninitrd < 10000.20
150
151 %description initrd
152 Static busybox for initrd.
153
154 %description initrd -l pl.UTF-8
155 Statycznie skonsolidowany busybox dla initrd.
156
157 %prep
158 %setup -q
159 %patch100 -p1
160 %patch101 -p1
161 %patch102 -p1
162 %patch103 -p1
163 %patch104 -p1
164 %patch1 -p1
165 %patch2 -p1
166 #%patch3 -p1
167 %patch4 -p1
168 %patch5 -p1
169 %patch6 -p1
170 %patch7 -p1
171 %patch9 -p1
172
173 %build
174 install -d built
175 %if %{with initrd}
176 install %{SOURCE2} .config
177 %{__make} oldconfig
178 %{__make} \
179         %{?with_verbose:V=1} \
180         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
181         LDFLAGS="%{ld_rpmldflags} -static" \
182 %if %{with dietlibc}
183         LIBRARIES="-lrpc" \
184         CC="diet %{__cc}"
185 %else
186 %if %{with glibc}
187         %{CrossOpts} \
188         CC="%{__cc}"
189 %else
190         %if "%{_target_base_arch}" != "%{_arch}"
191         CROSS="%{_target_cpu}-uclibc-" \
192         %endif
193         CC="%{_target_cpu}-uclibc-gcc"
194 %endif
195 %endif
196
197 mv -f busybox built/busybox.initrd
198 %{__make} clean
199 %endif
200
201
202 %if %{with altconfig}
203 install %{SOURCE3} .config
204 %else
205 install %{SOURCE1} .config
206 %endif
207
208 %if %{with static}
209 %{__make} oldconfig
210 %{__make} \
211         %{?with_verbose:V=1} \
212         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
213         LDFLAGS="%{ld_rpmldflags} -static" \
214 %if %{with dietlibc}
215         LIBRARIES="-lrpc" \
216         CC="diet %{__cc}"
217 %else
218 %if %{with glibc}
219         %{CrossOpts} \
220         CC="%{__cc}"
221 %else
222         %if "%{_target_base_arch}" != "%{_arch}"
223         CROSS="%{_target_cpu}-uclibc-" \
224         %endif
225         CC="%{_target_cpu}-uclibc-gcc"
226 %endif
227 %endif
228
229 mv -f busybox built/busybox.static
230 %{__make} clean
231 %endif
232
233 %{__make} oldconfig
234 %{__make} \
235         %{?with_verbose:V=1} \
236         %{CrossOpts} \
237         CFLAGS_EXTRA="%{rpmcflags}" \
238         LDFLAGS="%{ld_rpmldflags}" \
239         CC="%{__cc}"
240 %{__make} busybox.links docs/busybox.1
241
242 %install
243 rm -rf $RPM_BUILD_ROOT
244 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
245
246 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
247 %if %{with initrd}
248 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
249 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
250 %endif
251
252 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
253 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
254
255 # install links to busybox binary, when linkfl is defined
256 %if %{with linkfl}
257 %{__make} install \
258         PREFIX=$RPM_BUILD_ROOT
259 %else
260 install busybox $RPM_BUILD_ROOT%{_bindir}
261 %endif
262
263 %clean
264 rm -rf $RPM_BUILD_ROOT
265
266 %files
267 %defattr(644,root,root,755)
268 %doc AUTHORS README .config
269
270 %if %{with linkfl}
271 %attr(755,root,root) %{_bindir}/*
272 %attr(755,root,root) /sbin/*
273 %attr(755,root,root) %{_bindir}/*
274 %attr(755,root,root) %{_sbindir}/*
275 %else
276 %attr(755,root,root) %{_bindir}/busybox
277 %endif
278
279 %{_libdir}/busybox
280 %{_mandir}/man1/*
281
282 %if %{with static}
283 %files static
284 %defattr(644,root,root,755)
285 %attr(755,root,root) %{_bindir}/busybox.static
286 %endif
287
288 %if %{with initrd}
289 %files initrd
290 %defattr(644,root,root,755)
291 %attr(755,root,root) %{_libdir}/initrd/busybox
292 %endif
This page took 0.04465 seconds and 2 git commands to generate.