]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
ba7193536390aa7937bf0f44dc0bf0a4b903591d
[packages/busybox.git] / busybox.spec
1 # TODO:
2 #       - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
3 #       - make internal commands work even if busybox is not in /bin/busybox (initrd)
4 #         or when /proc is not mounted (static / normal)
5 #
6 # Conditional build:
7 # alternative busybox config file (replaces default one) you should
8 # define cfgfile macro, i.e.
9 #
10 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
11 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
12 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
13 %bcond_without  static          # don't build static version
14 %bcond_without  initrd          # don't build initrd version
15 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
16 %bcond_with     glibc           # build glibc-based initrd and static versions
17 %bcond_with     verbose         # verbose build
18 #
19 # Options below are useful, when you want fileutils and grep providing.
20 # For example, ash package requires fileutils and grep.
21 %bcond_with     fileutl_prov    # adds fileutils providing
22 %bcond_with     grep_prov       # adds grep providing
23 # Option below is useful, when busybox is built with shell support.
24 %bcond_with     sh_prov         # adds /bin/sh providing
25 # WARNING! Shell, fileutils and grep providing may depend on config file!
26 # Fileutils, grep and shell provided with busybox have not such
27 # functionality as their GNU countenders.
28 #
29 %ifnarch %{ix86} %{x8664} ppc
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common Unix utilities for embeded systems
33 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 # stable line only
37 Version:        1.15.2
38 Release:        1
39 License:        GPL
40 Group:          Applications
41 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
42 # Source0-md5:  d5653e5b74b17dbb1eeecda8b8f22c0a
43 Source1:        %{name}.config
44 Source2:        %{name}-initrd.config
45 %{?with_altconfig:Source3:      %{cfgfile}}
46 Patch1:         %{name}-logconsole.patch
47 Patch2:         %{name}-printf-gettext.patch
48 Patch3:         %{name}-loadfont.patch
49 Patch4:         %{name}-kernel_headers.patch
50 Patch5:         %{name}-insmod-morearchs.patch
51 Patch6:         %{name}-dhcp.patch
52 Patch7:         %{name}-fix_64_archs.patch
53 Patch9:         %{name}-ash-export-PATH.patch
54 URL:            http://www.busybox.net/
55 BuildRequires:  gcc >= 3.2
56 BuildRequires:  perl-tools-pod
57 BuildRequires:  rpmbuild(macros) >= 1.333
58 %if %{with initrd} || %{with static}
59         %if %{with dietlibc}
60 BuildRequires:  dietlibc-static
61         %else
62                 %if %{with glibc}
63 BuildRequires:  glibc-static
64                 %else
65 %if "%{_target_base_arch}" != "%{_arch}"
66 BuildRequires:  cross%{_target_base_arch}-uClibc-static
67 %else
68         %ifarch ppc %{x8664}
69 BuildRequires:  uClibc-static >= 3:0.9.30.1
70         %else
71 BuildRequires:  uClibc-static >= 3:0.9.30.1
72         %endif
73 %endif
74                 %endif
75         %endif
76 %endif
77 %{?with_fileutl_prov:Provides:  fileutils}
78 %{?with_grep_prov:Provides:     grep}
79 %{?with_sh_prov:Provides:       /bin/sh}
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %define         _bindir         /bin
83
84 %if "%{_target_base_arch}" != "%{_arch}"
85         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
86 %else
87         %define CrossOpts %{nil}
88 %endif
89
90 %define         filterout_ld    -Wl,-z,(combreloc|relro)
91
92 %description
93 BusyBox combines tiny versions of many common UNIX utilities into a
94 single small executable. It provides minimalist replacements for most
95 of the utilities you usually find in fileutils, shellutils, findutils,
96 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
97 POSIX environment for any small or embedded system. The utilities in
98 BusyBox generally have fewer options than their full-featured GNU
99 cousins; however, the options that are included provide the expected
100 functionality and behave very much like their GNU counterparts.
101
102 BusyBox has been written with size-optimization and limited resources
103 in mind. It is also extremely modular so you can easily include or
104 exclude commands (or features) at compile time. This makes it easy to
105 customize your embedded systems. To create a working system, just add
106 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
107 ae).
108
109 %description -l pl.UTF-8
110 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
111 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
112 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
113 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
114 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
115 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
116 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
117 (np. elvis-tiny albo ae).
118
119 %description -l pt_BR.UTF-8
120 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
121 executável, fornecendo substitutos minimalistas para muitos dos
122 executáveis encontrados em pacotes como fileutils, shellutils,
123 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
124 em geral têm menos opções que os utilitários GNU, mas as opções
125 implementadas comportam-se de maneira similar aos equivalentes GNU.
126
127 %package static
128 Summary:        Static busybox
129 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
130 Group:          Applications
131
132 %description static
133 Static busybox.
134
135 %description static -l pl.UTF-8
136 Statycznie skonsolidowany busybox.
137
138 %package initrd
139 Summary:        Static busybox for initrd
140 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
141 Group:          Applications
142 Conflicts:      geninitrd < 10000.10
143
144 %description initrd
145 Static busybox for initrd.
146
147 %description initrd -l pl.UTF-8
148 Statycznie skonsolidowany busybox dla initrd.
149
150 %prep
151 %setup -q
152 %patch1 -p1
153 %patch2 -p1
154 %patch3 -p1
155 %patch4 -p1
156 %patch5 -p1
157 %patch6 -p1
158 %patch7 -p1
159 %patch9 -p1
160
161 %build
162 install -d built
163 %if %{with initrd}
164 install %{SOURCE2} .config
165 %{__make} oldconfig
166 %{__make} \
167         %{?with_verbose:V=1} \
168         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
169         LDFLAGS="%{ld_rpmldflags} -static" \
170 %if %{with dietlibc}
171         LIBRARIES="-lrpc" \
172         CC="diet %{__cc}"
173 %else
174 %if %{with glibc}
175         %{CrossOpts} \
176         CC="%{__cc}"
177 %else
178     %if "%{_target_base_arch}" != "%{_arch}"
179         CROSS="%{_target_cpu}-uclibc-" \
180     %endif
181         CC="%{_target_cpu}-uclibc-gcc"
182 %endif
183 %endif
184
185 mv -f busybox built/busybox.initrd
186 %{__make} clean
187 %endif
188
189
190 %if %{with altconfig}
191 install %{SOURCE3} .config
192 %else
193 install %{SOURCE1} .config
194 %endif
195
196 %if %{with static}
197 %{__make} oldconfig
198 %{__make} \
199         %{?with_verbose:V=1} \
200         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
201         LDFLAGS="%{ld_rpmldflags} -static" \
202 %if %{with dietlibc}
203         LIBRARIES="-lrpc" \
204         CC="diet %{__cc}"
205 %else
206 %if %{with glibc}
207         %{CrossOpts} \
208         CC="%{__cc}"
209 %else
210     %if "%{_target_base_arch}" != "%{_arch}"
211         CROSS="%{_target_cpu}-uclibc-" \
212     %endif
213         CC="%{_target_cpu}-uclibc-gcc"
214 %endif
215 %endif
216
217 mv -f busybox built/busybox.static
218 %{__make} clean
219 %endif
220
221 %{__make} oldconfig
222 %{__make} \
223         %{?with_verbose:V=1} \
224         %{CrossOpts} \
225         CFLAGS_EXTRA="%{rpmcflags}" \
226         LDFLAGS="%{ld_rpmldflags}" \
227         CC="%{__cc}"
228 %{__make} busybox.links docs/BusyBox.1
229
230 %install
231 rm -rf $RPM_BUILD_ROOT
232 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
233
234 %{?with_static:install built/busybox.static $RPM_BUILD_ROOT%{_bindir}}
235 %if %{with initrd}
236 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
237 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/initrd-busybox
238 %endif
239
240 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
241 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
242 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
243
244 # install links to busybox binary, when linkfl is defined
245 %if %{with linkfl}
246 %{__make} install \
247         PREFIX=$RPM_BUILD_ROOT
248 %else
249 install busybox $RPM_BUILD_ROOT%{_bindir}
250 %endif
251
252 %clean
253 rm -rf $RPM_BUILD_ROOT
254
255 %files
256 %defattr(644,root,root,755)
257 %doc AUTHORS README .config
258
259 %if %{with linkfl}
260 %attr(755,root,root) /bin/*
261 %attr(755,root,root) /sbin/*
262 %attr(755,root,root) %{_bindir}/*
263 %attr(755,root,root) %{_sbindir}/*
264 %else
265 %attr(755,root,root) %{_bindir}/busybox
266 %endif
267
268 %{_libdir}/busybox
269 %{_mandir}/man1/*
270
271 %if %{with static}
272 %files static
273 %defattr(644,root,root,755)
274 %attr(755,root,root) %{_bindir}/busybox.static
275 %endif
276
277 %if %{with initrd}
278 %files initrd
279 %defattr(644,root,root,755)
280 %attr(755,root,root) %{_libdir}/initrd/initrd-busybox
281 %endif
This page took 0.081191 seconds and 2 git commands to generate.