]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- 1.01
[packages/busybox.git] / busybox.spec
1 #
2 # TODO:
3 #       - sparc64 modules support in sparc(32) version
4 #       - make internal commands work even if busybox is not in /bin/busybox
5
6 #
7 # Conditional build:
8 # alternative busybox config file (replaces default one) you should
9 # define cfgfile macro, i.e.
10 #
11 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
12 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
13 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
14 # Options below are useful, when you want fileutils and grep providing.
15 # For example, ash package requires fileutils and grep.
16 %bcond_with     fileutl_prov    # adds fileutils providing
17 %bcond_with     grep_prov       # adds grep providing
18 # Option below is useful, when busybox is built with shell support.
19 %bcond_with     sh_prov         # adds /bin/sh providing
20 # WARNING! Shell, filetuils and grep providing may depend on config file!
21 # Fileutils, grep and shell provided with busybox have not such
22 # functionality as their GNU countenders.
23 #
24 %bcond_without  static          # don't build static version
25 %bcond_without  initrd          # don't build initrd version
26 %bcond_with     dietlibc        # build dietlibc-based initrd version
27 %bcond_with     glibc           # build glibc-based initrd version
28 #
29 %ifnarch %{ix86}
30 %define with_glibc 1
31 %endif
32 Summary:        Set of common unix utils for embeded systems
33 Summary(pl):    Zestaw narzêdzi uniksowych dla systemów wbudowanych
34 Summary(pt_BR): BusyBox é um conjunto de utilitários UNIX em um único binário
35 Name:           busybox
36 Version:        1.01
37 Release:        1
38 License:        GPL
39 Group:          Applications
40 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
41 # Source0-md5:  f250842dae2854a38470ed16a46bba66
42 Source1:        %{name}.config
43 Source2:        %{name}-initrd.config
44 %{?with_altconfig:Source3:      %{cfgfile}}
45 Patch0:         %{name}-logconsole.patch
46 Patch1:         %{name}-printf-gettext.patch
47 Patch2:         %{name}-loadfont.patch
48 Patch3:         %{name}-pivot_root.patch
49 Patch4:         %{name}-raid_start.patch
50 Patch5:         %{name}-force-dietlibc.patch
51 Patch6:         %{name}-ash_exec.patch
52 Patch7:         %{name}-kernel_headers.patch
53 Patch8:         %{name}-insmod-morearchs.patch
54 Patch9:         %{name}-dhcp.patch
55 Patch10:        %{name}-switchroot.patch
56 Patch11:        %{name}-fix_64_archs.patch
57 Patch12:        %{name}-LFS.patch
58 Patch13:        %{name}-ftpput.patch
59 #http://www.zelow.no/floppyfw/download/Development/Patches/busybox-snapshot/busybox-lzmacat.diff
60 Patch14:        %{name}-lzmacat.diff
61 URL:            http://www.busybox.net/
62 BuildRequires:  gcc >= 3.2
63 %{?with_static:BuildRequires:   glibc-static}
64 %if %{with initrd}
65         %if %{with dietlibc}
66 BuildRequires:  dietlibc-static
67         %else
68                 %if %{with glibc}
69 BuildRequires:  glibc-static
70                 %else
71 BuildRequires:  uClibc-static >= 0.9.21
72                 %endif
73         %endif
74 %endif
75 %{?with_fileutl_prov:Provides:  fileutils}
76 %{?with_grep_prov:Provides:     grep}
77 %{?with_sh_prov:Provides:       /bin/sh}
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80
81 %define         _bindir         /bin
82 %define         _initrd_bindir  /bin
83
84 %description
85 BusyBox combines tiny versions of many common UNIX utilities into a
86 single small executable. It provides minimalist replacements for most
87 of the utilities you usually find in fileutils, shellutils, findutils,
88 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
89 POSIX environment for any small or embedded system. The utilities in
90 BusyBox generally have fewer options than their full-featured GNU
91 cousins; however, the options that are included provide the expected
92 functionality and behave very much like their GNU counterparts.
93
94 BusyBox has been written with size-optimization and limited resources
95 in mind. It is also extremely modular so you can easily include or
96 exclude commands (or features) at compile time. This makes it easy to
97 customize your embedded systems. To create a working system, just add
98 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
99 ae).
100
101 %description -l pl
102 BusyBox sk³ada ma³e wersje wielu narzêdzi uniksowych w jeden ma³y plik
103 wykonywalny. Zapewnia minimalne zastêpniki wiêkszo¶ci narzêdzi
104 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
105 tar itp. BusyBox daje w miarê kompletne ¶rodowisko POSIX dla ma³ych
106 lub wbudowanych systemów. Narzêdzia maj± mniej opcji ni¿ ich pe³ne
107 odpowiedniki GNU, ale maj± podstawow± funkcjonalno¶æ. Do dzia³aj±cego
108 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
109 (np. elvis-tiny albo ae).
110
111 %description -l pt_BR
112 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
113 executável, fornecendo substitutos minimalistas para muitos dos
114 executáveis encontrados em pacotes como fileutils, shellutils,
115 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
116 em geral têm menos opções que os utilitários GNU, mas as opções
117 implementadas comportam-se de maneira similar aos equivalentes GNU.
118
119 %package static
120 Summary:        Static busybox
121 Summary(pl):    Statycznie skonsolidowany busybox
122 Group:          Applications
123
124 %description static
125 Static busybox.
126
127 %description static -l pl
128 Statycznie skonsolidowany busybox.
129
130 %package initrd
131 Summary:        Static busybox for initrd
132 Summary(pl):    Statycznie skonsolidowany busybox dla initrd
133 Group:          Applications
134 Conflicts:      geninitrd < 3075
135
136 %description initrd
137 Static busybox for initrd.
138
139 %description initrd -l pl
140 Statycznie skonsolidowany busybox dla initrd.
141
142 %prep
143 %setup -q
144 %patch0 -p1
145 %patch1 -p1
146 %patch2 -p1
147 %patch3 -p1
148 %patch4 -p1
149 %patch5 -p1
150 %patch6 -p1
151 %patch7 -p1
152 %patch8 -p1
153 %patch9 -p1
154 %patch10 -p1
155 %patch11 -p1
156 %patch12 -p1
157 %patch13 -p1
158 %patch14 -p1
159
160 %build
161 install %{SOURCE1} .config
162
163 %if %{with initrd}
164 install %{SOURCE2} .config
165 %{__make} oldconfig
166 %{__make} \
167         CFLAGS_EXTRA="%{rpmcflags} -D_BSD_SOURCE" \
168         LDFLAGS="%{rpmldflags} -static" \
169 %if %{with dietlibc}
170         LIBRARIES="-lrpc" \
171         CC="diet gcc"
172 %else
173 %if %{with glibc}
174         CC="%{__cc}"
175 %else
176         CC="%{_target_cpu}-uclibc-gcc"
177 %endif
178 %endif
179
180 mv -f busybox busybox.initrd
181 %{__make} clean
182 install %{SOURCE1} .config
183 %endif
184
185 %if %{with altconfig}
186 install %{SOURCE3} .config
187 %endif
188
189 %if %{with static}
190 %{__make} oldconfig
191 %{__make} \
192         CFLAGS_EXTRA="%{rpmcflags}" \
193         LDFLAGS="%{rpmldflags} -static" \
194         CC="%{__cc}"
195 mv -f busybox busybox.static
196 %{__make} clean
197 %endif
198
199 %{__make} oldconfig
200 %{__make} \
201         CFLAGS_EXTRA="%{rpmcflags}" \
202         LDFLAGS="%{rpmldflags}" \
203         CC="%{__cc}"
204
205 %install
206 rm -rf $RPM_BUILD_ROOT
207 install -d $RPM_BUILD_ROOT{%{_initrd_bindir},%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
208
209 %{?with_static:install busybox.static $RPM_BUILD_ROOT%{_bindir}}
210 %{?with_initrd:install busybox.initrd $RPM_BUILD_ROOT%{_initrd_bindir}/initrd-busybox}
211
212 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
213 install docs/BusyBox.1 $RPM_BUILD_ROOT%{_mandir}/man1
214 echo ".so BusyBox.1" > $RPM_BUILD_ROOT%{_mandir}/man1/busybox.1
215
216 # install links to busybox binary, when linkfl is defined
217 %if %{with linkfl}
218 %{__make} install \
219         PREFIX=$RPM_BUILD_ROOT
220 %else
221 install busybox $RPM_BUILD_ROOT%{_bindir}
222 %endif
223
224 %clean
225 rm -rf $RPM_BUILD_ROOT
226
227 %files
228 %defattr(644,root,root,755)
229 %doc AUTHORS README .config
230
231 %if %{with linkfl}
232 %attr(755,root,root) /bin/*
233 %attr(755,root,root) /sbin/*
234 %attr(755,root,root) %{_bindir}/*
235 %attr(755,root,root) %{_sbindir}/*
236 %else
237 %attr(755,root,root) %{_bindir}/busybox
238 %endif
239
240 %{_libdir}/busybox
241 %{_mandir}/man1/*
242
243 %if %{with static}
244 %files static
245 %defattr(644,root,root,755)
246 %attr(755,root,root) %{_bindir}/busybox.static
247 %endif
248
249 %if %{with initrd}
250 %files initrd
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_initrd_bindir}/initrd-busybox
253 %endif
This page took 0.089871 seconds and 3 git commands to generate.