]> git.pld-linux.org Git - packages/busybox.git/blob - busybox.spec
- updated to 1.23.2
[packages/busybox.git] / busybox.spec
1 # TODO:
2 # - review patch 3. Updated to 1.17.3, but the code changed so much it's unclear
3 #   if it still serves a purpose
4 # - sparc64 modules support in sparc(32), x86_64 modules support in i386 version
5 # - make internal commands work even if busybox is not in /bin/busybox (initrd)
6 #   or when /proc is not mounted (static / normal)
7 #
8 # Conditional build:
9 # alternative busybox config file (replaces default one) you should
10 # define cfgfile macro, i.e.
11 #
12 #       rpm --rebuild busybox.*.src.rpm --with altconfig --define "cfgfile bb-emb-config.h"
13 #
14 %bcond_with     altconfig       # use alternative config (defined by cfgfile)
15 %bcond_with     linkfl          # creates links to busybox binary and puts them into file list
16 %bcond_without  dynamic         # don't build dynamic (base) version
17 %bcond_without  static          # don't build static version
18 %bcond_without  initrd          # don't build initrd version
19 %bcond_with     dietlibc        # build dietlibc-based initrd and static versions
20 %bcond_with     glibc           # build glibc-based initrd and static versions
21 %bcond_without  verbose         # verbose build
22 # Options below are useful, when you want fileutils and grep providing.
23 # For example, ash package requires fileutils and grep.
24 %bcond_with     fileutl_prov    # adds fileutils providing
25 %bcond_with     grep_prov       # adds grep providing
26 # Option below is useful, when busybox is built with shell support.
27 %bcond_with     sh_prov         # adds /bin/sh providing
28 # WARNING! Shell, fileutils and grep providing may depend on config file!
29 # Fileutils, grep and shell provided with busybox have not such
30 # functionality as their GNU countenders.
31 #
32 %ifnarch %{ix86} %{x8664} ppc
33 %define         with_glibc      1
34 %endif
35 %ifarch x32
36 # until uClibc builds on x32
37 %undefine       with_static
38 %endif
39 Summary:        Set of common Unix utilities for embeded systems
40 Summary(pl.UTF-8):      Zestaw narzędzi uniksowych dla systemów wbudowanych
41 Summary(pt_BR.UTF-8):   BusyBox é um conjunto de utilitários UNIX em um único binário
42 Name:           busybox
43 # stable line only
44 Version:        1.23.2
45 Release:        1
46 License:        GPL v2
47 Group:          Applications
48 Source0:        http://www.busybox.net/downloads/%{name}-%{version}.tar.bz2
49 # Source0-md5:  7925683d7dd105aabe9b6b618d48cc73
50 Source1:        %{name}.config
51 Source2:        %{name}-initrd.config
52 %{?with_altconfig:Source3:      %{cfgfile}}
53 Patch0:         x32.patch
54 Patch1:         %{name}-logconsole.patch
55 Patch2:         %{name}-printf-gettext.patch
56 Patch3:         %{name}-loadfont.patch
57 Patch4:         %{name}-kernel_headers.patch
58 Patch5:         %{name}-insmod-morearchs.patch
59 Patch6:         %{name}-dhcp.patch
60 Patch7:         %{name}-fix_64_archs.patch
61 Patch9:         %{name}-ash-export-PATH.patch
62 URL:            http://www.busybox.net/
63 BuildRequires:  gcc >= 3.2
64 BuildRequires:  perl-tools-pod
65 BuildRequires:  rpmbuild(macros) >= 1.652
66 %if %{with initrd} || %{with static}
67         %if %{with dietlibc}
68 BuildRequires:  dietlibc-static
69         %else
70                 %if %{with glibc}
71 BuildRequires:  glibc-static
72                 %else
73 %if "%{_target_base_arch}" != "%{_host_base_arch}"
74 BuildRequires:  cross%{_target_base_arch}-uClibc-static
75 %else
76         %ifarch ppc %{x8664}
77 BuildRequires:  uClibc-static >= 3:0.9.30.1
78         %else
79 BuildRequires:  uClibc-static >= 3:0.9.30.1
80         %endif
81 %endif
82                 %endif
83         %endif
84 %endif
85 %{?with_sh_prov:Provides:       /bin/sh}
86 %{?with_fileutl_prov:Provides:  fileutils}
87 %{?with_grep_prov:Provides:     grep}
88 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
89
90 %define         _bindir         /bin
91
92 %if "%{_target_base_arch}" != "%{_host_base_arch}"
93         %define CrossOpts CROSS="%{_target_cpu}-pld-linux-"
94 %else
95         %define CrossOpts %{nil}
96 %endif
97
98 %define         filterout_ld    -Wl,-z,(combreloc|relro)
99
100 %description
101 BusyBox combines tiny versions of many common UNIX utilities into a
102 single small executable. It provides minimalist replacements for most
103 of the utilities you usually find in fileutils, shellutils, findutils,
104 textutils, grep, gzip, tar, etc. BusyBox provides a fairly complete
105 POSIX environment for any small or embedded system. The utilities in
106 BusyBox generally have fewer options than their full-featured GNU
107 cousins; however, the options that are included provide the expected
108 functionality and behave very much like their GNU counterparts.
109
110 BusyBox has been written with size-optimization and limited resources
111 in mind. It is also extremely modular so you can easily include or
112 exclude commands (or features) at compile time. This makes it easy to
113 customize your embedded systems. To create a working system, just add
114 a kernel, a shell (such as ash), and an editor (such as elvis-tiny or
115 ae).
116
117 %description -l pl.UTF-8
118 BusyBox składa małe wersje wielu narzędzi uniksowych w jeden mały plik
119 wykonywalny. Zapewnia minimalne zastępniki większości narzędzi
120 zawartych w pakietach fileutils, shellutils, findutils, grep, gzip,
121 tar itp. BusyBox daje w miarę kompletne środowisko POSIX dla małych
122 lub wbudowanych systemów. Narzędzia mają mniej opcji niż ich pełne
123 odpowiedniki GNU, ale mają podstawową funkcjonalność. Do działającego
124 systemu potrzeba jeszcze tylko kernela, shella (np. ash) oraz edytora
125 (np. elvis-tiny albo ae).
126
127 %description -l pt_BR.UTF-8
128 BusyBox combina versões reduzidas de muitos utilitários UNIX num único
129 executável, fornecendo substitutos minimalistas para muitos dos
130 executáveis encontrados em pacotes como fileutils, shellutils,
131 findutils, textutils, grep, gzip, tar, etc. Os utilitários do BusyBox
132 em geral têm menos opções que os utilitários GNU, mas as opções
133 implementadas comportam-se de maneira similar aos equivalentes GNU.
134
135 %package static
136 Summary:        Static busybox
137 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox
138 Group:          Applications
139
140 %description static
141 Static busybox.
142
143 %description static -l pl.UTF-8
144 Statycznie skonsolidowany busybox.
145
146 %package initrd
147 Summary:        Static busybox for initrd
148 Summary(pl.UTF-8):      Statycznie skonsolidowany busybox dla initrd
149 Group:          Base
150 Conflicts:      geninitrd < 10000.20
151
152 %description initrd
153 Static busybox for initrd.
154
155 %description initrd -l pl.UTF-8
156 Statycznie skonsolidowany busybox dla initrd.
157
158 %prep
159 %setup -q
160 %patch0 -p1
161 %patch1 -p1
162 %patch2 -p1
163 #%patch3 -p1
164 %patch4 -p1
165 %patch5 -p1
166 %patch6 -p1
167 %patch7 -p1
168 %patch9 -p1
169
170 %build
171 install -d built
172 %if %{with initrd}
173 install %{SOURCE2} .config
174 %{__make} oldconfig
175 %{__make} \
176         %{?with_verbose:V=1} \
177         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
178         LDFLAGS="%{rpmldflags} -static" \
179 %if %{with dietlibc}
180         LIBRARIES="-lrpc" \
181         CC="diet %{__cc}"
182 %else
183 %if %{with glibc}
184         %{CrossOpts} \
185         CC="%{__cc}"
186 %else
187         %if "%{_target_base_arch}" != "%{_host_base_arch}"
188         CROSS="%{_target_cpu}-uclibc-" \
189         %endif
190         CC="%{_target_cpu}-uclibc-gcc"
191 %endif
192 %endif
193
194 mv -f busybox built/busybox.initrd
195 %{__make} clean
196 %endif
197
198 %if %{with altconfig}
199 install %{SOURCE3} .config
200 %else
201 install %{SOURCE1} .config
202 %endif
203
204 %if %{with static}
205 %{__make} oldconfig
206 %{__make} \
207         %{?with_verbose:V=1} \
208         CROSS_CFLAGS="%{rpmcflags} -Os -D_BSD_SOURCE" \
209         LDFLAGS="%{rpmldflags} -static" \
210 %if %{with dietlibc}
211         LIBRARIES="-lrpc" \
212         CC="diet %{__cc}"
213 %else
214 %if %{with glibc}
215         %{CrossOpts} \
216         CC="%{__cc}"
217 %else
218         %if "%{_target_base_arch}" != "%{_host_base_arch}"
219         CROSS="%{_target_cpu}-uclibc-" \
220         %endif
221         CC="%{_target_cpu}-uclibc-gcc"
222 %endif
223 %endif
224
225 mv -f busybox built/busybox.static
226 %{__make} clean
227 %endif
228
229 %if %{with dynamic}
230 %{__make} oldconfig
231 %{__make} \
232         %{?with_verbose:V=1} \
233         %{CrossOpts} \
234         CFLAGS_EXTRA="%{rpmcflags}" \
235         LDFLAGS="%{rpmldflags}" \
236         CC="%{__cc}"
237 %{__make} busybox.links docs/busybox.1
238 %endif
239
240 %install
241 rm -rf $RPM_BUILD_ROOT
242
243 %if %{with static}
244 install -d $RPM_BUILD_ROOT%{_bindir}
245 install built/busybox.static $RPM_BUILD_ROOT%{_bindir}
246 %endif
247
248 %if %{with initrd}
249 install -d $RPM_BUILD_ROOT%{_libdir}/initrd
250 install built/busybox.initrd $RPM_BUILD_ROOT%{_libdir}/initrd/busybox
251 %endif
252
253 %if %{with dynamic}
254 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_libdir}/busybox}
255 install busybox.links $RPM_BUILD_ROOT%{_libdir}/busybox
256 install docs/busybox.1 $RPM_BUILD_ROOT%{_mandir}/man1
257
258 # install links to busybox binary, when linkfl is defined
259 %if %{with linkfl}
260 %{__make} install \
261         PREFIX=$RPM_BUILD_ROOT
262 %else
263 install busybox $RPM_BUILD_ROOT%{_bindir}
264 %endif
265 %endif
266
267 %clean
268 rm -rf $RPM_BUILD_ROOT
269
270 %if %{with dynamic}
271 %files
272 %defattr(644,root,root,755)
273 %doc AUTHORS README .config
274
275 %if %{with linkfl}
276 %attr(755,root,root) /bin/*
277 %attr(755,root,root) /sbin/*
278 %attr(755,root,root) %{_bindir}/*
279 %attr(755,root,root) %{_sbindir}/*
280 %else
281 %attr(755,root,root) %{_bindir}/busybox
282 %endif
283
284 %{_libdir}/busybox
285 %{_mandir}/man1/busybox.1*
286 %endif
287
288 %if %{with static}
289 %files static
290 %defattr(644,root,root,755)
291 %attr(755,root,root) %{_bindir}/busybox.static
292 %endif
293
294 %if %{with initrd}
295 %files initrd
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/initrd/busybox
298 %endif
This page took 0.055965 seconds and 3 git commands to generate.